Jump to content

NitroDatsik

Member
  • Content count

    1,119
  • Joined

  • Last visited

Community Reputation

433 Excellent

1 Follower

About NitroDatsik

  • Rank
    Senior Enthusiast
  • Birthday 04/23/1991

Profile Information

  • Name
    Jorge
  • Location
    Houston, TX
  • Gender
    Male
  • Drives
    2014 Silverado Crew Cab (summit white)

Recent Profile Visitors

13,469 profile views
  1. Yes is possible, is not completely plug and play Sent from my LG-H918 using Tapatalk
  2. I agree with you that the video quality does seem a bit lacking in quality lol. My gf 15 focus on the tiny screen has a better image. Sent from my LG-H918 using Tapatalk
  3. Here's my install video Sent from my LG-H918 using Tapatalk
  4. When connecting to the clock spring harness, you mean from the steering wheel to the clock spring? Pretty much on the steering wheel harness? Sent from my LG-H918 using Tapatalk
  5. Just fix it and works. The brown plug is easy to determine pin 26 for reverse power as is numbered there. Is one on a very corner. The green plug here's where you will find pin 5 as they are not numbered. Just hold the plug like it is on the pic and find the purple/yellow wire. There's 2 of each so make sure is the one on the pic Sent from my LG-H918 using Tapatalk
  6. It works. Need to solder now Sent from my LG-H918 using Tapatalk
  7. Phil they pretty much got a female plug that will connect to your camera, with all the pins on it. Then the harness goes to the bcm and 3 wires from the harness your supposed to connect to the bcm. One for power on reverse, one for auxiliary power and ground. Then 2 more wires are connected to a female video cable and run into the hmi. On the hmi they did a pigtail (factory Grey plug to hmi with every pin on it to a factory female plug with all pins and your stock harness Grey plug will plug there and in between the pigtail there's the 2 video cables coming out to male video cable that will plug into the one for the camera. I will post a video on here and YouTube. Sent from my LG-H918 using Tapatalk
  8. I got it to work. So many damn pins on the bcm, I was plugging into the green plug and what I thought was pin 5 with the same color wires purple/yello and it was totally across the other side. Sent from my LG-H918 using Tapatalk
  9. I just got my harness today, installed it and still nothing. It was late and dark so I will see if I can fix it tomorrow. The harness is real simple to install, so I need to re do everything to make sure I did everything right. I'm going to get rid of the truck taps and connect it directly then if it works ill solder the connections. Sent from my LG-H918 using Tapatalk
  10. They said they will most likely ship it today so hopefully I get it before the weekend. Sent from my LG-H918 using Tapatalk
  11. You only need to upgrade clockspring if your adding a heated steering wheel. If you are going from a work truck to one with steering wheel controls but not heated then you will be fine with your current one Sent from my LG-H918 using Tapatalk
  12. Have you check the fuse box in the engine bay to see if you didn't blow reverse fuse? Maybe is making bad connection where you splice wires together and it blew the fuse. Happened to me when I was working on mine. Also maybe it would have been good to use a diode on that connection there so the constant power won't flow to reverse lights. Maybe that also can have an impact in the fuse for reverse Sent from my LG-H918 using Tapatalk
  13. Gave in and bought the harness lol. I'm sure it was something simple that I didn't do to make it work, I just don't have enough much time to fiddle with it. Sent from my LG-H918 using Tapatalk
  14. Lol I'm trying to keep the cost down since i have other projects in progress. Saving to get my new gauge cluster reprogram and add steering wheel controls. Already did more then half the work on that. Sent from my LG-H918 using Tapatalk
  15. Lol but where's the fun in that. Did you purchase the camera from them aswell? I bought mine off Amazon so I take it all they do is hook up their harness to the cables that came off the camera under the bed and they never plug in to the rear junction block correct? Sent from my LG-H918 using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.