Jump to content

nicks2014sierra

Member
  • Content count

    19
  • Joined

  • Last visited

Community Reputation

1 Neutral

About nicks2014sierra

  • Rank
    Enthusiast

Profile Information

  • Location
    brooklyn ny
  • Drives
    2014 gmc sierra
  1. Is this the complete set Sent from my SM-G950U using Tapatalk
  2. Looking to put new Bilsteins on my 2014 GMC Sierra 1500 z71 does anyone have an exact part number for front and rears? Sent from my SM-G950U using Tapatalk
  3. If there is then what Sent from my SM-G935P using Tapatalk
  4. During a nutreal idal rooms fluctuate from 500 to 1000 with a rough rumble almost feels like truck wants to stall Sent from my SM-G935P using Tapatalk
  5. Anyone know why this is happening Sent from my SM-G935P using Tapatalk Is there a way to post videos here? Sent from my SM-G935P using Tapatalk
  6. I will be getting the part today will update you and let you know thanks for all the info Sent from my SM-G935P using Tapatalk
  7. These were all the codes Sent from my SM-G935P using Tapatalk
  8. 4.3 Sent from my SM-G935P using Tapatalk
  9. Where is it located Sent from my SM-G935P using Tapatalk
  10. Po496 is the code Po496 is the code Sent from my SM-G935P using Tapatalk
  11. What do you mean large or small Sent from my SM-G935P using Tapatalk
  12. Evap emessions leak and to lean bank 1 and 2 are the codes any ideas on a fix Sent from my SM-G935P using Tapatalk
  13. Rough ride

    Anyone have exact specs or product number of what I need for fronts and rears Sent from my SM-G935P using Tapatalk
  14. I have 50 k miles on it and my father in law owns a shop. He plugged it in yesterday and said it was running lean and had codes for 02 sensor Sent from my SM-G935P using Tapatalk
  15. I have a 2014 GMC Sierra I've noticed for a while now that it idles a little rough..But today the check engine light came on and I noticed the idle issue got worse to the point where it almost bogs out and once or twice when I start it up it bogs out immediately. Anyone else experience this? If so what were the issues and fix? Sent from my SM-G935P using Tapatalk
×

Important Information

By using this site, you agree to our Terms of Use.