Jump to content

aricketts

Member
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About aricketts

  • Rank
    Enthusiast

Profile Information

  • Name
    GMC Sierra
  • Location
    Corner Brook, Newfoundland, Canada
  • Drives
    2016 GMC Sierra All-Terrain
  1. It was not the alternator after all. It was the vacuum pump. Sent from my Moto G (4) using Tapatalk
  2. Thanks, I'll check into it. That sounds fairly drastic for a newer truck. Good stuff. Sent from my Moto G (4) using Tapatalk
  3. The dealer/warranty is not a solution where I live unfortunately. Sent from my Moto G (4) using Tapatalk
  4. Thanks for that, it does match a lot of the symptoms described there. Strange that it only started doing it the last 2 days after 65,000 kms and a second winter though. Other than that, it does sound similar. I'll see tomorrow when the temperature hits 10 degrees. Sent from my Moto G (4) using Tapatalk
  5. Hey fellas, I've been noticing a whining noise coming out of the front-left side of my truck over the last few days. It's been colder lately, around -6°C or so. It sounds identical to a power steering pump that's low on fluid or on it's way out. However, the truck has electronic power steering and does not use fluid. Has anyone here noticed a whining type of sound that increases with engine RPM and figured out what's going on? It somewhat comes and goes, but generally is very noticeable all the time. Would rather figure it out before whatever is causing the sound inevitably gives out or falls apart. Thanks,
×

Important Information

By using this site, you agree to our Terms of Use.