Jump to content



Photo
- - - - -

Bad Fuel Pump In 99 Tahoe 5.7?


  • Please log in to reply
9 replies to this topic

#1 BillPet

BillPet

    Enthusiast

  • Member
  • 37 posts

Posted 06 December 2009 - 05:34 PM

OK guys, I've been chasing a problem in my Tahoe. I've heard alot of possibilities but now it does look to be the fuel pump. The vehicle has given me problems starting and it began on cold damp days so I suspected electrical problems. Replaced cap and rotor, pulled the alternator, had it tested and is OK. I replaced the battery first as I'd worn it down trying to start it and the battery was past warranty period. Oddly enough, it started right up with a new battery and gave me no trouble for about two or three weeks, then back to same old crap. I've taken every electrical sensor that I can find apart and made sure they were clean and added a smidge of dialectric grease.

I was reading some old posts about 5.7's not firing or giving intermittent starting problems and one of them was about the fuel pump. It talked about the smack test, hitting the bottom of the gas tank and then the vehicle will start. I did this today and the damn thing started, ran and drove to town and back. Started just fine again after getting home. The vehicle has 159k miles on it, actually runs and drives great when it runs, burns no oil, everything works except the antilock brakes, which are not a big issue to me, nice but I drove for nearly 40 years without them.

Anyway, what the hell is going on here? Does this mean the fuel pump is bad and if so, how does beating on the gas tank make it work? Is there just something sticking that banging on it makes it work temporarily? I had this fuel pump put in about 40k miles ago and it did impress me as one cheap little piece of junk that cost me about $275. I believe it is some kind of aftermarket item as the mechanic told me I didn't want to pay for an OEM and he was saving me money. I think he just got to put more in his pocket, not mine. Virtually everything on this truck is bone stock and at least almost everything is actual GM parts.

So what's with this fuel pump? Do I need to replace it? Thanks,

Bill

#2 txab

txab

    Your worst fWONking nightmare

  • Moderator
  • 8,770 posts
  • Location:Texas
  • Gender:Male
  • Drives:2014 GMC Sierra

Posted 06 December 2009 - 08:28 PM

Have you taken pressure readings from your pump? Also, have you checked or replaced the fuel pressure regulator?

100_0955-1-1-1.jpg
"When the people find they can vote themselves money, that will herald the end of the republic."
-- Benjamin Franklin

bbp.pngsynad.pngAdamslogo3_zpsc74f7e65.png


#3 BillPet

BillPet

    Enthusiast

  • Member
  • 37 posts

Posted 06 December 2009 - 09:14 PM

Have you taken pressure readings from your pump? Also, have you checked or replaced the fuel pressure regulator?

No, I haven't checked the pressure, I don't have a gauge but was planning to borrow one tomorrow. Today was the first time it's run in about a week and had absolutely nothing but a sputter here and there until I smacked the gas tank.

I spun it over yesterday and checked the valve where you read the pressure, had no fuel at all. This got me reading more about what I may have and found the stuff on beating on the gas tank. I had wondered about the fuel pump as it acted this way when I had a new one put in the last time but thought that mine was too new to go out again. Maybe not but I don't get what is going on that we can jar it and make it work again. I will check the pressure as soon as I get my hands on a gauge.

I looked at the threads (posts) on the pressure regulator. Isn't that the fun one that you have to tear the motor apart to get to? If it was easier to get at, I'd have changed it already.

Bill

#4 sparkstech

sparkstech

    Senior Enthusiast

  • Member
  • 1,722 posts
  • Location:Northern Illinois
  • Gender:Male

Posted 06 December 2009 - 10:17 PM

Anyway, what the hell is going on here? Does this mean the fuel pump is bad and if so, how does beating on the gas tank make it work? Is there just something sticking that banging on it makes it work temporarily?


The pump is a motor just like a starter. When a winding goes bad you can bounce off the bad spot by smacking it. It get's to a perfect spot where it won't carry the current needed to start moving, you move it a little by smacking it and it moves to a spot that will carry the current. Once moving one dead spot will not be noticeable unless you have a lab scope on the circuit.

If you had absolutely no fuel and smacked the tank and got fuel immediately it's a pretty safe be that you need a pump.
The tech who thinks he knows it all hasn't begun to learn.
and
If at first you don't succeed suc harder.

#5 BillPet

BillPet

    Enthusiast

  • Member
  • 37 posts

Posted 07 December 2009 - 09:56 AM

Anyway, what the hell is going on here? Does this mean the fuel pump is bad and if so, how does beating on the gas tank make it work? Is there just something sticking that banging on it makes it work temporarily?


The pump is a motor just like a starter. When a winding goes bad you can bounce off the bad spot by smacking it. It get's to a perfect spot where it won't carry the current needed to start moving, you move it a little by smacking it and it moves to a spot that will carry the current. Once moving one dead spot will not be noticeable unless you have a lab scope on the circuit.

If you had absolutely no fuel and smacked the tank and got fuel immediately it's a pretty safe be that you need a pump.

Thanks, seems logical enough and I'd have to agree that this points to the pump. Now, there are many to choose from with prices from around $100 to around $300. Obviously, some are going to be better than others. Is the Delco the only good one? Is it actually made by Delco?

I see you are in northern IL, where? I live in Roscoe, just curious, not trying to put you to work or anything. :uhoh:

Bill

#6 Rod R

Rod R

    Enthusiast

  • Member
  • 778 posts
  • Location:Saskatoon, SK Canada
  • Gender:Male

Posted 07 December 2009 - 10:57 AM

... some times the pumps fail to work because the contacts on the top of the tank become corroded, and then have 'no contact' at some positions.... the 'banging on the fuel tank' can get the truck going as the vibration from the impact can rotate the pump just enough to catch good contacts ... always change this part the pump assembly as well..... this could make you think that a brand new pump is no good

... the general wisdom on these replacement pumps is to get a Delco from the dealer, or a Delphi from somewhere like NAPA (Delphi was the OE pumps and since have been spun off to a separate company) ...

... Airtex and Carter also sell pumps for these trucks, but many people advise to stay away because of reliability issues (I have an Airtex replacement and it is working OK, but I had it put in BEFORE I read all these forums on fuel pump issues)
Rod Ramage, Saskatoon, Saskatchewan CANADA
1997 Chevrolet Cheyenne C2500 xcsb w/ 5.7L Vortec & 4L60E; 3.73 gears w/ G80 (231,000 km)

#7 BillPet

BillPet

    Enthusiast

  • Member
  • 37 posts

Posted 07 December 2009 - 12:07 PM

... some times the pumps fail to work because the contacts on the top of the tank become corroded, and then have 'no contact' at some positions.... the 'banging on the fuel tank' can get the truck going as the vibration from the impact can rotate the pump just enough to catch good contacts ... always change this part the pump assembly as well..... this could make you think that a brand new pump is no good

... the general wisdom on these replacement pumps is to get a Delco from the dealer, or a Delphi from somewhere like NAPA (Delphi was the OE pumps and since have been spun off to a separate company) ...

... Airtex and Carter also sell pumps for these trucks, but many people advise to stay away because of reliability issues (I have an Airtex replacement and it is working OK, but I had it put in BEFORE I read all these forums on fuel pump issues)

Thanks, I thought I'd heard the Delphi was OK too. Electrical contacts definately become a problem as our vehicles get older. I try to clean any that I find but there are a ton of them on these vehicles, especially if we have many electric options and I think I have them all. I'll check the ones along the harness to the tank and see if I can get at them. Under the truck takes a beating around here with wintertime salt use and just plain old age and moisture.

I've found several that claim to be OEM, maybe GM used a few? Or is this just BS?

Bill

#8 Rod R

Rod R

    Enthusiast

  • Member
  • 778 posts
  • Location:Saskatoon, SK Canada
  • Gender:Male

Posted 07 December 2009 - 01:49 PM

... OEM would be either Delco or Delphi
..... just to confuse things there is counterfeit stuff out there as well...
..... if you are concerned then either go to a dealer for the Delco or to a parts store like NAPA for the Delphi
Rod Ramage, Saskatoon, Saskatchewan CANADA
1997 Chevrolet Cheyenne C2500 xcsb w/ 5.7L Vortec & 4L60E; 3.73 gears w/ G80 (231,000 km)

#9 BillPet

BillPet

    Enthusiast

  • Member
  • 37 posts

Posted 07 December 2009 - 07:15 PM

... OEM would be either Delco or Delphi
..... just to confuse things there is counterfeit stuff out there as well...
..... if you are concerned then either go to a dealer for the Delco or to a parts store like NAPA for the Delphi

Thanks guys for all the info.

Bill

#10 MA87K5

MA87K5

    Enthusiast

  • Member
  • 81 posts
  • Location:Chicopee,Ma
  • Gender:Male

Posted 07 December 2009 - 08:00 PM

I heard that the delphi pumps are no good. I bought a bosch pump at advance autoparts w/lifetime warranty. For around $280. The only pump that comes with a lifetime warranty.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users