Jump to content

Archived

This topic is now archived and is closed to further replies.

leboyd

97 Tahoe 5.7 P0102 And P0340

Recommended Posts

My 97 started throwing the P0102 and P0340 codes. Since I had a problem with burnt wires before (laying against manifold), pealed back the covering and found what looked like a slight break in the red (?) wire. I spliced this back together and still have the code.

 

It seems if the MAF was out I'd get a different code and I assume the P0340 is a related code.

 

Any thoughts?

Larry

Share this post


Link to post
Share on other sites
the p0340 code is a "camshaft position sensor circuit malfunction", here's a link to a site with some info on what may have cause this.

 

Yes, I was aware of what the codes were - but THANKS for the link. It had some additional information that may help.

Share this post


Link to post
Share on other sites
the p0340 code is a "camshaft position sensor circuit malfunction", here's a link to a site with some info on what may have cause this.

 

Yes, I was aware of what the codes were - but THANKS for the link. It had some additional information that may help.

 

 

Looks like there is 0v at high-power side of the MAF wiring harness. I looked at all the fuses on the door panel and all tested good.

 

Anyone have an idea of where the fuse to the MAF is?

Share this post


Link to post
Share on other sites

ADSENSE FOOTER
  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.