Jump to content



Photo
- - - - -

2009 Sierra Sle Rough Idle


  • Please log in to reply
14 replies to this topic

#1 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 14 November 2010 - 03:48 PM

I have an 09 Sierra Sle Ex Cab with 27000km on it. The only modification I've done is installing a GMPP CAI. Since winter is coming on, I notice the truck is having a rough idle in park. The engine will dip as low as 500RPM from the normal 750RPM and I can noticbly see my headlights dim if they're turned on. No stalling though. In gear, it has a rough idle when stopped, but when I'm giving it gas, everything works just fine.

My voltometer reads in the middle, but my oil pressure fluctuates with the engine as the idle slows/speeds up.

I checked the CAI for any leaks and didin't find any, and I filled up the truck today as the gas was low and about 4 weeks old. I also added gas line antifreeze/fuel system cleaner to see if that helps. Should I wait a few days and see if it fixes itself, or should I schedule an appointment at the deals ASAP?

#2 Super Stealth

Super Stealth

    GM DEALER TECH

  • Member
  • 1,051 posts
  • Location:WISCONSIN

Posted 14 November 2010 - 03:53 PM

clean the throttle body

sounds like its all carboned-up right now
2010 CHEVROLET SILVERADO
EXTENDED CAB,STANDARD BOX
LIFE IS GREAT WITH THE 4.8

#3 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 14 November 2010 - 04:04 PM

clean the throttle body

sounds like its all carboned-up right now



Can I just use a can of spray to clean it, or should I take it off and clean it completely?

#4 Super Stealth

Super Stealth

    GM DEALER TECH

  • Member
  • 1,051 posts
  • Location:WISCONSIN

Posted 14 November 2010 - 05:21 PM

clean the throttle body

sounds like its all carboned-up right now



Can I just use a can of spray to clean it, or should I take it off and clean it completely?



leave the actual throttle body on the intake manifiold

remove/set aside air intake

clean the tb as best as possible, including cleaning the tb bore and butterfly

if truck still acts up AFTER tb cleaning, bring it in for warranty work
2010 CHEVROLET SILVERADO
EXTENDED CAB,STANDARD BOX
LIFE IS GREAT WITH THE 4.8

#5 ruggedlife

ruggedlife

    Enthusiast

  • Member
  • 845 posts
  • Gender:Male
  • Drives:2012 Silverado 1500

Posted 14 November 2010 - 05:36 PM

my 09 5.3 has had a slightly rough idle since day one, if you're sitting there you can see the antenna shaking, almost every one ive been in does it, just characteristics of the engine i assume

#6 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 14 November 2010 - 09:44 PM

I'll try the trottly body clean first and if that doesn't work, I'll bring it in. I'll keep everyone posted.

#7 pm26

pm26

    Senior Enthusiast

  • Member
  • 6,340 posts
  • Location:Florida
  • Gender:Male

Posted 14 November 2010 - 11:23 PM

I would remove that cold air intake and return the truck to stock configuration. If the problem does not disappear, take it in for warranty work. I seriously doubt you have much carbon buildup anywhere with so few kms on the truck.

#8 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 15 November 2010 - 01:31 AM

One other thing I should note. I live in a community with no road access and the only way of bringing vehicles in/out is by trian. When I do drive my truck around, it rarely goes over 40km/h. I only drive highway speeds for one week in October, December and March and for July/August. The rest of the time its all dirt roads and slow going, which may help build up the carbon quicker?

#9 jtramsey

jtramsey

    Enthusiast

  • Member
  • 228 posts
  • Location:Columbus, MS

Posted 15 November 2010 - 07:54 AM

Where are you from?
Posted Image

#10 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 15 November 2010 - 08:22 AM

Moosonee, Ontario

#11 KMGZ400

KMGZ400

    Senior Enthusiast

  • Moderator
  • 5,403 posts
  • Location:Pennsylvannia
  • Gender:Male

Posted 15 November 2010 - 08:31 AM

are you sure its not a private island? what exactly is that place?

image_V1MHcoloredsized_zpsa15e91fd.jpg
2014 GMC Sierra Denali 2500 CCSB 4x4 LML 3.73 G80

2013 Chevrolet Silverado LTZ 1500 ECSB 4x4 5.3 3.08 G80
2012 Chevrolet Cruze eco 1.4T M-6

2012 Nissan NV3500 S 5.6 3.54


#12 Blue Sierra Owner

Blue Sierra Owner

    Enthusiast

  • Member
  • 695 posts
  • Location:Atl
  • Gender:Male
  • Drives:2014 GMC Sierra SLE Iradium Metalic

Posted 15 November 2010 - 01:56 PM

Correct me if I am wrong please. I have read on here in more than one post that GMPP did not make a CAI for the 2009 model year truck for some reason on another. If they did could someone post the part number for it?

#13 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 15 November 2010 - 02:17 PM

#19212450 is the part, but good luck finding one, they were discontinued after GM declared Bankruptcy.

#14 Blue Sierra Owner

Blue Sierra Owner

    Enthusiast

  • Member
  • 695 posts
  • Location:Atl
  • Gender:Male
  • Drives:2014 GMC Sierra SLE Iradium Metalic

Posted 15 November 2010 - 09:31 PM

Thanks for the reply. Now I get to start hunting.

#15 todder85

todder85

    Enthusiast

  • Member
  • 10 posts

Posted 19 November 2010 - 01:16 AM

Cleaned out the carbon (there was enough) and used some contact cleaner spray on the MAF. truck seems to be running like new again.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users