Jump to content

Archived

This topic is now archived and is closed to further replies.

nondy

2007 New Style Silverado Remote Starter Problems

Recommended Posts

Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

Share this post


Link to post
Share on other sites
Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

 

Welcome to the site!

 

1. Do you have a check engine light on? This disables the remote start.

2. I believe that in the driver's info center (DIC) there is an option to turn the feature on and off. Check that. (I could be off on this one, as I don't remember and I am not with my truck to check right now.)

3. Are you the original owner? It's possible that the remotes were replaced with remote start ones, but the truck was not actually equipped.

Share this post


Link to post
Share on other sites
Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

 

Welcome to the site!

 

1. Do you have a check engine light on? This disables the remote start.

2. I believe that in the driver's info center (DIC) there is an option to turn the feature on and off. Check that. (I could be off on this one, as I don't remember and I am not with my truck to check right now.)

3. Are you the original owner? It's possible that the remotes were replaced with remote start ones, but the truck was not actually equipped.

 

 

 

I did have the engine light on and the fuel sensor was replaced and the remote worked fine, just in the last cold spell, it ight of started twice from a distance of 200 feet. Now nothing. I'm the second owner and the remotes are original. Where would I fine the DIC to turn off or on ?

Share this post


Link to post
Share on other sites
Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

 

Welcome to the site!

 

1. Do you have a check engine light on? This disables the remote start.

2. I believe that in the driver's info center (DIC) there is an option to turn the feature on and off. Check that. (I could be off on this one, as I don't remember and I am not with my truck to check right now.)

3. Are you the original owner? It's possible that the remotes were replaced with remote start ones, but the truck was not actually equipped.

 

 

 

I did have the engine light on and the fuel sensor was replaced and the remote worked fine, just in the last cold spell, it ight of started twice from a distance of 200 feet. Now nothing. I'm the second owner and the remotes are original. Where would I fine the DIC to turn off or on ?

 

 

 

I hate it when I can't find my DIC!

 

Ok, jokes aside. The four button panel that shows the tire pressure monitor system, oil life, etc. if your truck is equipped. Like I said before, I dont remember if the remote start was an option to turn on and off via the DIC. On the dash to the left of the steering wheel in the non LTZ models.

Share this post


Link to post
Share on other sites
Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

 

Welcome to the site!

 

1. Do you have a check engine light on? This disables the remote start.

2. I believe that in the driver's info center (DIC) there is an option to turn the feature on and off. Check that. (I could be off on this one, as I don't remember and I am not with my truck to check right now.)

3. Are you the original owner? It's possible that the remotes were replaced with remote start ones, but the truck was not actually equipped.

 

 

 

I did have the engine light on and the fuel sensor was replaced and the remote worked fine, just in the last cold spell, it ight of started twice from a distance of 200 feet. Now nothing. I'm the second owner and the remotes are original. Where would I fine the DIC to turn off or on ?

 

 

 

I hate it when I can't find my DIC!

 

Ok, jokes aside. The four button panel that shows the tire pressure monitor system, oil life, etc. if your truck is equipped. Like I said before, I dont remember if the remote start was an option to turn on and off via the DIC. On the dash to the left of the steering wheel in the non LTZ models.

 

 

Ah yes will check it out, I know exactly what ur talking about

Off to work I go, back on here later TKS big time

Share this post


Link to post
Share on other sites

Have you tried starting your truck with the keys and then try the remote start again. then check DIC to see if it somehow it got turned off. Good luck hope you get it fixed!

Share this post


Link to post
Share on other sites

Make sure that the hood is closed as well. You may want to check that the hood open sensor is working as well

Share this post


Link to post
Share on other sites
Make sure that the hood is closed as well. You may want to check that the hood open sensor is working as well

 

 

Ckecked everything I possiblity can, went inside the truck set the DCI to checkmark the command start. It started while I was in the truck and the minute I get out and lock the doors and try the remotes, Zippo again.

Share this post


Link to post
Share on other sites
Hi, have a new style 07 silverado with (2) factory remotes, doors operate fine, but starter does not work on either remotes, changed battery and still no go. Even walked right up to the truck and around and still nothing. Pressed lock button and start, zippo.

Can anyone shed any light here. Tks

 

Welcome to the site!

 

1. Do you have a check engine light on? This disables the remote start.

2. I believe that in the driver's info center (DIC) there is an option to turn the feature on and off. Check that. (I could be off on this one, as I don't remember and I am not with my truck to check right now.)

3. Are you the original owner? It's possible that the remotes were replaced with remote start ones, but the truck was not actually equipped.

 

 

 

I did have the engine light on and the fuel sensor was replaced and the remote worked fine, just in the last cold spell, it ight of started twice from a distance of 200 feet. Now nothing. I'm the second owner and the remotes are original. Where would I fine the DIC to turn off or on ?

 

 

 

I hate it when I can't find my DIC!

 

Ok, jokes aside. The four button panel that shows the tire pressure monitor system, oil life, etc. if your truck is equipped. Like I said before, I dont remember if the remote start was an option to turn on and off via the DIC. On the dash to the left of the steering wheel in the non LTZ models.

 

 

Yeah on my truck, on the DIC you have the option to turn on or off remote start.

Share this post


Link to post
Share on other sites

Pull the neg side of the battery for 10 minutes, then reattach. Try the remote start and see if it works or not. If there is a stored code in the ECM, the remote start feature won't work. :dunno:

 

Otherwise, it might be a trip to the dealership.

Share this post


Link to post
Share on other sites

Have you tried a new battery in the remote ? Don't think it's the problem, but you never know.

Share this post


Link to post
Share on other sites

My V-Max has been crazy recently, the check engine light comes on and off. So this interferes with my remote start. I would go to the dealer but last time I asked them to check the engine light they wanted to charge me almost a hundred dollars.

Share this post


Link to post
Share on other sites

Also, if your low fuel light is on, it wont start (to keep from running out of gas)

Share this post


Link to post
Share on other sites
Also, if your low fuel light is on, it wont start (to keep from running out of gas)

 

Thanks for all the advice, still have the problem, I guess I going to have to take it to the (gulp) dealership along with one of my kids . That' s probably the cost to repair, one child.

Share this post


Link to post
Share on other sites

  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.