Jump to content



Photo
- - - - -

Not Shifting Out Of 1st Code P0700


  • Please log in to reply
8 replies to this topic

#1 ken2400

ken2400

    Enthusiast

  • Member
  • 6 posts

Posted 05 June 2011 - 07:35 PM

2001 Sierra 2500 HD truck 130K miles 4X4 used for plowing.

So a friend of mine lent me his truck. It ran good for four halls, all light stuff and the 5 th time the CEL came and gave me a P0700 code. It now clucks when I shift into drive and does not want to shift out of first.

It runs OK and all BUT not shift.

Any help would be GREAT. Thanks

#2 8.1HD/ALLISON

8.1HD/ALLISON

    Senior Truck Tweaker

  • Moderator
  • 2,594 posts
  • Name:Matt
  • Location:Indiana
  • Gender:Male
  • Drives:04 K2500HD

Posted 06 June 2011 - 11:49 AM

p0700 is an information code stored in the engine control module. It is to let you know there is a code stored in the transmission control module. Need to check codes for the tranny.

backhoe6_zps0cfc8c15.jpg
You want fuel economy? Buy a Prius.... I have a big block!
------------------------------------------------------------------------------------------------------
2004 Chevy Silverado K2500 HD CCLB, 8.1L/Allison, 285/75R16 Goodyear Duratracs,
B&W hitch, Whelen 6 channel strobe lights, Soundoff Signal Mini Light Bar,
Dual Flowmaster Super 44's, BlackBear Tuned, Too much to list,


 


#3 Mike G

Mike G

    What do you mean you can buy colors????

  • Member
  • 607 posts
  • Location:Littleton, CO

Posted 06 June 2011 - 02:35 PM

Which transmission is in the truck? Is the motor a diesel?
--Mike
06 2500HD Crew Shorty 4x with the 6.6 LBZ turbo diesel beast and 6 Speed Ally
02 Avalanche (wife's driver)--Front leveled and 285s look sweet!
92 GMC K1500 Z71--Refreshed warmed 5.7L at 190K (sold 5/5/11 to an excited neighbor)
(02 F350 Crew Dually 7.3L PS Diesel - the #1 sons)

Dirt Bike-Street Bike-Two classic vehicles-5.7l Boat-32 Ft 5th wheel-Too much other stuff to fit in my sig

White truck club member? - I own it....

#4 ken2400

ken2400

    Enthusiast

  • Member
  • 6 posts

Posted 07 June 2011 - 08:27 PM

The owner said it was the heavy duty trans and it has a 8 cyl gas motor

Where would I find more info on the transmission model?

Thanks

Which transmission is in the truck? Is the motor a diesel?
--Mike



#5 ken2400

ken2400

    Enthusiast

  • Member
  • 6 posts

Posted 07 June 2011 - 08:28 PM

Well truck is changing gears again and the light is off. The only thing I did is put it in 4 high and 4 low. I don't know if that did it or if would have cleared on it own?

#6 ken2400

ken2400

    Enthusiast

  • Member
  • 6 posts

Posted 10 June 2011 - 07:56 AM

The light came back on and it's not shifting right.
Keep ya posted.

#7 Stevens14

Stevens14

    Senior Enthusiast

  • Member
  • 8,226 posts
  • Location:Bellefonte, Pa
  • Gender:Male
  • Drives:2014 Silverado Z71 Double Cab 5.3L

Posted 10 June 2011 - 08:15 AM

If it's an HD, it will have the 4L80e trans unless it's the 8.1L then it could have the allison trans. Good luck

336f9a49-39ea-421d-a456-ae7752cdf8e1_zps

Deep Ruby Metallic
2014 Silverado Z71 Double Cab


#8 Kurt_T

Kurt_T

    Enthusiast

  • Member
  • 300 posts
  • Location:connecticut
  • Gender:Male

Posted 11 June 2011 - 11:33 AM

Funny cause every time i post somthing 2x everyone flips on me but. I JUST had this problem with my truck over the winter, it happens when the sensor gets wet idk its some trans control sensor your going to have someone replace it so just take it to the dealership or your favored mechanic since you already know the code it shouldnt be a problem (Also at the same time my Cam position sensor went so have them check that too)

-Kurt

P.S if you search the forum you might find my post i think i made it back in January idk if it still exists but just go have it checked out cause i did just that and its Fine Now i had the exact same problem it would not shift out of first and somtimes it wouldn't shift past third or fourth i think it may have disabled my overdrive and basicly put me in Gear 3 or tow/haul mode
Posted Image

#9 ken2400

ken2400

    Enthusiast

  • Member
  • 6 posts

Posted 18 June 2011 - 06:58 AM

The owner of the truck said he was going to have the neutral safety switch replaced. I hope to write back after he has this done. Thanks for all the help so far.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users