Jump to content

Sign in to follow this  
Z71Silverado

Problem With Defroster/air Conditioner?

Recommended Posts

Hey. I know driving with the air on decreases horsepower but does driving with the defroster on also decrease horsepower? i thinki will have an eventual problem. when the air conditioner is on there is a noise that sounds like a snake hissing when it's running, the same noise also happens when i turned the defroster on. There is a huge difference in get up and go with either the air or defrost on. is that normal? what could be making that noise? the air compressor?

Edited by Z71Silverado

Share this post


Link to post
Share on other sites

Yes it's normal. In DEFROST mode the air conditioning compressor comes on to dehumidify the air and clear the windshield faster.

 

DEWFPO

Share this post


Link to post
Share on other sites

Is there a way to set up the truck so that the compressor doesn't kick on with the defroster? I only use the defroster when it's cold so I see no reason for compressor to kick on.

Share this post


Link to post
Share on other sites

By running the compressor you're accomplishing at least 2 things:

 

1. Removing moisture from the air which aids in defrosting.

2. Allows seals in the AC system to be lubricated by the circulation of refrigerant and oil

Share this post


Link to post
Share on other sites
Well what do you guys think the hissing sound is? it only happens when i turn the air or defrost on.

 

 

I also have had the same noise. I don't think it is coming from the compressor, I think it is coming from the drier? near the firewall.

Share this post


Link to post
Share on other sites
Well what do you guys think the hissing sound is? it only happens when i turn the air or defrost on.

 

 

I also have had the same noise. I don't think it is coming from the compressor, I think it is coming from the drier? near the firewall.

 

 

what was the problem? and what did you do to fix it?

Share this post


Link to post
Share on other sites
Well what do you guys think the hissing sound is? it only happens when i turn the air or defrost on.

 

 

I also have had the same noise. I don't think it is coming from the compressor, I think it is coming from the drier? near the firewall.

 

 

what was the problem? and what did you do to fix it?

 

 

I haven't done anything yet. Been waiting to see if anybody else has been having the same problem and seeing what they do. Since the A/C and heat still work and since my local mechanic (doesn't do A/C work but I believe knows his stuff) said there is nothing there that can do any damage he said to leave it. Since it hasn't bothered me lately I haven't really looked anymore into getting it fixed. However, in my case it got worse when I had my snowplow on and since we are getting into that season I might end up being bothered by it enough to get it worked on.

Share this post


Link to post
Share on other sites

My truck has made that hissing noise from day 1. It will only do it on lower fan settings like 1 or 2. I don't really worry about it. My father-in-law has a 2001 and his does not make that noise. Strange.

Share this post


Link to post
Share on other sites

I have the same noise on my '06. My '00, '01, or '02 didn't do it though.

Share this post


Link to post
Share on other sites

I also have the hissing noise on my '04 Suburban. It's been that way since I bought it.

Share this post


Link to post
Share on other sites

Anybody have any idea as to what that noise is or where it is coming from? Not concerned about it but just one of those things I would like to know. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

ADSENSE FOOTER
  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.