Jump to content

Recommended Posts

have problem with my truck. checked everything out have 62psi pressure to fuel rail, spark to plugs , clear air intake.

truck turns over fine but wont fire. happened twice b4 and after towing to shop the mech checked all the usual issues and when he cleared codes and turned it over to check what codes reset the darned thing started and ran.

he didnt charge me anything except the tow fee and told me he was at a loss to explain why its just up and started.

its a chevy 1500 5.7L vortec. the only issues that occur b4 the wont start issue is it starts running a bit rough and gives me hessitant shifting b4 i turn it off and it wont start. its makin me nuts trying to figure this out . the only code its giving is an evap code which i dont believe will not let it start and run . HELP

Share this post


Link to post
Share on other sites

had a mech look at it and he said timing was off . problem fixed for about a month then came back exactly the same as before. towing it in to him in the morn since he said he stands by his work gonna give him another shot at it. this is driving me nuts

Share this post


Link to post
Share on other sites

Well your getting spark,fuel now you compression.do a compression test.Could be your timing chain.

Share this post


Link to post
Share on other sites

look into the carb e if its getting fuel up there

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

ADSENSE FOOTER
  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.