Jump to content



Photo
- - - - -

OGM-1/iGo DST clock issue fix due 4/12/12


  • Please log in to reply
43 replies to this topic

#1 ADC Mobile

ADC Mobile

    Enthusiast

  • Member
  • 611 posts
  • Name:Walt Ottenad
  • Location:Lake Tapps, WA
  • Gender:Male
  • Drives:2011 Tahoe, 2006/2007/2010 Express. 2003 Tahoe, 68 GMC PU

Posted 10 April 2012 - 03:42 PM

Advent released this information today regarding the DST bug that affected iGo Primo-equipped head units:
 

Complaint: Since Daylight Savings Time my clock has been off for one hour.

Issue: Nav-N-Go the makers of iGO My Way maps has identified a glitch in some time zones that causes the map software to adjust the radio clock one hour in advance of the actual time.

Solution: iGO will release a map system update on Thursday April 12, 2012 to correct this situation. In order to receive this update; remove the SD card from the radio, place it in a SD Card reader attached to their computer and go to www.naviextras.com on the internet. When the update is loaded on the Map there is no further changes needed. There is no update to run in the radio. When finished just re-insert the SD card into the radio and run the map as usual.

Once at Naviextras.com you must register the map (yes this is free) and download the Naviextras Toolbox program. There are step by step instructions in the lower left corner of the page in a box labeled “How To Get Started”. The instructions even include pictures to show how to complete the installation and get the update.

The Naviextras website is a great resource, it will make updates to the map operating system, offer a free map backup, and allow additional mapping information such as Red Light and Speed Camera databases to be purchased and added to the navigation system. By loading the map into your computer and checking back with Naviextras from time to time you will be able to stay up to date with all changes.

This is also where you can purchase a new map upgrade when available.

As a FREE service to the user, the system will check the map the first time it is run in the Naviextras Tool Box program and if a map data update is available, this will be done for free. This is an update that adds streets, addresses and POI (Points Of Interest). This is a $99.00 value.

Note: This must be run within 90 days of purchasing and navigating with the system the first time. Map operating system updates are always free, Map upgrades and updates must be paid for at the time of downloading from Naviextras.com. Advent does not sell or offer updates.

Please also note that iGO is a third party vendor, Advent Tech support cannot make changes or assist with naviextras.com web site interaction or issues. If you have a problem at the web site please click on the “SUPPORT” tab at the top of the page and follow the instructions listed in order to have your question about the web site answered.

THIS UPDATE IS ONLY FOR iGO MAPPING IN ADVENT OE SPECIFIC RADIOS – THIS WILL NOT WORK WITH NAVMATE BY HORIZON OR ON ANY OTHER RADIO. USING THIS UPDATE IN A RADIO NOT LISTED MAY CAUSE YOUR SYSTEM TO OPERATE INCORRECTLY OR NOT AT ALL.
Walt Ottenad
ADC Mobile

Posted Image

#2 wtbrowne

wtbrowne

    Enthusiast

  • Member
  • 150 posts
  • Name:Wm. Terry Browne
  • Location:Springfield, OH
  • Gender:Male
  • Drives:2008 Silverado 2500HD CC Duramax

Posted 11 April 2012 - 09:54 AM

Thank you Walt! I find it interesting that the problem was with the NAV software and not with the OS.
Black 08 Silverado 2500HD CC Duramax/Allison
Posted Image

#3 Z71_Denali

Z71_Denali

    Enthusiast

  • Member
  • 858 posts
  • Location:Midland, TX
  • Gender:Male
  • Drives:2014 GMC Sierra Z71 Denali

Posted 11 April 2012 - 12:48 PM

whoop!

Formerly Known as 2010TexasEdition


#4 ADC Mobile

ADC Mobile

    Enthusiast

  • Member
  • 611 posts
  • Name:Walt Ottenad
  • Location:Lake Tapps, WA
  • Gender:Male
  • Drives:2011 Tahoe, 2006/2007/2010 Express. 2003 Tahoe, 68 GMC PU

Posted 11 April 2012 - 05:10 PM

Thank you Walt! I find it interesting that the problem was with the NAV software and not with the OS.


Me too, but I don't know if the problem was with the time/date information that's passed to the OS by the navi or what exactly the relationship is. The important thing is that they've identified it and are fixing it...

Edited by ADC Mobile, 11 April 2012 - 05:13 PM.

Walt Ottenad
ADC Mobile

Posted Image

#5 wtbrowne

wtbrowne

    Enthusiast

  • Member
  • 150 posts
  • Name:Wm. Terry Browne
  • Location:Springfield, OH
  • Gender:Male
  • Drives:2008 Silverado 2500HD CC Duramax

Posted 12 April 2012 - 09:24 AM

Got the updates this morning. Put the SD Card in the reader, started Naviextras Toolbox, signed in and everything worked automatically. I made a backup as suggested by the prompt, which took about 10 minutes and then the system updated itself. The clock problem appears to be fixed as advertised.

You will be prompted to put the SD Card back into the truck and start the NAV - then remove the card and go back to Naviextras for more updates, which I've done. The system will then update the maps with the most recent data. I'm doing that now and it's taking some time. My estimate to complete is about two hours at the present rate. I decided to go ahead with the map updates while they are available and also to ensure I have the most recent maps and info. You can choose to wait, but there is a chance that the map updates won't be available later due to time restraints.

Editing this post to say that each state map is updated individually by the system, which is probably a good feature in that a lost connection with the internet won't require a complete restart of the download to finish the update. iGO will know which states are up-to-date and only download those that still need the updates.

Edited by wtbrowne, 12 April 2012 - 09:43 AM.

Black 08 Silverado 2500HD CC Duramax/Allison
Posted Image

#6 johnrunner89

johnrunner89

    Enthusiast

  • Member
  • 28 posts

Posted 12 April 2012 - 01:38 PM

My clock usually jumps up two hours in advance rather than one as listed in the OP. This update should still correct my issue right? Or is it possibly another problem? Thanks

#7 wtbrowne

wtbrowne

    Enthusiast

  • Member
  • 150 posts
  • Name:Wm. Terry Browne
  • Location:Springfield, OH
  • Gender:Male
  • Drives:2008 Silverado 2500HD CC Duramax

Posted 12 April 2012 - 02:09 PM

It should fix the problem - try it and see. Also, make sure you have the time zone set correctly for your area.
Black 08 Silverado 2500HD CC Duramax/Allison
Posted Image

#8 JdubUB

JdubUB

    Senior Enthusiast

  • Member
  • 1,542 posts
  • Name:Josh
  • Location:Dallas TX/ Houston TX
  • Gender:Male
  • Drives:2010 Chevy Z71

Posted 13 April 2012 - 08:01 AM

sweetness!
-You can set my truck on fire, and role it down a hill, but I still wouldn't trade it for a Coupe De'ville-
Posted Image
--Blackbear Performance Tune (AutoCal 89oct.), ADVENT OGM-1, GMPP/Borla Exhaust, Spray in Liner, AMP Power Steps,
Wheel Well Liner, Tint, Billet Bowtie, 285/65/18 Terra Graps, RC Leveling Kit, 2.25" Rear Blocks, De-badged, Weathertech Liners, Fog Light Diode Mod, Escort 9500ix, Viper 5701, "Pocket Rocket" Glock .357, Nothing But AMSOIL--

2008 GMC Sierra- SOLD

#9 parshal

parshal

    Enthusiast

  • Member
  • 153 posts
  • Location:Colorado
  • Gender:Male

Posted 13 April 2012 - 10:25 AM

I updated mine last night. It didn't update any of maps, though, as far as I can tell. There was no second download after the initial update.

#10 aesalazar

aesalazar

    Enthusiast

  • Member
  • 277 posts
  • Location:New Jersey
  • Gender:Male
  • Drives:2009 Silverado LT

Posted 14 April 2012 - 09:41 AM

Anyway to get the EXE/update without having to install their software? I hate putting thing on my PC like that, dont know what it will do to it.

Ernie
2009 Silverado 4x4 LT1
Advent OGM1, JL Audio Stealthbox, JL Audio ZR650-CSi Components, JL Audio XD400-4 Amp, Camera Source Backup Cam
Autocal Black Bear Custom Performance Tune, MBRP Single side-exit exhaust, Volant powercore intake
OEM Addons: Steering While with audio controls, DIC Controls, Homelink (X-10) compatible overhead buttons

#11 MikeNH

MikeNH

    Senior Enthusiast

  • Moderator
  • 6,589 posts
  • Name:Mike
  • Location:Michigan
  • Gender:Male
  • Drives:2011 Silverado 1500

Posted 14 April 2012 - 01:25 PM

Anyway to get the EXE/update without having to install their software? I hate putting thing on my PC like that, dont know what it will do to it.

Ernie


The only thing the software will do is enable you to download updates. :lol:

The interface is web-based. I have it on my work laptop which has a real aggressive virus/spyware/malware protection package and I haven't heard a peep from it.


Did the first update last night. Said I had to go restart the deck before proceeding with the map update. I got sidetracked generating reports for work and I did those till it hurt to look at the computer so I went to bed. :lol: First update fixed the clock issue. Maps being updated now.

Edited by MikeNH, 14 April 2012 - 01:32 PM.


#12 MikeNH

MikeNH

    Senior Enthusiast

  • Moderator
  • 6,589 posts
  • Name:Mike
  • Location:Michigan
  • Gender:Male
  • Drives:2011 Silverado 1500

Posted 14 April 2012 - 03:16 PM

Upgrade done. My road still doesn't exist. :lol:

#13 doug_scott

doug_scott

    Senior Enthusiast

  • Member
  • 2,175 posts
  • Location:Ajax, ON
  • Gender:Male
  • Drives:2010 GMC SL

Posted 14 April 2012 - 06:29 PM

Thank you Walt! I find it interesting that the problem was with the NAV software and not with the OS.


Too late for me to test this theory, but if someone has not applied the update yet, if they would enable the DST in the IGO settings, then restart their OGM-1. After it restarts, go into Settings, page 2, and set your time correctly, and make sure the time zone is correct. BTW, make sure Nav is NOT set to run auto on start up. Do not start NAV at all. Listen to radio, or watch dvd. See if the time changes on its own. I know that if NAV is run, the clock does change on its own.
If the time stays correct when NAV is not loaded, but changes when it is loaded, this means NAV is pulling time from the satellights, and applying DST rules incorrectly, then updating the o/s.
Mine is working correctly with the fix.

#14 CPD1670

CPD1670

    Enthusiast

  • Member
  • 58 posts
  • Location:Southern Tier New York
  • Gender:Male
  • Drives:2008 Avalanche Z71

Posted 15 April 2012 - 05:40 AM

After the update I've seen a major upgrade in the NY maps :)
God made Cops, so Fireman would have Hero's too...

#15 ADC Mobile

ADC Mobile

    Enthusiast

  • Member
  • 611 posts
  • Name:Walt Ottenad
  • Location:Lake Tapps, WA
  • Gender:Male
  • Drives:2011 Tahoe, 2006/2007/2010 Express. 2003 Tahoe, 68 GMC PU

Posted 15 April 2012 - 12:40 PM

After the update I've seen a major upgrade in the NY maps :)


Good to hear! Not too bad for free, huh?
Walt Ottenad
ADC Mobile

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users