Jump to content

Sign in to follow this  
MrWizard

MYLink and IPhone with Google Maps not working

Recommended Posts

I am enjoying the new truck but I have a problem with MYLink and my IPhone 5 and it's applicaitons.


I noticed the other day when I got a text message on my phone (IPhone 5) while driving my truck the other day I never heard the phone give me a text message ring. It did however vibrate as it is programmed up to do both at the same time. At first it thought this was no big deal as I really don’t care if I get a text message while I drive because I don’t text and drive at the same time.

Today I wanted to try out how the navigation on my IPhone 5 worked with the new truck and it left me very disappointed. I first tried Google maps then I tried the IPhone own map product and they both reacted the same. What I found out was that once I put in a location to navigate to it would show me my route and it would show me each turn I needed to make however the IPhone voice turn
by turn was silent. That is correct I never heard any instructions on when to turn. So, I tried a couple of things and one of things I tried that made it work was to turn off the Bluetooth on my IPhone then I got voice commands telling me when to turn. This is unacceptable as I need both to work together not separately. Next I tried having my phone connected by Bluetooth and changing the connection to media. Then all of a sudden my Google Maps voice turn came thru the system with no problems. My text sounds came thru and it seemed as it all worked. However once I changed the source back to FM, AM, or XM Google map voice and text message tone no longer worked again. I am surprise that Chevy (MYLink) have not found out about this problem earlier and would have a fix out to the public real quick.

 

Then when I was on vacation I was talking with my sister who has an 2013 Impala with MyLink and a Droid phone she was having the same problem.

 

Really...why can't Chevy (MYLink) get this bug fixed?



Share this post


Link to post
Share on other sites

You have to have Bluetooth audio selected as the input source on the radio to hear sound coming from the Bluetooth source

 

Sent from my SCH-I535 using Tapatalk 2

 

 

  • Like 1

Share this post


Link to post
Share on other sites

If you have Bluetooth selected as the input you must listen to audio from the Bluetooth source...

 

Sent from my SCH-I535 using Tapatalk 2

 

 

Share this post


Link to post
Share on other sites

I think there is a bug to this. Sometimes after a phone call the google maps will suddenly "call" the truck from my phone when it needs to talk. Any others notice this?

Share this post


Link to post
Share on other sites

Yes, I understand if you have your audio select as Bluetooth you must listen to your IPhone music. However, in my 2012 Camaro (doesn't have MYLink) works the way it should. When listening to AM/FM/XM your Bluetooth device will receive text messages and Google Maps will give you turn by turn instructions using the radio system then when it is done it tells me that the call has ended. Almost kind of like the way bcridez sometimes works after a phone call.

I should not be limited to just listening to my music on my IPhone to make Google Map work correctly with MYLink.

 



Share this post


Link to post
Share on other sites

I am enjoying the new truck but I have a problem with MYLink and my IPhone 5 and it's applicaitons.

 

I noticed the other day when I got a text message on my phone (IPhone 5) while driving my truck the other day I never heard the phone give me a text message ring. It did however vibrate as it is programmed up to do both at the same time. At first it thought this was no big deal as I really don’t care if I get a text message while I drive because I don’t text and drive at the same time.

Today I wanted to try out how the navigation on my IPhone 5 worked with the new truck and it left me very disappointed. I first tried Google maps then I tried the IPhone own map product and they both reacted the same. What I found out was that once I put in a location to navigate to it would show me my route and it would show me each turn I needed to make however the IPhone voice turn

by turn was silent. That is correct I never heard any instructions on when to turn. So, I tried a couple of things and one of things I tried that made it work was to turn off the Bluetooth on my IPhone then I got voice commands telling me when to turn. This is unacceptable as I need both to work together not separately. Next I tried having my phone connected by Bluetooth and changing the connection to media. Then all of a sudden my Google Maps voice turn came thru the system with no problems. My text sounds came thru and it seemed as it all worked. However once I changed the source back to FM, AM, or XM Google map voice and text message tone no longer worked again. I am surprise that Chevy (MYLink) have not found out about this problem earlier and would have a fix out to the public real quick.

 

Then when I was on vacation I was talking with my sister who has an 2013 Impala with MyLink and a Droid phone she was having the same problem.

 

Really...why can't Chevy (MYLink) get this bug fixed?

 

 

 

Oh no! I am sorry to hear that you are experiencing an issue with your MyLink. If you have not already, Infotainment General Support are great at answering any question or concern you may have with technology in your vehicle. Here is their number 855-478-7767.

 

Jennifer T.

GM Customer Care

Share this post


Link to post
Share on other sites

my droid does this... not a big deal as I find it nice for forget about emails and text sometimes.. I just look down at the light.. see if it's blinking then I know I have an email or text.

Share this post


Link to post
Share on other sites

I could care less about the email and phone noises. But like the OP said, Very annoying that I have to turn bluetooth off just so I can use the phone as for turn by turn directions or I am forced to listen to phone music instead of Radio/XM/etc... if I want to have it play turn by turn over the speaker system.

Share this post


Link to post
Share on other sites

Just listen to XM from your phone...

 

Sent from my SCH-I535 using Tapatalk 2

 

 

Share this post


Link to post
Share on other sites

Just listen to XM from your phone... Sent from my SCH-I535 using Tapatalk 2

HA! That's one solution, if you have unlimited data plan, which I do not, plus when my free months run out on XM, I won't be paying the extra for the ability to listen to XM over the internet.

Share this post


Link to post
Share on other sites

Same thing on my 2014 SLT and wifes 2013 ATS. I am curious to see if there is a fix to get Google Nav voice to play over speakers.

Share this post


Link to post
Share on other sites

This isn't a fix - but a workaround I use to get my text tone or voice directions to come through the phone while it is still connected by Bluetooth.

 

On the iPhone (while connected to the truck), double tap the Home button. There will be a square icon with a triangle in it. If you press that you can choose to put the sounds back to the phone. The pisser is that this setting doesn't stick. You need to do it every time the truck and my phone connect.

 

photo2.pngphoto.png

Share this post


Link to post
Share on other sites
This isn't a fix - but a workaround I use to get my text tone or voice directions to come through the phone while it is still connected by Bluetooth.

 

On the iPhone (while connected to the truck), double tap the Home button. There will be a square icon with a triangle in it. If you press that you can choose to put the sounds back to the phone. The pisser is that this setting doesn't stick. You need to do it every time the truck and my phone connect.

 

 

 

Nice trick! I like this work around. I'll try it out tomorrow. Honestly kicking myself for not already trying this. I knew airplay was there, just didn't think about it with the truck.

Share this post


Link to post
Share on other sites

This doesn't work. I got in truck this morning and tried this and it is already set to this automatically when it Bluetooth connects for the phone. So it is the my link system that is muting the sounds other than phone. :-(

 

Wish they would fix that. Or at least let the phone play those sounds.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.