Jump to content

Recommended Posts

Posted (edited)

Guys I made a mistake and over torqued the front lower strut bolts. I over did it with the impact to be more specific haha. One of them is right and not moving at all the other. The tabs broke off and is just hanging there loose.

 

Now I don't even know what these tabs are called to even look for them? Should I just replace them with a bolt and washer/nut? 5506f8d3296bdeae2ed0eb19b4d253c1.jpg

 

 

Sent from my iPhone using Tapatalk

Edited by Imperial91

Share this post


Link to post
Share on other sites

Replace it with a washer and nut. The 5100s I put on my '08 came with flange nuts. Did yours come with the clip-on nuts or did you transfer them from the stock shocks?

 

B679075E-1294-46D4-B013-B8DB47EB5B2D_zps

Share this post


Link to post
Share on other sites

My leveling kit just has a bolt and washer

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I had a shop install them the first time around. Thanks for the input.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

A new nut and bolt would be just fine. Just be sure to recheck it after a few hundred miles.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.