Jump to content

Recommended Posts

I took my truck in to have the coolant loss checked and because I also had delayed engagement into drive. Already had stator assembly replaced a few months ago and it went away temporarily but came back and seemed worse. The dealership said GM sent them a TCM update for my truck and they wanted to install it and see if it would help before going into the trans. I got the truck back and not only has the delay went away, it shifts better in all the other gears as well. Before when I drove it in tow/haul it downshifted to first real harsh as well and no longer does. Plus all the other usual gear hunting and clunks are gone. Its only been a couple of days but thought I would post this as there are still a lot of people dealing with 8 speed issues.

  • Like 1

Share this post


Link to post
Share on other sites

You know, my truck was just at the dealer too. I thought that it seemed to be shifting noticably smoother. Maybe there was some update applied that they didn't tell me about. Or my 8spd has just been having a couple of its good days recently.

Share this post


Link to post
Share on other sites

yes please get the exact TSB number. At first oil change I am going to have this done. This 2017 (almost exact same truck as my old 2016) is much worse than my 2016 ever was with harsh downshifts and crazy gear hunting. I have been holding off to let it LEARN but at 2000 miles it seems to be a slow learner LOL

Share this post


Link to post
Share on other sites

I will look on my paperwork when I get home and see what it says.

Share this post


Link to post
Share on other sites

I also had some issues with my 8spd, it makes some crazy harsh downshifts sometimes. And when driving around town slowly it doesn't shift smooth at all , I first of all blamed it on having to relearn also because I killed my battery a while back but installed new battery and its been at least 1,000 miles since then and it still doesn't the same thing. I need to check into this software update also!

  • Like 1

Share this post


Link to post
Share on other sites

Just called in to the dealership about mine and told them what was going on, the service manager told me that they have had numerous amounts of the 8 speeds come in with those same problems and GM keeps telling them that this is normal. If this is normal I will definitely be getting rid of my truck which I hate to do because I love the truck but don't like the trans problem. They said that she thought GM was working on a fix but hasn't told them anything yet to call back in a couple weeks to check and see. Also service manager said that they have put in complete new transmissions and it changed nothing it performed the same . So I dunno Im gonna wait a few weeks and see if maybe GM has something come out for it but I don't care what they say if it is normal operation then they need to pull the damn thing off the line up and start from scratch.

  • Like 1

Share this post


Link to post
Share on other sites

Just called in to the dealership about mine and told them what was going on, the service manager told me that they have had numerous amounts of the 8 speeds come in with those same problems and GM keeps telling them that this is normal. If this is normal I will definitely be getting rid of my truck which I hate to do because I love the truck but don't like the trans problem. They said that she thought GM was working on a fix but hasn't told them anything yet to call back in a couple weeks to check and see. Also service manager said that they have put in complete new transmissions and it changed nothing it performed the same . So I dunno Im gonna wait a few weeks and see if maybe GM has something come out for it but I don't care what they say if it is normal operation then they need to pull the damn thing off the line up and start from scratch.

If only those idiots (GM) would contact any reputable turner company considering they know how to fix the shift points lol.

  • Like 1

Share this post


Link to post
Share on other sites

If only those idiots (GM) would contact any reputable turner company considering they know how to fix the shift points lol.

 

That's PRECISELY what I was about to say! You could get HPTuners or Corvettes of Westchester to tune the transmission, but you'd have to research what that does to your warranty (and it also costs money that we shouldn't have to spend to fix a GM problem).

Edited by Mileguru
  • Like 1

Share this post


Link to post
Share on other sites

 

That PRECISELY what I was about to say! You could get HPTuners or Corvettes of Westchester to tune the transmission, but you'd have to research what that does to your warranty (and it also costs money that we shouldn't have to spend to fix a GM problem).

It will void the warranty that's the issue.

  • Like 1

Share this post


Link to post
Share on other sites

Ok, I took a picture of my paperwork. It has a tsb and SLF code# (whatever that is) hope it can help some of you like it has me. Truck is still shifting great so far.

 

I did read in another unrelated post that some one else had gotten an 8 speed update and truck is also much better and his has been in for a couple of months. So it all sounds promising.

 

df80662f33d1379b4aa80a36706428b2.jpg

 

Sent from my SM-G935V using Tapatalk

Edited by MrNasty
  • Like 2

Share this post


Link to post
Share on other sites

Dealer is supposed to contact me back and I will ask him about this particular bulletin

Edited by NathanFugett

Share this post


Link to post
Share on other sites

Let us know how it works, That TSB came out in Jan

Edited by Blue17

Share this post


Link to post
Share on other sites

Ok, I took a picture of my paperwork. It has a tsb and SLF code# (whatever that is) hope it can help some of you like it has me. Truck is still shifting great so far.

 

I did read in another unrelated post that some one else had gotten an 8 speed update and truck is also much better and his has been in for a couple of months. So it all sounds promising.

 

df80662f33d1379b4aa80a36706428b2.jpg

 

Sent from my SM-G935V using Tapatalk

Thanks for this.. .i have this same issue.. took it in once, they cant replicate... go figure... i'll be showing them this next time i go in!

Share this post


Link to post
Share on other sites

We have # for this. Mines going in on Monday. Would like to save a trip

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


ADSENSE FOOTER
  • Recently Browsing

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use.