Jump to content

Zane

2019 GMC Sierra Caught On Film Wearing Next To Nothing

Recommended Posts

They are literally playing copy cat with Nissan Titan, Ram and F150.  Why can't they just make a good CHEVY and a good GMC?  What was wrong with years past designs?  I know fuel economy has a play into design now more than ever, but come on.  Be original. 

 

I am slightly concerned with what's going to be shown. 

Share this post


Link to post
Share on other sites

Great!  Hope it has blind spot warnings, adaptive cruise control, HUD, heated rear seats, rear hvac vents, rear USB ports, push button start, and 360 deg cameras for towing and parking to name a few.    Otherwise I'll keep my 2014 sierra Denali which is a stripped down version of a luxury truck.   

Share this post


Link to post
Share on other sites

That ground clearance.... hopefully the 4x4 / z71 has a few more inches 

Share this post


Link to post
Share on other sites

If the truck is going to look anything like this at all,  I am SO happy I bought my 2017 Duramax DenaliHD. 

All it would take is for Ram to fix their ridiculous heater control and beef up the doors and they might have a more appealing truck.........sad days.

 

**Need to update my profile pic from my 1500 to my new 2500

Edited by GMSVCMGR99801

Share this post


Link to post
Share on other sites

There was the same speculation and hatred and doubts on this site when the 2014 models were being tested and prior to coming out, and look how many of you bozos got one.  :P   You can't tell crap about the trucks with all that crap that is on them right now.  Patience, patience. 

  • Like 2
  • Haha 2

Share this post


Link to post
Share on other sites
Wow 
Looks like a tundra & a Colorado had a bastard child !!
 
Gm, you have lost me as a new truck buyer. 
 


Relax don’t rush to judgement based on a camo covered truck


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

I absolutely hated the GMT900 when they were launched (photos etc). Obviously they grew on me since I bought a 2010.


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites
7 minutes ago, RyanbabZ71 said:

I absolutely hated the GMT900 when they were launched (photos etc). Obviously they grew on me since I bought a 2010.


Sent from my iPhone using Tapatalk Pro

Usually how it goes.

Share this post


Link to post
Share on other sites

It's going to look like the new Tahoe/Yukon/Escalade/Suburban/Yukon XL/Escalade XL.  Front doors might possibly be interchangeable as may the fenders, hood grill, etc. which would make the most sense from production and OEM aftermarket parts logistics standpoint. If you like the looks of the current SUV platform then you will like the next generation truck.  JMHO.  Front windshield appears to be laid back a little more also from current model.

Share this post


Link to post
Share on other sites

Funny how people are commenting on it's looks.  Can't seriously see much at all other than wheel types, which mean nothing.  Only thing I see that I feel is negative is that odd window curl at the bottom of the back window.  Not a fan of that, but it's a signature GM thing so no way it'll go away soon.  And, it's not like any truck looks really THAT different these days.  The squarish thing is to make them look bigger and mean business.  Marketing... meh.

Share this post


Link to post
Share on other sites

Still hard to tell since that camo is messing with my eyes so much. That said, the front end looks good but that bumper looks huge and really low. The beltline reminds me of the Chrysler 300, tall doors and short windows. I'm interested to see what they have done here.

 

I do like how they are differentiating the GMC vs the Chevy more now though.

Share this post


Link to post
Share on other sites
On 11/7/2017 at 9:01 AM, j20m715 said:

Wow 

Looks like a tundra & a Colorado had a bastard child !!

 

Gm, you have lost me as a new truck buyer. 

 

I thought it looked more like a Tundra and a Ridgeline had some wild offspring.  I definitely have to keep my '96 Sierra going as nothing new is impressing me.

Share this post


Link to post
Share on other sites

They are doing embossed / raised lettering in the tailgate. Similar to the old retro pickups.

“GMC” and “CHEVROLET”

Aluminum tailgates at least (probably more). Hopefully they leave the floor of the bed steel.

I think the headlight system will be a cross between the current 2017 sierrA Denali 1500 headlights and the headlights on the Yukon. (Sierra shape housing with Yukon style internals)

As long as they don’t start pushing turbo’d v6 in their trucks I think they will be nice.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 11/7/2017 at 9:28 AM, 2017SierraSLT said:

Not impressed. Glad I bought the one I have.

My brother is probably thinking the same thing. He bought a '16 last year.

Share this post


Link to post
Share on other sites
13 hours ago, Black Denali Canada said:

They are doing embossed / raised lettering in the tailgate. Similar to the old retro pickups.

“GMC” and “CHEVROLET”
 

Bummer.  I never was a fan of those.  Makes deleting difficult. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By Roberto
      Hi Everyone,
       
      I could have sworn I already posted this, but I can't find it anywhere.  My 2015 GMC Sierra All Terrain SLT 1500 truck's media center seems is glitchy, it's either that or I have a haunted truck.  I'll be driving and my radio display and my odometer display will randomly start selecting items and cycling through the menu, it will randomly change stations, and one time it even selected voice command, all without any input. Anyway,  I've experienced this issue before and I took it to the dealer and while they told me they had never heard or seen the issue before they suggested that they would perform a software / firmware update on my infotainment / intellilink system to see if that would fix the issue and it worked.... for a few months, now it's back.  I was wondering if anyone here has experienced the same thing and if they were able to find a permanent fix for it?  It is absolutely annoying and very distracting.  I have searched this forum and I haven't seen a post from a member that has the same thing that I have experienced.  Any help would be appreciated, I'd like to have a permanent fix for this once and for all.  I've include a video of what's going on. 
       
       
    • By Jared_bennett
      Alright so I’ve been wanting to to the 6l80 swap in my 2011 rcsb 4.8/4l60 for a while now. Not for gas mileage or anything like that, simply because I want to. I am capable of doing the swap and have a tuner, just need to know what all is needed. Thanks!
    • By Tyler Sywyk
      Hello, I own an 08 GMC Sierra 2500HD Diesel Crew Cab Long box pick up, it's throwing a display message, but not giving me any codes, the message is service trailer brake system, it used to show that message and then I had it brought into the shop the second of July and they replaced the trailer break relay in the rear, had to change out some eye connectors at the fuse box. They also replaced the fuse. Worked great again from then to about a three weeks ago and this was including an 11 000km trip towing the trailer, it brought the message up again. The truck had been sitting and driven every once and a while, a bit of idling this winter as well, but no towing. so I replaced the fuse because it looked blown. After replaced it work fine again no more message thought maybe wet weather caused it. Now unfortunately now again yesterday I went to use it again and the message comes up, it was just recently used a few days ago and no message, today we have some dense fog as well as some rain. I think it only happens when it rains heavy or fog.. I am not entirely sure on that though. I replaced the fuse in the fuse box for the (ITBC) The one I changed out before to get it to work, and this time it did not work and nothing changed on the dash message still up.  I can more than easily replace the Relay without any issues, but I don't want to do that if it is just going to create the exact same issue. Any ideas on what might be causing this?
       
      Also on a side note, whenever I start the truck it puts out grey smoke until it has warmed up passed about 79-85 degrees Celcius (174F-187F), which is normally after driving for about 5 mins 10 at most or letting it high idle until that temp, it also does smoke when driving until warmed up. it never puts out black or blue smoke. Its grey, just as it is on a cold day in a gas engine. today we've reached the highest temp lately about 8 degrees Celcius and it still smoked. It never did this in the summer or fall just after it got cold. So I am just wondering if this is normal or if something is causing this to happen when it shouldn't be. Could it be something  as simple as it needing an oil change? Or also does it need a long drive at highway speed to deal with burn cleaning the DPF? I am a new owner to this pickup, and it is my first year with it so I am new to diesel's and don't know what to expect from them.
       
      Any help Is much appreciated!
       
       
    • By BlackKnightSierra
      Hey Guys!
       
      Have not been able to find a site where you can submit your mods and have them post it without buying their products or going through some ridiculous process.  I have created: https://thegaminggalago.wixsite.com/mycompletemodlist
      to get the ball rolling.  Please share it amongst people on here and in your car clubs, it would be GREATLY appreciated!
       
      Thanks,
      Connor
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    193,696
    Total Topics
    2,043,907
    Total Posts
  • Member Statistics

    161,431
    Total Members
    8,960
    Most Online
    Bad_Asp
    Newest Member
    Bad_Asp
    Joined
  • Who's Online   100 Members, 0 Anonymous, 587 Guests (See full list)

×

Important Information

By using this site, you agree to our Terms of Use.