Jump to content

Recommended Posts

I bought a used 2015 Silverado 2500HD Duramax exactly one month ago today, Dec 12th 2017.  Truck has 58K miles on it. The alignment was off a bit and the steering wheel was crooked, to the right about 15 degrees. I didn't bother having it taken care of right away because I knew I was going to lift it and it would need to be aligned after the lift. Had the lift installed Dec 27th.  with no issues. I have driven the truck about 300-400 miles since having the lift installed but today was the first chance I've had to get it in the shop to have it aligned. When I took it in I had no issues what so ever. Upon leaving after the alignment was done I now have a service stabilitrak warning that pops up as soon as I start the truck and the warning light stays on. Again no issues prior to the alignment. Alignment is perfect now and the steering wheel is straight. I called the shop but the tech that did the alignment had already left for lunch. He called me when he returned and said yes the warning came up after the alignment and that anytime they do an aligment they have to reset the steering position sensor to zero, however he couldn't communicate with the sensor so he was unable to reset it. I guess this would indicate a faulty steering position sensor but I have a hard time believing that since everything was fine prior to the alignment. Any ideas what this could be? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.