Jump to content



Photo
- - - - -

1999 Suburban O2 sensor,which one??


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 ace3166

ace3166

    Enthusiast

  • Newbie
  • 18 posts

Posted 11 February 2004 - 02:55 PM

I have a 1999 GMC Suburban K1500 5.7L and get this trouble code:
P0141 O2 sensor heater circuit malfunction (bank 1-sensor 2)

Can somebody verify which sensor it would be? There are 4 of them. Don't want to replace all four as the truck has only 58K and the sensors are supposed to be good for 100k.

Thanks!!

#2 Frank S

Frank S

    Senior Enthusiast

  • Member
  • 3,895 posts
  • Gender:Male

Posted 11 February 2004 - 03:00 PM

Check your fuse panel and make sure that it isn't just a blown fuse.I had the code some up for my heater circuit on B1S1 and it was just a fuse that I didn't even know existed.
Retired 07/24/11

#3 ace3166

ace3166

    Enthusiast

  • Newbie
  • 18 posts

Posted 12 February 2004 - 09:22 AM

Thanks, I will check that out. Anyone else know which sensor it is in case I have to replace it??

Also I which fuse panel?? under hood or inside vehicle?

Edited by ace3166, 12 February 2004 - 10:45 AM.


#4 ace3166

ace3166

    Enthusiast

  • Newbie
  • 18 posts

Posted 12 February 2004 - 01:45 PM

All fuses are good,just need location of this O2 sensor...Somebody has to know.......

#5 dieselman

dieselman

    Enthusiast

  • Newbie
  • 23 posts

Posted 12 February 2004 - 08:22 PM

Drivers side after the cat