Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

 

:cheers: I have a 2002 K1500 XCab, 5.3 and LS Model.. So this morning my trusty windshield replacement company comes to the office to replace my windshield. No worries right? Well when I leave for lunch I use the AC and low and behold I have a new noise coming from the blower fan. Sounds like there is something caught in there or something. I used the AC yesterday and have never had a problem before. I had the glass replaced a year ago wioth no worrries either. I called the glass co but when the guy came back out he said he wasn't anywhere near the vent's etc and does not know what it could be. I am worried that I'll have to pull the entire dash etc to get to the issue. Do my buddies @ gm-trucks.com have any suggestions? Thanks guys.....

Share this post


Link to post
Share on other sites

Could something have fallen down the defrost vents and became stuck in the piping for whole AC system?

Have you tried the blower motor, with out the AC off to rule anything else out?

Share this post


Link to post
Share on other sites

This happened to me also. It was a leave that had gotten into the fan from the fresh air intake.

Share this post


Link to post
Share on other sites

Thanks for the ideas. I have tried it without the AC (Compressor) on and there is no difference. I like the idea tof the fresh air intake though. How do I uncover that

to clean it out? :cheers:

Share this post


Link to post
Share on other sites

  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.