Jump to content

Archived

This topic is now archived and is closed to further replies.

Recommended Posts

HI alljust have a few questions, Just got my new 04 SSC Silverado. Just wondering why my 02 5.3 was a rocket and this new one is such a dog. I know my02 had 4.10 gears and this one has 3.73 didnt think it should make that much diffrence. This truck has Corsa exhausts, which i kinda like the sound but dont think its doing much for power. thinking about the Hypertech programer and the K&N filter kit. Will that make a seat of the pants diffrence. TIA Darryl :thumbs:

Share this post


Link to post
Share on other sites

I'll count myself in, again. My 04' GMC Sierra Z71 3:73 is very tired. I have replied to a couple of post similar to yours with this performance problem, not to mention my three post I have wrote about this terd engine. :thumbs:

My truck feels like a:

-------- 4cly. when temperture outside is about 90deg. and above.

--------6cly when temp. is below 80 deg.

-------one day (the only day, since the 16000 miles I have put on)when temp. was about 70deg., felt like a supercharged V-10

Share this post


Link to post
Share on other sites

Ummm, something is wrong. This is a very zippy intermediate engine. Mine is completely stock in the exhaust and intake. Also, my motor was zippy before the Westers. All I use the Westers for is improved city economy and more power at lower RPMs for my usual city driving.

 

I really think you have something wrong. I'd have it diagnosed.

Share this post


Link to post
Share on other sites

i kno that my 2000 has the electronic drive by wire in it, and you need to hit the gas a good amount more than my 2002, with the old fashioned cable throttle. the 02 is much more responive and pulls much stronger, while the '00 just sort of drags sometimes unless i go down 3/4 to full throttle, and then she'll wake up. both trucks have 3.42s. i live in florida so a/c on all the time, and if i idle alot, in traffic or w/e, then the fan clutch is engaged so it can feel somewhat like a 6 cyl, but once i open them up and that clutch loosens up, they both run great. if i were you though, i would have it checked out, if its feeling that slow.

Share this post


Link to post
Share on other sites

Ditto,my new '04 runs great,I'd have it checked out :thumbs:

Share this post


Link to post
Share on other sites

Mine seems fast enough for a truck.. I raced an 03 V6 Auto Stang and beat it by a car length to about 55 or so from a stop.

 

I'm an 04 EC Z71 w/ 3.73

 

don't think that's too bad for a heavy truck.... :)

Share this post


Link to post
Share on other sites
i kno that my 2000 has the electronic drive by wire in it, and  you need to hit the gas a good amount more than my 2002, with the old fashioned cable throttle. the 02 is much more responive and pulls much stronger, while the '00 just sort of drags sometimes unless i go down 3/4 to full throttle, and then she'll wake up. both trucks have 3.42s. i live in florida so a/c on all the time, and if i idle alot, in traffic or w/e, then the fan clutch is engaged so it can feel somewhat like a 6 cyl, but once i open them up and that clutch loosens up, they both run great. if i were you though, i would have it checked out, if its feeling that slow.

I didnt think the 2000's had fly by wire. Or the 02's. I always thought that ETB was started in 2003. That and earlier model trucks with traction control had Electronic TB's.

Share this post


Link to post
Share on other sites

I was convinced that my new 5.3 was anemic. My wife's '03 5.3 in an identical Yukon rocks, with 20K miles. I had the dealer go over this new one, to no avail. There are no flashes or TSBs on this unit.

 

I will say that now with around 1000 miles, this '04 feels like it's opening up a bit. Maybe I need to drive it harder to set it straight.

Share this post


Link to post
Share on other sites

On the ETB trucks, torque managment actually closes the throttle blade. Instead of the PCM pulling timing during shifts the PCM closes the TB blade to reduce power between shifts.

Share this post


Link to post
Share on other sites

DITTO!

 

My 04 Crew Cab 5.3 is two seconds slower ( 0 to 60 ) than my 01 Silverado trade-in. Not to mention it gets 2 mpg less mileage. Same everything and a 3.73 limited slip. I have given it 2000 miles and that is enough. Its going to the shop

 

:thumbs:

Share this post


Link to post
Share on other sites

Cant take it anymore, Its going in the shop Saturday. I live on a dirt road and i did a little test. From a complete stop i put it in first, to the floor and wont even spin the tires. :thumbs:

Share this post


Link to post
Share on other sites

Something's definitely wrong. I can spin the tires and all sorts of other fun stuff from a dead stop in my 03 if I just press down on the pedal. Yeah, best thing to do is hop on the pedal when two senior citizens are sitting in their Caddy next to you :thumbs: . No mods to the intake or exhaust system - so it's completely stock. Just out of curiousity, did you take a test drive in the same truck you bought?? Was this sitting on a dealer's lot or did you order it?

Share this post


Link to post
Share on other sites

Doesn't sound so good. The 5.3L in my stock 04 Suburban can press your butt into the seat if you stomp on it and, more importantly, are willing to spend the $4 in gas. :thumbs:

 

04Yukon might also have a point.....maybe need to get some miles on the truck to blow the junk out, get in an oil change, and make it turn better.

Share this post


Link to post
Share on other sites

  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.