Jump to content



Photo
- - - - -

5.3 lack of power


This topic has been archived. This means that you cannot reply to this topic.
34 replies to this topic

#1 nepatsfn

nepatsfn

    Enthusiast

  • Newbie
  • 16 posts

Posted 22 August 2004 - 06:54 PM

HI alljust have a few questions, Just got my new 04 SSC Silverado. Just wondering why my 02 5.3 was a rocket and this new one is such a dog. I know my02 had 4.10 gears and this one has 3.73 didnt think it should make that much diffrence. This truck has Corsa exhausts, which i kinda like the sound but dont think its doing much for power. thinking about the Hypertech programer and the K&N filter kit. Will that make a seat of the pants diffrence. TIA Darryl :thumbs:

#2 misconduck

misconduck

    Enthusiast

  • Newbie
  • 10 posts

Posted 22 August 2004 - 07:58 PM

I'll count myself in, again. My 04' GMC Sierra Z71 3:73 is very tired. I have replied to a couple of post similar to yours with this performance problem, not to mention my three post I have wrote about this terd engine. :thumbs:
My truck feels like a:
-------- 4cly. when temperture outside is about 90deg. and above.
--------6cly when temp. is below 80 deg.
-------one day (the only day, since the 16000 miles I have put on)when temp. was about 70deg., felt like a supercharged V-10

#3 lrymal

lrymal

    Senior Enthusiast

  • Member
  • 1,991 posts
  • Location:Joaquin, TX
  • Gender:Male

Posted 22 August 2004 - 08:09 PM

Ummm, something is wrong. This is a very zippy intermediate engine. Mine is completely stock in the exhaust and intake. Also, my motor was zippy before the Westers. All I use the Westers for is improved city economy and more power at lower RPMs for my usual city driving.

I really think you have something wrong. I'd have it diagnosed.

-------------

2014 GMC 4WD SLT Crew Cab - Bronze

 

408637871.jpg


#4 joeman2199

joeman2199

    Enthusiast

  • Newbie
  • 63 posts

Posted 22 August 2004 - 09:52 PM

i kno that my 2000 has the electronic drive by wire in it, and you need to hit the gas a good amount more than my 2002, with the old fashioned cable throttle. the 02 is much more responive and pulls much stronger, while the '00 just sort of drags sometimes unless i go down 3/4 to full throttle, and then she'll wake up. both trucks have 3.42s. i live in florida so a/c on all the time, and if i idle alot, in traffic or w/e, then the fan clutch is engaged so it can feel somewhat like a 6 cyl, but once i open them up and that clutch loosens up, they both run great. if i were you though, i would have it checked out, if its feeling that slow.

#5 Pewter Pro-Tec

Pewter Pro-Tec

    Enthusiast

  • Newbie
  • 128 posts
  • Location:Hawaii

Posted 22 August 2004 - 11:09 PM

I agree with lrymal, my 03 5.3 runs very hard, I would have it checked out.

#6 MS3DALE

MS3DALE

    Senior Enthusiast

  • Senior Moderator
  • 14,904 posts
  • Name:Rich
  • Location:Carmichaels,Pa.
  • Gender:Male
  • Drives:'07 Silverado Z71 '11 Camaro SS '02 Saturn SC2

Posted 23 August 2004 - 05:44 AM

Ditto,my new '04 runs great,I'd have it checked out :thumbs:

sig1alternate.png
'07 SILVERADO Z71 LT2 "VortecMAX" 6-Liter,"Super-Duty" Auto Trans,9 1/2" rear-end w/3.73 G80 Locker,XM,On-Star,BOSE speaker system,Stabilitrak,Block Heater,Sunroof,18" ARE "Cannon" Wheels w/LT275/65R18 Goodyear Wrangler AT/S tires.
Custom tune by Justin at Black Bear,CORSA "Sport" exhaust system,EXTANG "Full-Tilt" snapless tonneau cover,Rough Country 1.5" front leveling kit,Fabtech 1" rear lift blocks,EZ-Down tailgate damper.
GM accessories...Hood Deflector,Molded Mud-Flaps,Ventvisors,Catch-All Floor-Mats,Bedrail Protectors,BedRug Bedliner & Bedmat,and a GM Performance Parts cold-air intake.

2011 CAMARO 2SS/RS - LS3/M6 - Inferno Orange Met. - HURST short-throw - Roto-Fab CAI - Kook's LTs - CORSA exhaust - Black Bear tuned (playtoy!)
2012 CRUZE 1LT - Blue Topaz Met. - RS pkg.- Convenience pkg. (work car!)

My Garage


#7 nepatsfn

nepatsfn

    Enthusiast

  • Newbie
  • 16 posts

Posted 23 August 2004 - 05:38 PM

Thanks to all who responded, Ill give it a little more time. Only 600 miles on her.

#8 BOFH-Z71

BOFH-Z71

    Enthusiast

  • Newbie
  • 34 posts

Posted 23 August 2004 - 05:46 PM

Mine seems fast enough for a truck.. I raced an 03 V6 Auto Stang and beat it by a car length to about 55 or so from a stop.

I'm an 04 EC Z71 w/ 3.73

don't think that's too bad for a heavy truck.... :)

#9 99Silver6.0

99Silver6.0

    Senior Enthusiast

  • Member
  • 1,941 posts
  • Location:Kansas

Posted 23 August 2004 - 06:30 PM

i kno that my 2000 has the electronic drive by wire in it, and  you need to hit the gas a good amount more than my 2002, with the old fashioned cable throttle. the 02 is much more responive and pulls much stronger, while the '00 just sort of drags sometimes unless i go down 3/4 to full throttle, and then she'll wake up. both trucks have 3.42s. i live in florida so a/c on all the time, and if i idle alot, in traffic or w/e, then the fan clutch is engaged so it can feel somewhat like a 6 cyl, but once i open them up and that clutch loosens up, they both run great. if i were you though, i would have it checked out, if its feeling that slow.

I didnt think the 2000's had fly by wire. Or the 02's. I always thought that ETB was started in 2003. That and earlier model trucks with traction control had Electronic TB's.

Edited by 99Silver5.3, 23 August 2004 - 06:42 PM.

Jared

EFILive-Corsa-AEM-Dynatech-Hotchkis-CK801-05 Fans
Posted Image

#10 04Yukon

04Yukon

    Enthusiast

  • Member
  • 44 posts

Posted 23 August 2004 - 07:21 PM

I was convinced that my new 5.3 was anemic. My wife's '03 5.3 in an identical Yukon rocks, with 20K miles. I had the dealer go over this new one, to no avail. There are no flashes or TSBs on this unit.

I will say that now with around 1000 miles, this '04 feels like it's opening up a bit. Maybe I need to drive it harder to set it straight.

Edited by 04Yukon, 23 August 2004 - 07:22 PM.


#11 99Silver6.0

99Silver6.0

    Senior Enthusiast

  • Member
  • 1,941 posts
  • Location:Kansas

Posted 23 August 2004 - 08:07 PM

On the ETB trucks, torque managment actually closes the throttle blade. Instead of the PCM pulling timing during shifts the PCM closes the TB blade to reduce power between shifts.
Jared

EFILive-Corsa-AEM-Dynatech-Hotchkis-CK801-05 Fans
Posted Image

#12 GritHead

GritHead

    Enthusiast

  • Newbie
  • 5 posts

Posted 30 August 2004 - 06:30 PM

DITTO!

My 04 Crew Cab 5.3 is two seconds slower ( 0 to 60 ) than my 01 Silverado trade-in. Not to mention it gets 2 mpg less mileage. Same everything and a 3.73 limited slip. I have given it 2000 miles and that is enough. Its going to the shop

:thumbs:

#13 nepatsfn

nepatsfn

    Enthusiast

  • Newbie
  • 16 posts

Posted 30 August 2004 - 06:43 PM

Cant take it anymore, Its going in the shop Saturday. I live on a dirt road and i did a little test. From a complete stop i put it in first, to the floor and wont even spin the tires. :thumbs:

#14 JimG

JimG

    Enthusiast

  • Newbie
  • 321 posts
  • Location:NJ

Posted 30 August 2004 - 07:18 PM

Something's definitely wrong. I can spin the tires and all sorts of other fun stuff from a dead stop in my 03 if I just press down on the pedal. Yeah, best thing to do is hop on the pedal when two senior citizens are sitting in their Caddy next to you :thumbs: . No mods to the intake or exhaust system - so it's completely stock. Just out of curiousity, did you take a test drive in the same truck you bought?? Was this sitting on a dealer's lot or did you order it?

#15 Supurban

Supurban

    Enthusiast

  • Newbie
  • 382 posts

Posted 30 August 2004 - 10:52 PM

Doesn't sound so good. The 5.3L in my stock 04 Suburban can press your butt into the seat if you stomp on it and, more importantly, are willing to spend the $4 in gas. :thumbs:

04Yukon might also have a point.....maybe need to get some miles on the truck to blow the junk out, get in an oil change, and make it turn better.




Advertise Here