Jump to content



Photo
- - - - -

Turn signal thinks it's the 4 way flasher!


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 CardGuy

CardGuy

    Enthusiast

  • Newbie
  • 24 posts

Posted 14 March 2005 - 01:16 PM

Could my problem be simple?

My 03 silverado left turn signal activates all 4 signals just like the flasher button. Here's the deal. It does this intermittantly and is getting worse. After I use the right turn signal, then I do a left signal I will get all 4 corners flashing. If I turn off the left signal and then turn on the left signal again it will work fine. It's just after a right signal that the left becomes all 4. Anyone have any ideas what could be wrong?

#2 71GMC_3/4T

71GMC_3/4T

    Enthusiast

  • Member
  • 483 posts

Posted 14 March 2005 - 04:45 PM

You've probably got a bad ground somewhere.
It could be either in the front or rear at the lamp housings. Most likely on the left side since it is the side acting up.
2003 K2500HD Crew Cab. Dark Carmine Red. 6.0, 4.10, Westin step bars, Michelin LTX, Fold-A-Cover
1971 GMC C2500. Blue/White. 402/TH400/4.10

#3 99-2door

99-2door

    Senior Enthusiast

  • Member
  • 1,933 posts
  • Location:Broken Bow, OK

Posted 14 March 2005 - 05:40 PM

Yep, bad ground on the radiator support most likely.

95 Chevy K3500 SRW converted to 5.7L Vortec 4L80e, 4.10 w/G80
2003 Tahoe w/ Silverado front clip
2001 GMC C3, 6.0L AWD, lowered 3/5, Volant intake, pulleys, tuned with HPtuners by me.

#4 CardGuy

CardGuy

    Enthusiast

  • Newbie
  • 24 posts

Posted 15 March 2005 - 01:15 PM

Thanks guys. I'll have to check into all grounds and see if that makes a difference.

#5 Mess

Mess

    Enthusiast

  • Newbie
  • 2 posts

Posted 30 March 2005 - 03:14 PM

Could my problem be simple?

My 03 silverado left turn signal activates all 4 signals just like the flasher button. Here's the deal. It does this intermittantly and is getting worse. After I use the right turn signal, then I do a left signal I will get all 4 corners flashing. If I turn off the left signal and then turn on the left signal again it will work fine. It's just after a right signal that the left becomes all 4. Anyone have any ideas what could be wrong?

<{POST_SNAPBACK}>



#6 Mess

Mess

    Enthusiast

  • Newbie
  • 2 posts

Posted 30 March 2005 - 03:17 PM

Has anyone ever figured out the exact problem with the left turn signal periodically activating the 4 way flashers? My '03 Yukon XL does the same thing. I've found several other web site discussion groups noting the identical problem, but nowhere do I see that anyone has figured it out.