Jump to content



Photo
- - - - -

02 8.1 liter vortec engine problem


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 dmc22

dmc22

    Enthusiast

  • Newbie
  • 3 posts

Posted 06 September 2005 - 12:48 AM

I have a 02 8.1 liter vortec motor with 12,000 miles. After it was sitting for a week, the service engine soon light came on when i started it. Then the reduce power mode light came on. I turned the car off and on again and the reduce power light went away. After getting gas the reduced power mode light came on and stayed on. I limped it to the dealer where its been sitting for a week waiting to get looked at. Any ideas, I don't want to be in the middle of no man's land and this happens.

Edited by dmc22, 06 September 2005 - 12:49 AM.


#2 Chev8.1

Chev8.1

    Enthusiast

  • Newbie
  • 118 posts

Posted 06 September 2005 - 04:36 AM

Really needs some codes first, but here are some ideas

about the only thing is if you lose the crank sensor and cam sensor, or something is up with ETB (e-throttle body) about only thing that I know that can cause a reduce power mode.

Is you truck stock?
HD Stands For HEMI DESTROYER, 2001 8.1HD,REGCAB,WMP air intake,powertrax front locker,33x10.5x16 mud tires,westers ecu programming.Comp Cams XR 270 cam, WMP diesel style cat back,WMP Ram Air box conver.

#3 dmc22

dmc22

    Enthusiast

  • Newbie
  • 3 posts

Posted 06 September 2005 - 11:01 PM

The engine is stock. I had a prior problem with a leak in the transmission a couple of years ago, but no other problems.

#4 dmc22

dmc22

    Enthusiast

  • Newbie
  • 3 posts

Posted 15 September 2005 - 01:53 PM

It was a short in the electronic throddle body. They had to replace the modulator also.