Jump to content

Recommended Posts

I have a 2004 Avalanche. When I try to put gas into the tank any faster than a slow trickle, the pump cuts off. It seems like the line just won't take the gas any faster than the slowest possible flow rate. I've seen this at several different stations, so it isn't the pumps.

 

Any ideas?

Share this post


Link to post
Share on other sites

maybe your putting the pump nossel too far into the tank. Ive had that happen before, if you put it too far in the back pressure causes it to trigger...

Share this post


Link to post
Share on other sites

Document ID# 1811902

2004 Chevrolet Avalanche - 4WD

--------------------------------------------------------------------------------

Subject: Premature Pump Shut Off When Refueling - keywords 4.3 4.8 5.3 6.0 8.1 fill filler fuel hard hardtofill L18 L33 L35 L59 L76 LC9 LM7 LMG LQ4 LQ9 LR4 LY5 nozzle #PIT3961 - (04/05/2006)

 

Models: 2002-2007 Cadillac Escalade Models

2002-2007 Chevrolet Avalanche

1999-2007 Silverado, Suburban, Tahoe

1999-2007 GMC Sierra, Yukon Models

 

Equipped with a Gasoline Engine

--------------------------------------------------------------------------------

 

The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in this PI.

 

Condition/Concern:

Some customers may comment that when refueling at certain fuel stations / pumps that the fuel pump shuts off prior to completely filling the fuel tank. This is not a concern with the GM fuel system but is an industry wide issue with variation in OPW 11B fuel nozzles throughout the fuel station industry.

 

Recommendation/Instructions:

Until the fuel station industry can replace these nozzles with an improved versions, advise customers with this concern to try either another pump and/or another fuel station.

 

Please follow this diagnostic or repair process thoroughly and complete each step. If the condition exhibited is resolved without completing every step, the remaining steps do not need to be performed.

Share this post


Link to post
Share on other sites
Document ID# 1811902

2004 Chevrolet Avalanche - 4WD

--------------------------------------------------------------------------------

Subject: Premature Pump Shut Off When Refueling - keywords 4.3 4.8 5.3 6.0 8.1 fill filler fuel hard hardtofill L18 L33 L35 L59 L76 LC9 LM7 LMG LQ4 LQ9 LR4 LY5 nozzle #PIT3961 - (04/05/2006)

 

Models: 2002-2007 Cadillac Escalade Models

2002-2007 Chevrolet Avalanche

1999-2007 Silverado, Suburban, Tahoe

1999-2007 GMC Sierra, Yukon Models

 

Equipped with a Gasoline Engine

--------------------------------------------------------------------------------

 

The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in this PI.

 

Condition/Concern:

Some customers may comment that when refueling at certain fuel stations / pumps that the fuel pump shuts off prior to completely filling the fuel tank. This is not a concern with the GM fuel system but is an industry wide issue with variation in OPW 11B fuel nozzles throughout the fuel station industry.

 

Recommendation/Instructions:

Until the fuel station industry can replace these nozzles with an improved versions, advise customers with this concern to try either another pump and/or another fuel station.

Please follow this diagnostic or repair process thoroughly and complete each step. If the condition exhibited is resolved without completing every step, the remaining steps do not need to be performed.

You don't need another pump or station...like HuntingEd stated, just don't put the nozzle in so far.

-Jay

Share this post


Link to post
Share on other sites

You don't need another pump or station...like HuntingEd stated, just don't put the nozzle in so far.

-Jay

 

=================================================

 

That's not it. If I pull the nozzle back out any farther, I'll be spraying gas on the ground.

 

I don't have this problem, with the same pumps, with my Suburban or Silverado, just the Avalanche.

Share this post


Link to post
Share on other sites

Must be what bobcat said, maybed try putting it in further or look into some type of aftermarket fuel tank... I dont have an avalanche so i cant help to much...

Share this post


Link to post
Share on other sites

maybe your putting the pump nossel too far into the tank. Ive had that happen before, if you put it too far in the back pressure causes it to trigger..

 

It was the same problem that i have encountered with my GM fuel tank, don't put the pump nossel too far into the tank... or much better if your going to replace it, a aftermarket fuel tank would do.

Share this post


Link to post
Share on other sites

Dont feel bad

 

I have a 04 burb and had the same exact problem. Everyone told me to do this, do that, it turns out to be the gas station. Speaking about gas tanks I had mine replaced by the dealer under warrenty. Everytime I filled it it would over fill and leak our of the tank by the sender. they tried to fix it 3 times until that gas tank was done. Have to wait a see if thats it as im picking it up today.

 

 

Scott

Share this post


Link to post
Share on other sites

I GOT THE SAME PROB. WITH FUELING MY 2005 8.1 DUALLY! IT TAKE 1/2 HOUR TO FILL THE DANG THANG UP, ITS CONSTANTLY SHUTING OFF THE FUEL NOZZEL. THE ONLY TIME I HAVE EVER BEEN ABLE TO GET FUEL IN IT HALF WAY FAST IS BY PUMPING IT IN FROM THE BED MOUNTED AUX. FUEL CELL. IT SUCKS NOT TO BE ABLE TO PULL UP AND PUMP GAS LIKE NORMAL. MOST OF THE TIME I FILL UP THE FUEL CELL AND FORCE FEED THE TRUCK TANK WITH THE FUEL CELL ELECTIC PUMP. THERE HAS GOT TO BE A BETTER WAY. HOW CAN I JUST BYPASS THE EVP CAN??

Share this post


Link to post
Share on other sites

its most likely the solinoid valve at the tank /filler hose or the Evaporator canister is blocked up.

The dealer told me there was a TSB on this. Its not the occational gas pump clicking off but clicking off every second! Can't hardy pump any gas.

 

Jim

 

http://chevyavalanch...w;topicseen#new

 

http://www.chevyaval...g65336#msg65336

Edited by jimmypsp700

Share this post


Link to post
Share on other sites

My '09 HD does the same thing but only at some stations. Then I got a SES code and took it to the dealer to see what it was? Evap sol. they fixed it and I asked if that could have been my fuel slow

problem? they said yes. Went to the station later where it has had the slow fill problem and....

Yep still clicks off. Other stations it's fine?? Now the problem with pulling the nozzel out is some of

the stations now have that large vapor recovery hose and if you don't push the hose tight to the filler neck the fuel won't flow !

Share this post


Link to post
Share on other sites

Well in california my truck does this, but because of emissions and bad air we have vapor recovery nozzles so id too much builds up it clicks off

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.