Jump to content



Photo
- - - - -

'99 Silverado Brake Controller, Plug & Play?


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 JimChooz

JimChooz

    Enthusiast

  • Member
  • 51 posts

Posted 16 March 2008 - 12:25 PM

I have a '99 Silverado 5.3 Z71. Does anyone know if it's set up for "Plug & Play" trailer brake controller?

Thanks. Jim

#2 BlueGorilla

BlueGorilla

    Enthusiast

  • Member
  • 264 posts

Posted 16 March 2008 - 02:38 PM

I have a '99 Silverado 5.3 Z71. Does anyone know if it's set up for "Plug & Play" trailer brake controller?

Thanks. Jim

Jim, it should be. Just be carefull to get the proper harness for the early configuration.
General Motors Grand Master Technician
VISIT ME AT http://www.justanswe...=...orilla&bt=0
Ask for Blue Gorilla in the Chevy Category.




#3 JimChooz

JimChooz

    Enthusiast

  • Member
  • 51 posts

Posted 16 March 2008 - 02:41 PM

I have a '99 Silverado 5.3 Z71. Does anyone know if it's set up for "Plug & Play" trailer brake controller?

Thanks. Jim

Jim, it should be. Just be carefull to get the proper harness for the early configuration.


Thanks a bunch Blue!

#4 JimChooz

JimChooz

    Enthusiast

  • Member
  • 51 posts

Posted 17 March 2008 - 11:47 PM

I have a '99 Silverado 5.3 Z71. Does anyone know if it's set up for "Plug & Play" trailer brake controller?

Thanks. Jim

Jim, it should be. Just be carefull to get the proper harness for the early configuration.


Blue G,

Checked and I have a harness already plugged in and 18" of labeled wires under the dash. It will be a breeze!

Thanks.

#5 BlueGorilla

BlueGorilla

    Enthusiast

  • Member
  • 264 posts

Posted 18 March 2008 - 11:25 AM

Good to hear.
General Motors Grand Master Technician
VISIT ME AT http://www.justanswe...=...orilla&bt=0
Ask for Blue Gorilla in the Chevy Category.




#6 JimChooz

JimChooz

    Enthusiast

  • Member
  • 51 posts

Posted 19 March 2008 - 08:50 PM

Picked up a Draw-tite Controller, wired it up to my harness. All is good, no trailer on yet, picking that up 2 states away next weekend but controller display says all wired ok at truck end.
Question............ why is there a brown illumination wire coming from harness but no place to go on controller????

#7 BlueGorilla

BlueGorilla

    Enthusiast

  • Member
  • 264 posts

Posted 19 March 2008 - 09:49 PM

I have been asking that question for a long time. It may have been to confuse us when they switched that wire for the brake switch input in 2003. Long story short, if you turned on your lights, the trailer brakes would lock up. Messy!
General Motors Grand Master Technician
VISIT ME AT http://www.justanswe...=...orilla&bt=0
Ask for Blue Gorilla in the Chevy Category.




#8 BlueGorilla

BlueGorilla

    Enthusiast

  • Member
  • 264 posts

Posted 19 March 2008 - 09:50 PM

Oh, Ignore that brown wire. as long as it is not hooked up to anything, your fine.
General Motors Grand Master Technician
VISIT ME AT http://www.justanswe...=...orilla&bt=0
Ask for Blue Gorilla in the Chevy Category.




#9 JimChooz

JimChooz

    Enthusiast

  • Member
  • 51 posts

Posted 19 March 2008 - 10:00 PM

Oh, Ignore that brown wire. as long as it is not hooked up to anything, your fine.



I'll try to ignore it............ but..... but..... I'm a male....... wire just hanging there..... it must, must....... OK.
Taped off.

Thanks Blue G




Advertise Here