Jump to content

Archived

This topic is now archived and is closed to further replies.

  • 0
jambo726

89 Gmc Sierra 5.7 Won't Start, No Spark

Question

89 GMC Sierra 2WD, 5.7 AT

Newly installed GM crate OEM motor 2 mos ago

New Optima yellow top battery

Alternator and starter are new

New plugs, Taylor 8.5 wires, new cap and rotor

All was well after install

 

Recently engine began stumbling and then just quit running

 

 

Engine will crank but will not fire

I can hear the fuel pump when the key is switched on. When the fuel line is disconnected from the the throttle body and the engine is cranked, fuel spurts out of the line.

 

Fuel filter changed->cranks but will not start, no spark

 

Coil changed to MSD OEM->cranks but will not start, no spark

 

Hooked up a spark tester between spark plug and plug wire to see if the light comes indicating a spark->still cranks but not start and no spark

 

So, It gets fuel, there is gas in the tank(1/2 tank), fuel delivery is OK, coil is OK, new plugs, cap, rotor, battery.

 

Since it cranks but will not start and there is no spark, could it be the IGNITION CONTROL MODULE or NEUTRAL SAFETY SWITCH?

 

Thanks for your help

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

89 GMC Sierra 2WD, 5.7 AT

Newly installed GM crate OEM motor 2 mos ago

New Optima yellow top battery

Alternator and starter are new

New plugs, Taylor 8.5 wires, new cap and rotor

All was well after install

 

Recently engine began stumbling and then just quit running

 

 

Engine will crank but will not fire

I can hear the fuel pump when the key is switched on. When the fuel line is disconnected from the the throttle body and the engine is cranked, fuel spurts out of the line.

 

Fuel filter changed->cranks but will not start, no spark

 

Coil changed to MSD OEM->cranks but will not start, no spark

 

Hooked up a spark tester between spark plug and plug wire to see if the light comes indicating a spark->still cranks but not start and no spark

 

So, It gets fuel, there is gas in the tank(1/2 tank), fuel delivery is OK, coil is OK, new plugs, cap, rotor, battery.

 

Since it cranks but will not start and there is no spark, could it be the IGNITION CONTROL MODULE or NEUTRAL SAFETY SWITCH?

 

Thanks for your help

 

 

Sounds like the ignition module in the dsitributor...run it down to Autozone..they'll test it free.

Share this post


Link to post
Share on other sites
Sounds like the ignition module in the dsitributor...run it down to Autozone..they'll test it free.

 

Hey ziptow,

I think I will pick up an ignition module and a OBD-1 code reader to see what codes it has thrown. I am assuming the code reader should pick up a failed ignition module vs a bad neutral safety switch. Will let you guys know what it was.

Share this post


Link to post
Share on other sites

Well, just got done. I removed the old ignition module and replaced it with the new one. Buttoned everything back up. It fired up on the first try. Did not have to install the neutral safety switch. OBD-1 code reader had no codes afterwards. All is good tonight. It did need a new fuel filter and the MSD coil although not the problem made the truck start better. I think the cause may have been that one of the ignition wires on the distributor was not seated fully causing there to be a gap that need additional juice to jump across. Maybe not but it runs great now. Thanks ziptow!!!! You were spot on...... This forum rocks!!!!!!

 

cheers.gif

 

Sounds like the ignition module in the dsitributor...run it down to Autozone..they'll test it free.

 

Hey ziptow,

I think I will pick up an ignition module and a OBD-1 code reader to see what codes it has thrown. I am assuming the code reader should pick up a failed ignition module vs a bad neutral safety switch. Will let you guys know what it was.

 

Share this post


Link to post
Share on other sites

ADSENSE FOOTER
  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.