Jump to content

Archived

This topic is now archived and is closed to further replies.

02silveradols

Speedometer Not Working...

Recommended Posts

My speedometer stopped working on my way home from work. It slowly went down to zero and wouldn't move. Everything else works fine other then that. I took the truck out about 30 minutes later and it worked fine. Anyone know whatit could be. Its an 04 with 67,000 miles on it. Thanks

Share this post


Link to post
Share on other sites
My speedometer stopped working on my way home from work. It slowly went down to zero and wouldn't move. Everything else works fine other then that. I took the truck out about 30 minutes later and it worked fine. Anyone know whatit could be. Its an 04 with 67,000 miles on it. Thanks

 

GM has acknowledged an issue on 03/04 trucks and is fixing them for free (up to 70K miles I believe?). There is a "special service policy" out about this (as my dealer called it). I know because I had heard something about this and called my dealer to see if my wife's 04 Impala was included. Unfortunately, for me anyway, it's only for the trucks.

 

Call your dealer.

Share this post


Link to post
Share on other sites

That problem is very common on 2003-2006 Silverado & Suburban's. My 2003 Suburban speedometer stopped working everything else worked though, by the time I heard about getting it fixed under warranty I had already gotten rid of it.

Share this post


Link to post
Share on other sites

Now it's working again, will they replace it if I tell them it works and it doesnt work? Comes on and off. I'm right at the 70,000 mile marker. Thanks guys

Share this post


Link to post
Share on other sites

I would try getting it fixed under warranty ASAP, while u still can. Just cause it was working right now doesn't mean it is fixed.

Share this post


Link to post
Share on other sites
Now it's working again, will they replace it if I tell them it works and it doesnt work? Comes on and off. I'm right at the 70,000 mile marker. Thanks guys

 

Take it in. You won't have a problem getting it replaced.

Share this post


Link to post
Share on other sites
Now it's working again, will they replace it if I tell them it works and it doesnt work? Comes on and off. I'm right at the 70,000 mile marker. Thanks guys

 

Take it in. You won't have a problem getting it replaced.

 

 

Mine would drop to 0 then it worked fine, now it is stuck at 120mph, I have a 05 sierra with 87000km, i am getting no where with gm cs, if the dealer cant take care of it i will be signing on to the class action lawsuit, and have a magnetic sign made for my truck, it will tell potential buyers of GM Quality Products to talk to me before they purchase a GM product. Should have stuck with the Jap Crapp

Share this post


Link to post
Share on other sites

Mine would drop to 0 then it worked fine, now it is stuck at 120mph, I have a 05 sierra with 87000km, i am getting no where with gm cs, if the dealer cant take care of it i will be signing on to the class action lawsuit, and have a magnetic sign made for my truck, it will tell potential buyers of GM Quality Products to talk to me before they purchase a GM product. Should have stuck with the Jap Crapp

Share this post


Link to post
Share on other sites
Mine would drop to 0 then it worked fine, now it is stuck at 120mph, I have a 05 sierra with 87000km, i am getting no where with gm cs, if the dealer cant take care of it i will be signing on to the class action lawsuit, and have a magnetic sign made for my truck, it will tell potential buyers of GM Quality Products to talk to me before they purchase a GM product. Should have stuck with the Jap Crapp

 

 

Its not too late. I am sure Toyota or Nissan have plenty of un-sold trucks on their lots :lol:

Share this post


Link to post
Share on other sites
Mine would drop to 0 then it worked fine, now it is stuck at 120mph, I have a 05 sierra with 87000km, i am getting no where with gm cs, if the dealer cant take care of it i will be signing on to the class action lawsuit, and have a magnetic sign made for my truck, it will tell potential buyers of GM Quality Products to talk to me before they purchase a GM product. Should have stuck with the Jap Crapp

 

 

Its not too late. I am sure Toyota or Nissan have plenty of un-sold trucks on their lots :mad:

 

 

 

+1

 

And every single one of them is 100% perfect and flawless. :lol:

 

:fume:

Share this post


Link to post
Share on other sites

I got a letter for my 04 advising that all instrument clusters with speedo problems will be replaced up to 70k miles free of charge.

Share this post


Link to post
Share on other sites

I got a letter for my 04 advising that all instrument clusters with speedo problems will be replaced up to 70k miles free of charge.

mine is a 05 with 55k, gm wont replace even though it is same part # as 04

Share this post


Link to post
Share on other sites

I had the same issue with my '04 Yukon and it is out of warranty. The fuel gauge stopped working and was stuck on empty. I took it in after reading about it being a problem from this forum. I dropped it off and they checked it out and replaced it in about 20 minutes. They told me there were issues with the earlier gauges and it had a 70k warranty on it for that.

 

and I was all prepared to buy a new aftermarket cluster gauge which would have looked much nicer :lol:

but you cant beat free.

Share this post


Link to post
Share on other sites

Mine just did this stuck at zero thing today. Worked fine the next time out. I'm at 76,000 miles. Any chance they replace it anyway. I know, I know call the dealer and ask. Can't hurt.

Share this post


Link to post
Share on other sites

ADSENSE FOOTER
  • Popular Now

×

Important Information

By using this site, you agree to our Terms of Use.