Jump to content



Photo
* * * * * 1 votes

Left Side Trailer Brake Light Not Working


  • Please log in to reply
43 replies to this topic

#31 KTM200

KTM200

    Enthusiast

  • Newbie
  • 1 posts

Posted 24 August 2009 - 07:44 PM

there are fuses for the trailer under the hood and in the fuse compartment on the driverside dash, I would check both, is there another truck to plug the trailer into to see if it works correctly. Also just as a shot check the bulb in the trailer the bulb should have 2 filaments, one for turn the other for stop, one filament could be burnt out and the other still good, worth a shot.


7 pin was factory installed. I will check both fuse compartments again, but I'm almost 100% sure they were all good. I will let you know what I come up with.


I have an 04 pickup with exactly the same problem, I hope someone can help. Diferent trailers do the same thing.

#32 Pizzadb

Pizzadb

    Enthusiast

  • Newbie
  • 2 posts

Posted 12 February 2010 - 12:19 AM

I just had this exact same problem with my '05 Sierra 2500HD myself and it was the LCM (Light Control Module aka Turn Signal/Hazard Flasher Module). To get to it you have to remove the beauty panel below the steering wheel. Once you remove the panel you will see the module directly behind the fuse box at the bottom of the box (the fuse box faces towards the drivers door, and the LCM faces towards the steering column).

To remove it pull it straight out towards the steering column (it is black in color, has 10 blades, slides in and out like a fuse would and the end you can see measures 1" x 2-3/4").

Part #'s:

GM OEM: 15764135 (about $90 from a dealer)

Napa Auto Parts (OEM Replacement): LM-455 ($32.99)
Napa Auto Parts (LED Compatible): LM-487 ($76.99)

Hope this helps!



#33 Pizzadb

Pizzadb

    Enthusiast

  • Newbie
  • 2 posts

Posted 12 February 2010 - 12:28 AM

I just had this exact same problem with my '05 Sierra 2500HD myself and it was the LCM (Light Control Module aka Turn Signal/Hazard Flasher Module). To get to it you have to remove the beauty panel below the steering wheel. Once you remove the panel you will see the module directly behind the fuse box at the bottom of the box (the fuse box faces towards the drivers door, and the LCM faces towards the steering column).

To remove it pull it straight out towards the steering column (it is black in color, has 10 blades, slides in and out like a fuse would and the end you can see measures 1" x 2-3/4").

Part #'s:

GM OEM: 15764135 (about $90 from a dealer)

Napa Auto Parts (OEM Replacement): LM-455 ($32.99)
Napa Auto Parts (LED Compatible): LM-487 ($76.99)

Hope this helps!


I have the same problem 03 2500hd diesel. I have been tying to solve this one for a few days now, i have called gm and talked to service tech and parts department and no one had any idea of a control module. Looks to be a common problem with everyone having the left side blinker working but not the brake light, you would think someone at gm would have a little more info. Thanks again!

#34 scorepn

scorepn

    Enthusiast

  • Newbie
  • 1 posts

Posted 25 February 2010 - 10:00 AM

There was a lot of good suggestions here - did any ONE solve the problem of the left trailer brake light not working?


Bob
2004 GMC 2500HD SLT

#35 kalanbays

kalanbays

    Enthusiast

  • Newbie
  • 1 posts

Posted 31 May 2010 - 10:34 PM

I have 2005 Silverado, which I purchased new. I have used it for the last four years to tow an RV, with no problems. This years I hooked it up to my RV (7 pin) and the following occurred:

The truck lights work fine. The problem is definately in the trailer part of the truck:

Right turn signal on blinks both right and left (on the trailer only, the truck light work correctly
Left signal on, the trailer's left signal only blinks as it should
Brakes on, only the right trailer light comes on.

I thought this could be a problem with the trailer, but it does it with three different trailers.

I disassembled the truck end 7 pin, and with a test light got the same problems when touching the relative contacts.
Someone mentioned a controller, what is this and where is it?

Thanks,

#36 JOEPLAZEK

JOEPLAZEK

    Enthusiast

  • Newbie
  • 1 posts

Posted 14 November 2010 - 04:20 PM

Thanks to the internet and this site I saved my sanity. I ask myself why I don't go to the net first but I guesstorture is my thing. I have a bunch of GMC DURAMAX DIESEL trucks through our business but never seen a problem witha left trailer brake light not working. I got really tired of everyone telling me my left brake light wasn't working (never the less the legal implications) It is the plug in module right behind the under dash fuse block and was an easy fix (this after I chased all the wiring with a test light through the whole truck and found I had nothing all the way to the front) I have a little bit of an advantage in owning a recycling yard and now I carry a spare in the centre console!!! 15764135 2/4-w/opt trailering .

Attached Files



#37 pavwa

pavwa

    Enthusiast

  • Newbie
  • 2 posts

Posted 02 December 2010 - 09:33 AM

I have the same problem with my 04 chevy 2500with the left trailer brake light... Can anyone tell me if the flasher module is surely the problem? Ive been chasing this problem for a couple months after the sheriff pulled me over and went through all my USDOT regulations,so I really need to fix this soon..Thanks

#38 mephisto

mephisto

    Enthusiast

  • Newbie
  • 2 posts

Posted 05 December 2010 - 01:54 AM

I have the same problem with my 04 chevy 2500with the left trailer brake light... Can anyone tell me if the flasher module is surely the problem? Ive been chasing this problem for a couple months after the sheriff pulled me over and went through all my USDOT regulations,so I really need to fix this soon..Thanks



I have a similar problem, My left turn signal and brake light work intermitly on my 2004 GMC 2500. The truck lights are ok but the trailer lights are not working. :P

#39 akram

akram

    Enthusiast

  • Member
  • 49 posts

Posted 18 April 2011 - 10:04 PM

If anybody is still following this thread I have an 07 2500 Silverado classic where the right turn signal and brake trailer light does not work. There is no power to green wire on the bumper plug. I have tail lights on that side but not stop or turn. Does the module mentioned above exist on my gas model too? I removed the dash cover and see the fuses there, would the module be there or is it tucked up under the dash hidded somewhere, if it exists at all?

#40 denalibird

denalibird

    Enthusiast

  • Newbie
  • 1 posts

Posted 04 May 2011 - 06:53 PM

I had the same issue my trailer lights signals worked but my brake lights on both sides would not work. The answer was replaceing the flasher contrill module under my steering column. I have a 2003 denali XL drove me crazy rewired the trailer and tried everything. 37 dollars at NAPA.

Jonathan

#41 akram

akram

    Enthusiast

  • Member
  • 49 posts

Posted 04 May 2011 - 09:12 PM

Of all things it ended up being the fuse to the right side trailer light. Sometimes you overlook the obvious.

#42 skinnerd

skinnerd

    Enthusiast

  • Newbie
  • 2 posts

Posted 25 July 2011 - 09:35 PM

I found this issue on my 2004 silverado about 2 months ago. in my case everything works on the trailer works except the right brake lamp.

So i thought about it logically. the signal works on the same circuit as the brake on the trailer so the trailer is ok.
the signal is working from the truck so that circuit is working. The brake and signal on the truck are on 2 different bulbs therefore there must be a converter box so the trailer can luminate both functions on one bulb.

But where is the converter? Dealer has no idea what im asking for and told me to check all fuses. I double checked and all are good.

I searched the truck unable to find it until i read this forum tonite. This will correct the problem 100% sure.

I will post results as soon as it is repaired with best price i find and dificulty to replace and where i find the best price.

If someone has the time i wish they would look into weather gm had any recall on this issue, it sure seems like its a common problem that they should have addressed.

Skinner

#43 skinnerd

skinnerd

    Enthusiast

  • Newbie
  • 2 posts

Posted 26 July 2011 - 03:44 PM

Ok heres what i found.

The part shown earlier is correct #15764135 and this is the correct gm number. It has been subed to 10383321.

If you are looking for this part from gm expect about 90-115 dollars and you should quote the part # because they dont seem to know where to find it. I think the reason is the discription name varries by manyfacturer.

I located some aftermarket ones at misc prices. Best was $47.00 at carquest up to $74.00 at benson. All places could not find unless i quoted the part number for cross reference.

I purchased mine from an auto wrecker in my area for $25.00 cash. Was asking 40 but when i told him the new aftermarket was 47.00, he dropped to 25.

The unit i retrieved from the wreckers had the new part # on it and from what i understand, the newer one is LED compatable.

Now you need to remove the decorative plastic over the guages, then there are 2 screws at the bottom of the plastic pannel below the column to remove, the top of this pannel is snapped in place with clips.

after removing pannel, look on the back side of the fusebox located on the side of the dash below the headlanp switch.

it will be vertically mounted. because there are 10 pins on it you will have to pull and wiggle it slowly to remove it. Keep attention to the direction the pinsare when you remove it because its not ambidextrious. install replacement in reverse order.

Check all lights and everything should be back to normal.

Skinner

#44 xeroid

xeroid

    Enthusiast

  • Newbie
  • 1 posts

Posted 24 August 2011 - 09:17 PM

I also had this problem with my left brake light not working on my boat trailer when hooked up to my 2003 suburban 2500 HD.I removed the light control module behind the dashboard fusebox and found that the armature on one of the relay solenoids was binding on the plastic case that encases the solenoid. I freed up the armature and the problem was solved. Part # 15764135




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users