Jump to content



Photo
- - - - -

Timing On 1988 Gmc 1500 / 5.0


  • Please log in to reply
3 replies to this topic

#1 D_McQ

D_McQ

    Enthusiast

  • Newbie
  • 4 posts

Posted 02 May 2009 - 01:29 PM

Anyone know the timing setting on a 1988 GMC 1500 with a 305 (5.0)? Sticker is missing and no help through google. Know to disconnect wire at firewall but don't know the setting. Have found one post that says to set at 0 but that seems strange. Thanks - David

#2 redvett

redvett

    Senior Enthusiast

  • Member
  • 3,498 posts
  • Location:MI
  • Gender:Male

Posted 02 May 2009 - 02:55 PM

Yes all TBI engines 305 & 350 from 1987 to 1995 are set at zero with EST wire disconnected with engine at operating temp in "N"

Anyone know the timing setting on a 1988 GMC 1500 with a 305 (5.0)? Sticker is missing and no help through google. Know to disconnect wire at firewall but don't know the setting. Have found one post that says to set at 0 but that seems strange. Thanks - David



#3 dlewis1111

dlewis1111

    Senior Enthusiast

  • Member
  • 1,091 posts
  • Name:David
  • Location:Phenix City, AL
  • Gender:Male
  • Drives:2008 Silvefrado

Posted 03 May 2009 - 07:30 AM

+1 had a 1991 and sticker said 0 with the wire disconnected

Posted Image


#4 pennzoil29

pennzoil29

    The life I live, the cards I play, the hand that I just dealt

  • Member
  • 5,893 posts
  • Location:NE Ohio
  • Gender:Male

Posted 03 May 2009 - 08:12 AM

Yes all TBI engines 305 & 350 from 1987 to 1995 are set at zero with EST wire disconnected with engine at operating temp in "N"

Anyone know the timing setting on a 1988 GMC 1500 with a 305 (5.0)? Sticker is missing and no help through google. Know to disconnect wire at firewall but don't know the setting. Have found one post that says to set at 0 but that seems strange. Thanks - David




+1 had a 1991 and sticker said 0 with the wire disconnected


What they said. :cool:
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users