Jump to content



Photo
- - - - -

2000 Jimmy V6 Running Rich...?! Need Advice.


  • Please log in to reply
2 replies to this topic

#1 MB4x4

MB4x4

    Enthusiast

  • Member
  • 115 posts
  • Location:Manitoba, CA
  • Gender:Male

Posted 09 June 2009 - 11:26 AM

Well I just bought a 2000 GMC Jimmy 4.3L V6 and it throws two OBD codes:

P0172 Bank 1 running rich
P0175 Bank 2 running rich

I googled for it, it could be some clogged injectors but the idle is perfect and there is no lack of power. I went to the GM dealership they told me it could be the MAF but finding out the real problem could cost some $$$ and a MAF alone is 284$.

Anyone else had the problem? I put some Injector cleaner in the tank but it did nothing except that the light doesnt stay on all the time but goes off from time to time.

I believe the light comes on once the engine is hot.

Any advice would be appreciated. Thanks!
2000 GMC Jimmy SLE 4.3 V6

#2 Draenor

Draenor

    I'm offsetting your carbon credits!!!!!

  • Member
  • 3,605 posts
  • Location:CHURCH POINT, LOUISIANA

Posted 09 June 2009 - 11:41 AM

Clean the MAF and see if that solves the problem. The only other problem I can think of is the FPR or the spider is bad.

Did you not check the vehicle over before you bought it?


2004 GMC 2500 Sierra Metallic Gray CC/SWB


#3 MB4x4

MB4x4

    Enthusiast

  • Member
  • 115 posts
  • Location:Manitoba, CA
  • Gender:Male

Posted 09 June 2009 - 11:58 AM

Well I looked at the maf, it looks clean, the sensors aren't dirty neither is that screen. I cleaned the air filter. It was not dirty, too.
I knew about the codes when I bought the car, I got it cheaper therefore.
2000 GMC Jimmy SLE 4.3 V6




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users