Jump to content

PPV

Member
  • Content Count

    3
  • Joined

  • Last visited

Posts posted by PPV


  1. I have a 2009 Silverado 1500 Ext Cab LT 4wd that I bought new in late 09. I have 72k on it but being in the north east I’m dealing with the typical corrosion issues.

     

    The known list of what’s wrong is as follows:

    -Transmission lines are corroding and starting to leak at the rubber connections.

    -ps lines are corroded and leaking.

    -Front differential left output shaft leaked and is wobbly.

    -typically corrosion starting on the rear wheel wells.

     

    What else can I expect to go?

     

     

    Sent from my iPhone using Tapatalk


  2. I had a similar situation on my 2005. Went to replace half shaft and seal and noticed the output flange moved a little more than what seemed normal. Explains why the seal wore out I guess. Ended up just putting a new seal and shaft in and it ran for a 50k more miles with no issues. I think they just get a little loose but if you can't hear it howl in 4wd it's probably ok and not a shot bearing.

    Not hearing a grind just a clicking noise from the output shaft but will confirm by putting it in 4wd. I checked to output shaft cost with GM and it ain’t cheap. Are they available aftermarket?

     

    Ninja edit: answered my own question.

     

    https://www.ebay.com/i/311944080354

     

     

    Sent from my iPhone using Tapatalk


  3. I noticed a clicking noise coming from the front end of my 09 4wd 1500. Put it on the lift and discovered the driver side seal leaked and the output is sloppy when I wiggled the half shaft. Is this common? Is it typically a bearing or are there other hard parts that typically fail?

     

     

     

    Thanks in advance for any input or advice?

     

     

    Sent from my iPhone using Tapatalk

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.