Jump to content

CCMC

Member
  • Posts

    9
  • Joined

  • Last visited

Posts posted by CCMC

  1. I’m having a brake issue with a 2007 1500 Silverado classic. I’ll give a little history of the problem..it began with a bad booster, could hear it blowing air while pumping the brakes, oil in the booster and the brakes not acting quite right. So the process began, I figured since I was replacing the booster, I’d replace the master cylinder, fluid was nasty and figured I kill two birds with one stone. I replaced master cylinder and booster, bled the brake system, test drove it and brakes worked as they should!! Thought I was done…not hardly!! My son drives it for a day or so and advises me that the brakes had locked up and needed help. Once the brakes cooled, I was able to drive it to the mechanic shop, I did this because I had no idea why and had no time to troubleshoot it at this point. So fast forward 3 weeks…and multiple problems caused by contaminated brake fluid…new calipers, new ABS module, tried 4 different aftermarket master cylinders, multiple bleed cycles, GM saying to use aftermarket because the one we need is discontinued (which we’ve used 4 different ones). After all of this, the shop says, front brakes are still dragging…shop said if they break the line at the master cylinder the brakes release…so I mentioned, “I still have my old master cylinder (confirmed leaking) wanna try that to see if it makes a difference? Low and behold, old master cylinder works no dragging, and the brakes operate like they should. So bingo found the problem, I’ll just order a new GM master cylinder and go on down the road… not so fast…after multiple superseded gm part numbers still can’t get the correct master cylinder to fix my sons truck!!

     

    Sorry for being so long winded…I can fix pretty much anything, there are two things I haven’t been able to fix, is a karaoke microphone for my daughter and this truck! 

     

    I’m hoping someone out there has had the same issue or am I missing something really simple…any help will be greatly appreciated!!

  2. My 2021 AT4 2500 Duramax is having an issue with the trailer running lights staying on with the truck off, lights off of auto, doors locked, etc. I didn't have the problem until I connected my daughters new camper trailer (incandecent running lights). And now my GN trailer with LED running lights stay on continuously. I now have an error that shows up to "check trailer wiring", I have verified that my trailer lights work as they should. I pinned out the connector on the truck trailer plug and confirmed that the running lights have 12v continuously. Is this correct? Has anyone else had this issue? And what should I do to fix this issue?

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.