Jump to content

Search the Community

Showing results for tags 'egr system'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GM-Trucks.com Original News & Product Reviews
    • General Motors Product and Industry News
    • The GM-Trucks.com Garage - Vehicle Testing & Product Reviews
    • The Newsroom Archive
    • The Garage Archive
  • Future Vehicle Discussion
    • Silverado / Sierra & Future Vehicle Speculation & Spy Shots
    • GMC HUMMER EV & Future Electric Chevrolet Silverado
  • Fullsize Truck & SUV - 2019 - 2020 - 2021 T1XX Platform
    • 2019-2021 Silverado & Sierra
    • 2020+ Silverado HD & Sierra HD
    • 2021 Tahoe, Suburban, Yukon, Yukon XL & Escalade
  • Fullsize Truck & SUV - 2014-2019 K2XX Platform
    • 2014 - 2019 Silverado & Sierra
    • 2015-2020 Suburban/Tahoe & Yukon/Yukon Denali
    • 2015-2019 Silverado HD & Sierra HD
  • Fullsize Truck & SUV - 1999-2006 GMT800 & 2007-2013 GMT900 Platforms
    • 1999-2013 Silverado & Sierra 1500
    • 2000-2014 Silverado & Sierra HD
  • Chevy Colorado & GMC Canyon
    • 2015-2021 Colorado & Canyon
    • 2005-2012 Chevy Colorado & GMC Canyon
  • Midsize Crossover - 2017-2020 C1XX Platform
    • 2017-2021 Traverse, Acadia, Enclave & XT5
    • 2019 - 2021 Blazer
  • Classic Chevrolet / GMC Pickup Trucks
    • 1988-1999 Chevrolet & GMC C/K GMT400 Platform
    • 1973-1987 Chevrolet & GMC Square Body / Rounded Line Pickups
    • 1967-1972 Chevrolet & GMC Glamour / Action Line Pickups
    • 1960-1966 Chevrolet C/K/Apache & GMC 1000-3000 Pickups
    • 1982-2005 Chevrolet S-10/Blazer & GMC S15/Sonoma/Jimmy
    • 1969-1994 Chevrolet K5 Blazer & GMC Fullsize Jimmy
  • Marketplace
    • For Sale/Wanted
    • Member & Vendor Rating Forum
    • Member Product Reviews
  • GM-Trucks.com is supported by
    • Adam's Premium Car Care
    • Agri-Cover
    • Arnott Air Suspension
    • Black Bear Performance
    • GMPartsDirect.com
    • UPR Products
    • Synthetic Advantage
  • The Lounge
    • Off-Topic
    • Automotive Industry & Market Discussion
    • New Member Introductions
    • Meetups, Events, & Gatherings
    • GM-Trucks.com Comment Box
  • Hobbies & Lifestyle
    • Photography
    • Major League Sports, Outdoor Recreation, Firearms, Hunting, OHRV
    • Racing, Strip, & Track
    • Trailers, Hitches, & Towing
    • Garage & Home, Snow Plowing, Landscaping, & Lawn Care
    • Technology, Devices, & Gaming
    • Vehicle Buying, Financing, Incentives, & GM Card
    • Vehicle Builds
  • Technical & Advanced
    • Vehicle Appearance, Care, & Maintenance
    • Ask the GM Technician
    • Performance Engine Tuning
    • Transmission, Suspension, Transfer Case, & Axles
    • Wheels, Tires, & TPMS
    • Audio, Electronics, OnStar, MyLink, Intellilink & SiriusXM
    • How-To
  • Chevrolet, GMC, Buick & Cadillac Crossovers
    • 2013-2021 Buick Encore & Chevrolet Trax
    • 2018-2021 Chevrolet Equinox & GMC Terrain
    • 2009-2017 Chevrolet Equinox & GMC Terrain
    • 2007-2016 Chevrolet Traverse, GMC Acadia, Buick Enclave, & Saturn Outlook
    • 2001-2008 Chevrolet TrailBlazer, GMC Envoy & Buick Rainier
  • Commercial Vehicles
    • 1980-2009 Chevrolet Kodiak and GMC Topkick
    • 1996-2018 Chevrolet Express & GMC Savana
    • 2019-2021 Chevrolet Silverado 4500HD/5500HD/6500HD
  • Black Truck Club's Topics
  • Texas Owner's Group's Topics
  • California Owner's Group's Topics
  • New England Owner's Group's Topics
  • Midwest Owner's Group's Topics
  • South Carolina Silverado Owners's Topics
  • Canadian Owners Club's Topics
  • SCUBA divers of GM-Trucks's Scuba Talk
  • Red Truck Club's Topics
  • Idaho Sierra & Silverado Owners Club's Idaho
  • Colorado Trucks's Exhaust Setups
  • Colorado Trucks's Pics of trucks
  • SEO Paint's seo color ordered
  • NorthSky Blue Club's NorthSky Blue Metallic
  • NorthSky Blue Club's Pics
  • diesel 3.0's Topics

Calendars

  • Events
  • Birthdays
  • Texas Owner's Group's Events
  • California Owner's Group's Events
  • Midwest Owner's Group's Events
  • Red Truck Club's Events

Categories

  • Articles
  • News
  • Reviews
    • Project Sierra
  • Resources

Categories

  • RPO

Product Groups

  • Premium Memberships

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


MSN


Website URL


Yahoo


Skype


Facebook


Twitter


Name


Location


Interests


Drives

Found 3 results

  1. What's the word everyone. Full disclosure, this post will officially mark my first ever post on any forum board. Over the last 20 years give or take, I've utilized the forum boards in research efforts to gain knowledge. Subsequently stumbled upon case studies that were valuable bits of knowledge that happened to be very handy long after i had read them. And on certain rainy days forums have even been an outlet of entertainment! However, it wasn't until earlier this year that i ever took the time to register an account and devuldge deeper into the community of a forums page and I honestly couldn't tell you why that is. I joined a page for info on a Saturn Vue that i've had since 2005 and though i had browsed the posting from this webpage countless hours over the years i had never been so completely stump by an issue (be it motor cars 0r any other type of forum) that i was ready to invest time into creating an account. If you think this sounds bizarre and silly you should put yourself in my shoes and kick your own tail for withholding yourself from the community and vast resources that come with joining. I am now registered to a few boards and todays the day i make a post. BLAhBLAHbLAH BLAH BLAhBLAHbLAH BLAHBLAhBLAHbLAH BLAH 1999/2000 4.3L looking @ rolling 310 k. I've owned the truck since 2003 when she still had less than 30K racked up on the OD. I recently pulled her out of the stable to get her back on the road after 2.5 years. Also just to note, this is not the first time i stored the truck for lengthy period of time. With that being said i am knowledgeable to enough to know that i dont know $h!T outside of what i know has worked for me and what has not worked over the years. While being put up or stored, depending on the reason she got parked i would make the effort to start and let run every 8-12 weeks on average and try to maintain the integrity of components that would fall victim to these situations IE- brake lines, rubbers hosing and such, fuel systems,.... In doing so i have always been able to bring her back to life after minimal post storage tinkering. Nothing a little carb cleaner and high octane fuel wasnt able to cure for her to run like she had never been stored. In all honesty, after sitting for close to 48 months ( stabil mixed in half tank of gas or more and then circulated through the motor / tires pulled / harnesses seperated and or protected from critters / cabin vented to help against mold and condensation) I aired tires up and connected the same red top optima that had been with the truck for 9 years, she started on the third key turn. Not being one to hide behind allure and taking things for whst ther are. I would have no hard feelings about how sluggish or tired she would feel in any part of the power curve as i understand this is what you will encounter on any motor that has seen milage of that sort. (ESP with me driving like I do/ OR DID WHEN I WAS A YOUNGer lol) Last time i revived the truck it was parked with a toasted 4l60e. fast forward the tranny installed and truck on the road was running but not nearly as efficient as previous revivals in the sense that she seemed to bog off the bottom and not want to accelerate/build rpm's unless i were to command WOT. At that point the 262 would scream and rev out. I had started gathering parts for a basic tune-up and aimed at completing this a few weeks before i took it the the Inspection house but all things considered it was running / idling / shifting / exchanging heat / and burning fuel / and holding fluids as good as i could of wanted. I working with a scanner on my Saturn Vue (2003, 3.0L v6 dohc 5-Speed auto "NON CVT" unicorn) and the scanner suddenly refused to display anything when plugged in. tried to reconnect an few times. key on, off, on ect. and still nothing. Strange being i had it reading code and fuel trips only 45minutes before hand. Puzzeled i decide to function test the scanner on my 1500. It worked as designed on the truck, pulled P0453 and cleared. I turned key to off position unplugged scan and went back to the Saturn. Hours later i hit the ignition in the truck and got a healthy cranking effort with no start. I didnt think too much of it i figured fuse or maybe fuel clog somewhere. after checking every thing i could with DMM @ midnight on Sunday with Monday approaching rapidly i accepted defeat and took an uber to home and then work. Further diagnosis that Monday evening determined i had no spark. No spark at the plugs, coil, cap, but the cranckshaft pos sensor was rotating @ around 200-210 so i assumed it was in the operating. Jiggled some wires around after replacing the distributer/CAP/ROTOR/COIL/TBS/ MAF, AND PLUGD ANF WIRES STILL NO SPARK. I then jiggled the wire harnesses and replaced the MAP and bingo we had spark. a few bumps on the ignition later we were running but struggling to communicate and fluXuating from low to high idle missing and choking on i belief air, but wasnt sure. I drove around from home an work a few days and logged 100miles hoping it would smooth out an i didnt. I verified connectors were in operating condition and established they were get power, scratching my head and getting SES light only for the evap P0453.. From there i checked fuel pressure (55-58psi with 15min hold time give or take, had nice 5Psi jump when key was turned off). Sprayed a entire can of carb clean around all upper intake and swapped ignition parts that were replaced out with the newly installed ones to rule out any dUds. I decided i was bored and needed to look inside the intake. My research suggested i was dealing with a fuel issue after the fuel pressure regulator. Pulled upper intake and verified injector were cycling but could use an upgrade to revised CFI system so i ordered that fine piece of monkey madness engineering and popped the lower manifold off. the coolant ports seemed to blanketed by carbons-grime-and other trash stuck to the gasket from last install, which covered approximately 60-80% of the port opening. This was the case on both front and the back of the of the intake orientation. I expected to see worse if i had to bet on it before hand (not that they good) and was surprised. Made the mistake of pulling valve covers before assessing the condition of intake/head mating. What appeared to be dust turned to coolant - oil soaked debris that had collected in the valley of heads and plenum was in fact just that. ALONG WITH PINE NEEDLES, LEAVES, AN ASSORTMENT OF ANTHROPODS NOW DECEASED, 2-HIDE N SEEK WORLD CHAMPION 10MM X 1/4" SOCKETS AND ALL THE OTHER THINGS CYLINDER WALLS JUST CANT GET ENOUGH OF LOL. MY QUESTION IS IN REGARDS TO FINDING ENTHUSIEST IN THE HOUSTON AREA THAT ARE WELL VERSED AND PROVEN IN DOING FLASH WORK FOR THE NEW AGE COMPUTERS. THIS 99/00 IS MY BEAT UP BABY THAT WAS AVERAGING 21-23MPG SINCE THE DAY I GOT IT. SHE STARTED RUNNING AWEFUL AFTER ALMOST ALL IGNITION SYSTEM BEING UPGRADED/REPLACED. Found small coolant leak in plenum along with three poppit valves in poor working condition. I will reassemble sometime this week after i rework some ports in the intake. i WANT TO DELETE DOWNSTREAM o2'S AND EGR. CAN I ALSO DELETE PCV? Need someone in Houston who can flash these off my ecu!!! i have two other motors for projects and im eager to start setting things in motion for some builds as well as being educated by guys or gals that have a good grasp on the electrical side of these things. i truly believe you are able to learn something for every single person you meet in life. IF I CANT HELP YOU, I WONT HURT YOU !!! _________ 99/00 GMC 1500 swb 4.3L vortec W(vin), 310k on OD
  2. Having some issues with my '93 C1500 stalling and dying. It started last month when I was replacing parts to get my truck back on the road after sitting for a long time without much use. After I had managed to get the A/C blowing cold air again (freon, compressor pigtail and tensioner pulley) I noticed that the idle would slow and get choppy, even stalled and died once. I went back to work on it and ended up putting in a brand new Delco egr valve, IAC, fuel pressure regulator assembly, emissions tubing, intake adaptor, intake and egr solenoid. Even with all the parts the truck will still stall with or without the ac engaged and gets significantly worse with the egr solenoid plugged in. As in it stalls terribly at very light throttle since it looks like the valve completely closes when you hit the throttle just right. The engine is a jasper 350 crate with around 80k miles and Ive replaced every single sensor on it at some point or another. I should also mention that before this work was done I'd had the egr blocked off completely with a plate and an adjustable fuel pressure regulator in. I just wanted to get it back to stock once the stalling started so I could have a reliable truck again. At this point i'm worried the problem may be in the pcm or prom since it was running great most of the day with the solenoid unplugged then started stalling again after sitting for an hour turned off. I'm stumped
  3. I have a 1995 GMC k1500 4x4 with the 5.7L TBI engine in it. I just bought the truck and as it is about 24 years old, it only needs to pass one more emisions test before It is grandfathered and therefore immune to e-checks (I live in northern Ohio) and also before I can get plates for it. The problem is, I've failed e check 3 times. A code 32 pops up every time I test it (on my own with a reader) and when I got the emissions test, high nox is the reason it fails. This would make sense, as code 32 is an egr error, and the egr being faulty would definitely trigger high nox, however: The egr valve has been replaced (yes, a negative one) The egr vacuum solenoid has been replaced Map sensor replaced Spark plugs, cap, rotor, wires. Replaced Even went as far as to replace the oxygen sensor. There doesn't seem to be any vacuum leaks and every test I've done on any part of the egr system points to it all running correctly. The kicker is: the truck runs great! No loss in power. Idles great. Super clean and well kept truck. Notes : it does have a Flowmaster super 10 dual exhaust on it, but it isn't a true dual as only one pipe comes from the catalytic into the exhaust, Then two come out. Also, high nox seems to be caused by high engine Temps, however, my engine temp on my dash shows that it never gets above about 165 or 170*. Idk if this is relevant but it seemed strange. Any help is greatly appreciated. I'm really at a loss and I'm running out of time before I need to buy another temporary tag. Thanks again - Joe
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.