Jump to content

A/C LEAK FIXED...NOW COMPRESSOR PROBLEM


Recommended Posts

Last year my a/c system blew a leak, but was working great up until that point. I figured out what happened a couple weeks ago, one of the sensors on the lines coming from the condenser rusted and blew off. I found the other half of it still plugged into the wire harness. I grabbed a new sensor from napa and installed it. I put a vacuum on the system which held great, and recharged the system. While recharging the compressor would come on and off, and eventually i felt ice cold air blowing inside. The next day i tried the a/c and it just wasnt cold anymore, and i realized the compressor was not coming on. However it came on fine while recharging the system.

 

Anybody know what could be going on here? When i bought the sensor napas computer showed two..and i made my best guess on getting the correct one based on color coding. I wondered if i got the wrong one...although the system seemed to be working correctly during the recharge. And also worked fine before it sprung a leak.

Link to comment
Share on other sites

Sounds like you may still have a leak some where, if the Freon is low or gone the compressor will not come on. I would start with checking you Freon level first.

Link to comment
Share on other sites

Here is a trick you can use to determine if its low level or if the compressor went bad, Ive done this before with my 01 Sierra I had. Google AC compressor paper clip trick if you need more help and you will find a ton of inof about it

 

Leave Relay Plugged in.
Disconnect AC Hi-Pressure Sensor.
2-Wire Connector Sensor.
Usually Located in Hi-Pressure Line
Or at Reciever-Dryer.
(Check Google for Location if Not Sure)
Start Vehicle and Turn On AC.
Plug the Paper Clip Ends into Connector.
There are only 2 Pin Sockets in Connector,
(Signal and Ground to Relay/ECU)
Creates Closed Circuit to Relay and Body ECU.
Compressor Clutch should Engage if Working.
Be sure to Check Fuses Befor and After Testing.
If Clutch does not Engage
Then either Clutch Bad,
Relay Bad,
Or System Completely Empty.

Link to comment
Share on other sites

Thanks for the info Dgrinnell. I think you were right about the leak. I just put my guages back on and there is 0 pressure both with the truck off and with it running with the AC on max :`( I'm surprised that i couldnt hear any sort of leak after charging the system. I'll go put a vacuum back on it and see if it still holds.

Link to comment
Share on other sites

I figured that's what it was, I just know it wont run if there is nothing in the system or if the compressor is bad. As far as trying to find the leak maybe get some Freon with the dye in it to maybe track it down. Im no expert on AC stuff but the little I know seems to help you out. Good luck!

Link to comment
Share on other sites

After a little while...30 minutes or so i noticed a couple psi loss in vacuum. I took the switch back off to see if there was anything going on there and remembered i used the old o-ring after dropping the new one into never never land while installing. I went and got a new o-ring and put the switch back on, and re-vacuumed the system. It seemed to hold steady this time after 30 minutes. I will pick up some more refrigerant tomorrow and check the vacuum again tomorrow night. If it looks good i will try recharging.

 

The system be able to hold all that vacuum for extended periods of time , correct? With no drop in vacuum?

 

Thanks for the advice dgrinnell

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.