Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
Zane

Bluetooth audio issues with Chevy MyLink? Quick straw poll

Recommended Posts

If you saw my comment in our Live Review of a 2014 Silverado over the last week, you know that I ran into some issues trying to listen to Bluetooth audio through my phone. I've since confirmed using some diagnostic apps that using multiple devices running Android 4.2.2 and 4.3, only the left channel is played through the MyLink system. What we can't figure out is... why??

 

Is there anyone else with these new trucks that has tried Bluetooth audio streaming? How is it working for you? Also, what device, OS, and OS version are you running? What version of MyLink is installed on your truck?

 

Here

 

Devices we tried

Galaxy S4 running Android 4.2.2

Nexus 7 running Android 4.3

 

This Silverado was running MyLink software "version" 23174395 and we only heard audio from the left channel

 

Any one with other Android and Apple devices that can try this out and let us know what happens?

 

Share this post


Link to post
Share on other sites

I honestly think it's an issue with how the OS handles the Bluetooth audio. I use custom ROMs on my phone and one build it works and the next it doesn't and then the next it's back working again.

 

Side question will audio streaming work through the usb connection for something like SiriusXM rather than Bluetooth?

 

Also, is it only music or is it phone calls as well that are only coming out of one channel?

 

I highly doubt this is an issue with the radio. My money is on the software on the phones...

 

Sent from my Galaxy Nexus using Tapatalk 2

 

Edited by BringTheRain403

Share this post


Link to post
Share on other sites

We're hoping to figure it all out. Lets see if someone with an iPhone and someone with an older/different version of Android can chime in and we can compare notes.

Share this post


Link to post
Share on other sites

Further deepening the mystery, tried bluetooth audio with a 2013 Ram 3500 with uConnect today. Worked perfectly.

Share this post


Link to post
Share on other sites

Did you reboot the phone since you tried it in the Silverado?

 

Sent from my Galaxy Nexus using Tapatalk 2

 

 

Share this post


Link to post
Share on other sites

Did you reboot the phone since you tried it in the Silverado? Sent from my Galaxy Nexus using Tapatalk 2

No, I did not.

Share this post


Link to post
Share on other sites

I have been using my iPhone 4S running the latest version of iOS6 with the MyLink bluetooth, with no issues whatsoever. I'll have to check on my MyLink software version later, but it is whatever version came with the truck.

Share this post


Link to post
Share on other sites

One suggestion though: is it possible that your phone is seeing the MyLink bluetooth as a some sort of bluetooth headset? Correct me if I'm wrong, but I think when some phones connect to a headset, they only require the use of one audio channel. If that is the case, it may require a software update on the phone's part.

  • Like 1

Share this post


Link to post
Share on other sites

I have been using my iPhone 4S running the latest version of iOS6 with the MyLink bluetooth, with no issues whatsoever. I'll have to check on my MyLink software version later, but it is whatever version came with the truck.

 

Where is the version info listed at for mylink?

Share this post


Link to post
Share on other sites

I have been using my iPhone 4S running the latest version of iOS6 with the MyLink bluetooth, with no issues whatsoever. I'll have to check on my MyLink software version later, but it is whatever version came with the truck.

Here is my version:

 

null_zpsa21cf10d.jpg

Share this post


Link to post
Share on other sites

While we're on the subject of the firmware version numbers does anyone know how these things get updates?

 

Sent from my Galaxy Nexus using Tapatalk 2

 

Edited by BringTheRain403

Share this post


Link to post
Share on other sites

My software is the same ending in 395 just like everyone else.

 

I run iPhone 5 with iOS 7 beta 6 and Bluetooth audio works great like it should.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By kellycapps
      I purchased a brand new Suburban in 2015 from Sawgrass Chevrolet in November 2015. Over the last 6 months my husband and I noticed the paint on the hood of the vehicle is faded and has noticiable swirls. I had it evaluated by a auto body shop and they confirmed the paint is defective and there is no clear coat. I've also been told by the dealership that this is a very common issue they have seen on the hood/ over the engine. Yet, there is nothing they can do, I must contact GM. How is it possible that this is a know issue and there is no resolution. My car is just over four years old! My 10 year old Ford Expedition's paint looked close to brand new compared to this!!!
      Does anyone have any advice or recommendations? CLASS Action lawsuit?????
    • By rviscuso
      As the title suggests the USB music is exhibiting erratic behavior.
       
      Sometimes folder view is not available (it is not indexing as the flash drive was not removed).
       
      When returning to vehicle and turning on key, the music played will typically be what I was last listening to; sometimes it will randomly play something else.
       
      Sometimes it shows “No Media Found” then after a period of time when it does recognize the USB it shows “No Artist Info”. The song title will display but no artist or album title. When this happens there is no sound and adjusting the volume control has no effect. If I press radio the sound works, then pressing media and now the sound works and the song title, artist and album display correctly.
       
      2017 Silverado LT. The USB is Patriot Slate 3.1 256GB NTFS. I have another one which works fine in a 2017 Corvette. The owner’s manual page 203 states USB format FAT16/32 or ex FAT is recognized but NTFS is not. Page 201 states USB 2.0. However, page 27 of the Infotainment manual states that it supports file systems FAT32 and NTFS. So, what to believe?
       
      What do you guys think? Anyone have the same or similar issues?
    • By Kyle Mills
      Hello, im currently in the market for a new (to me) truck. I have a little girl, and a fiancee. Ive looked at many truck for sale. The biggest features im looking for is, 4door, leveling kit, tint, somewhat low miles, wheels and tires are a plus, but not nessicary, and well maintained. I know truck pricing in general is pretty high nowadays. But i made this forum to ask, what would a good price be for a Silverado between 2014-2016 be? Thabks in advance 
    • By RogueOneOverland
      Finally finished my stereo setup. SoundMan iPad Dash Kit, AudioQuest DragonFly DAC, AudioControl Overdrive Plus, JL Audio HD900/5, JL Audio 8W3v3-4, Focal K2 Power 6.5, 33 Sq Ft of SoundSkins Dampening, SMD OM-1 Monitors on highs and lows. 



    • By Sam Hohn
      I recently acquired a 1951 Chevrolet 6100 missing its engine and would like to refurbish it. However, Instead of putting in the original engine (Chevrolet 235) I am looking for an engine that came out in the next 10-15 years to put in my truck that will out put 200+ horsepower without being out of touch with the truck. Any advice would be greatly appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    217,348
    Total Topics
    2,330,441
    Total Posts
  • Member Statistics

    199,698
    Total Members
    8,960
    Most Online
    Kimber Zero
    Newest Member
    Kimber Zero
    Joined
  • Who's Online   31 Members, 0 Anonymous, 951 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.