Jump to content

block8head

What have you done to your K2 today?

Recommended Posts

I just got these exact same leds in the mail the other day for this same purpose, how do you like them so far?
They deffinetely help backing up at night with tinted windows.

Sent from my SAMSUNG-SM-G890A using Tapatalk

Share this post


Link to post
Share on other sites

Follow up to my bed rail picture the other day, finished up the video. If you can’t tell I’m a huge fan of the hex series stuff Deezee started making, they finally got out of their comfort zone (90s era truck accessories) and started designing cooler crap for our trucks.




Waterfowler 41’s Youtube channel: https://www.youtube.com/user/brittmork

Share this post


Link to post
Share on other sites

Rainy day means no work for me so I had a set of Michelin Defenders installed on my (new to me) '16 Sierra Denali. Stock Bridgestones had 4/32 left at 44k miles. Lots of praise on here for the Michelins and lots of guys saying they get 70k+ on them. Hope to be one of them! I use the truck for work and put about 25k miles a year on it with a 60/40 mix of highway/city. 

Share this post


Link to post
Share on other sites
On 12/31/2018 at 5:30 PM, Fix29 said:

Swapped the reverse and cargo light bulbs out with leds.e9f89a77dfdd9c9e00d7f3892777b057.jpg8a2d4a481667e7caeaf0c8988acce256.jpg5628ecc6d5917c72b5cb4cadb0e99e3a.jpg

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

I need this with my tint as well.  Mind sharing those part model bulbs?  Assuming it should be same part number for a 18 Silverado?

Share this post


Link to post
Share on other sites
I need this with my tint as well.  Mind sharing those part model bulbs?  Assuming it should be same part number for a 18 Silverado?
The factory bulbs are 921. Just search Auxito 921 LED and you will find them. I got mine off Ebay.

Sent from my SAMSUNG-SM-G890A using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
I didn’t do anything but Mother Nature decided to add some snow. I know it’s not a big deal for most of y’all but snow down here in southern Arizona isn’t something that happens often.


What part of AZ? I’m in Tucson and was in FL during snowpocolypse.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I'm just south of you in Sahuarita. It was a nice change to have some snow for a few days.

  • Like 2

Share this post


Link to post
Share on other sites
The factory bulbs are 921. Just search Auxito 921 LED and you will find them. I got mine off Ebay.

Sent from my SAMSUNG-SM-G890A using Tapatalk



Are they the T10’s or T15’s?


Sent from above

Share this post


Link to post
Share on other sites


Are they the T10’s or T15’s?


Sent from above
T15

Sent from my SAMSUNG-SM-G890A using Tapatalk

Share this post


Link to post
Share on other sites
9 hours ago, DenaliStone said:

Rainy day means no work for me so I had a set of Michelin Defenders installed on my (new to me) '16 Sierra Denali. Stock Bridgestones had 4/32 left at 44k miles. Lots of praise on here for the Michelins and lots of guys saying they get 70k+ on them. Hope to be one of them! I use the truck for work and put about 25k miles a year on it with a 60/40 mix of highway/city. 

Put the Michelin's on our Tahoe, great tire! Truck rides better, handles better, etc...…

  • Like 1

Share this post


Link to post
Share on other sites
T15

Sent from my SAMSUNG-SM-G890A using Tapatalk



Identical purchase, great to hear they’re that good.


Sent from above

Share this post


Link to post
Share on other sites


Identical purchase, great to hear they’re that good.


Sent from above
They're definitely an improvement over the stock bulbs for sure.

Sent from my SAMSUNG-SM-G890A using Tapatalk

Share this post


Link to post
Share on other sites
They're definitely an improvement over the stock bulbs for sure.

Sent from my SAMSUNG-SM-G890A using Tapatalk


Good to hear


Sent from above

Share this post


Link to post
Share on other sites

Just dropped it off at the dealer for my free oil change & tire rotations.

It’s also got a suspension squeaks going over bumps when it’s cold out. The truck only got 8017 miles on it.... wonder if that’s normal....




Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.