Jump to content

block8head

What have you done to your K2 today?

Recommended Posts

Today, my son and I gassed it up, fixed my fill tube, and drove up to Tehachapi to return a few things, that I no longer needed.  Unfortunately, I'll have to go up there AGAIN, later this week, Radio Shack was closed.  :mad:   Next time I'm at ACE, I'll get the specs for the bolt/nut.  When I picked them up, I almost bought "chrome" ones, but then caught a glimpse of these a couple sections over. 

 

My son ran the nut down, in this case up, the bolt from under the bed.  We then switched places, so I could make sure that the nut was on there good and tight.  Survived our 80+ mile trip to Tehachapi, from Edwards AFB, and back to the house.

A few weeks ago, I was filling up and noticed that another Silverado owner, from Florida, had the same issue.  He was reinstalling his broken plastic fastener, when he was done filling up, just like I was repeatedly doing, until today.

IMG_0050.jpg

  • Like 1

Share this post


Link to post
Share on other sites
On 3/17/2018 at 4:57 PM, Korazu said:

Pictures or it didn't happen.. lol

 

Today I took off the bottom part of the front skirt and finally installed my LED lights in the truck bed under my Backflip.

 

Before:

 

Gq52Kbk.jpg

 

After:

 

obIJTJG.jpg

 

Bed lighting:

 

4d3a9To.jpg

What bed lighting kit did you use?  Looks great.....

Share this post


Link to post
Share on other sites
3 hours ago, Ravenkeeper said:

Today, my son and I gassed it up, fixed my fill tube, and drove up to Tehachapi to return a few things, that I no longer needed.  Unfortunately, I'll have to go up there AGAIN, later this week, Radio Shack was closed.  :mad:   Next time I'm at ACE, I'll get the specs for the bolt/nut.  When I picked them up, I almost bought "chrome" ones, but then caught a glimpse of these a couple sections over. 

 

My son ran the nut down, in this case up, the bolt from under the bed.  We then switched places, so I could make sure that the nut was on there good and tight.  Survived our 80+ mile trip to Tehachapi, from Edwards AFB, and back to the house.

A few weeks ago, I was filling up and noticed that another Silverado owner, from Florida, had the same issue.  He was reinstalling his broken plastic fastener, when he was done filling up, just like I was repeatedly doing, until today.

IMG_0050.jpg

What was the original problem? From what I'm reading, the fix is only a bolt? I'm just curious, I was going you had a solution to the capless fuel tank. I've done some research on it, I think I have a solution, it's just on the back burner for now...

  • Like 1

Share this post


Link to post
Share on other sites
What bed lighting kit did you use?  Looks great.....


I actually bought the bed lighting kit from GM as I had a $100 off coupon. I just used the wiring harness from the kit and then bought some led waterproof lights from amazon. I cut off the ends from the harness and wired them to one end of the led lighting, so they’ll come on with the cargo light switch.

https://www.amazon.com/gp/product/B00HSF66JO/


Sent from my iPad using Tapatalk
  • Like 1

Share this post


Link to post
Share on other sites

Replaced my condenser, Dealership want to do it for 1400$ I went out and bought a condenser for 84$ , spent 4 hours and a couple beers putting it in, then took it to my buddy to vaccum it and put refrigerant in for 40$. Saved 1276$


Sent from my iPhone using Tapatalk

  • Like 3

Share this post


Link to post
Share on other sites
Pictures or it didn't happen.. lol
 
Today I took off the bottom part of the front skirt and finally installed my LED lights in the truck bed under my Backflip.
 
Before:
 
Gq52Kbk.jpg
 
After:
 
obIJTJG.jpg
 
Bed lighting:
 
4d3a9To.jpg

Got any side shots of the truck , and wheel and tire specs looks like you got a bit of a lip wheel


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
9 hours ago, 6.2Midnight said:

What was the original problem? From what I'm reading, the fix is only a bolt? I'm just curious, I was going you had a solution to the capless fuel tank. I've done some research on it, I think I have a solution, it's just on the back burner for now...

Nowhere did I mention "capless."  There is at least one other thread for that, in the modifications forum. 

 

The fill tube housing is held in place, at the bed, by a flimsy plastic "fastener."  You can see the bolt that I installed, just inside the fuel door.  One of the expansion parts of the fastener broke, back in September, on my way back from San Diego, and I've been just reinserting it until yesterday. 

Share this post


Link to post
Share on other sites

Smoked my driving lights, amber turn signals, amber corner markers, and fogs with VHT nightshades. Blacked out my bowtie, Z71 emblem, and chrome bumper valance with plastidip.

IMG_0213.JPG

IMG_0229.JPG

IMG_0234.jpg

IMG_0235.jpg

IMG_0237.jpg

  • Like 9

Share this post


Link to post
Share on other sites
8 hours ago, Kyleorsini said:


Got any side shots of the truck , and wheel and tire specs looks like you got a bit of a lip wheel


Sent from my iPhone using Tapatalk

What do you mean lip wheel? The specs are in my signature, 20x9 Fuel Vandal's wrapped with 285/55R20 Nitto Ridge Grapplers.

 

HUEiH2R.jpg

VK2Ay9Z.jpg

Share this post


Link to post
Share on other sites

New go rhino D6 Dominator running boards88e49c114a73fad3e508287c0cbe8a67.jpg6cd39b6d4440531e933c2027a27b0063.jpg

Sent from my SAMSUNG-SM-G935A using Tapatalk

Share this post


Link to post
Share on other sites

0a401d608f38a41dd9ca9795f61a9fc5.jpg

Finally got my ProClip IPad Mount put in. Used a RAM mount to extend it out to have more adjustability. Snaps on and off so i can take it off if i have a passenger riding with me. Also pictured is the ProClip mount for my phone as well.

Share this post


Link to post
Share on other sites
Smoked my driving lights, amber turn signals, amber corner markers, and fogs with VHT nightshades. Blacked out my bowtie, Z71 emblem, and chrome bumper valance with plastidip.
IMG_0213.thumb.JPG.88ae711b2b15b224f81e5808f1474182.JPG
IMG_0229.thumb.JPG.c75b2b1011bc9bbb650b0744bed9dfde.JPG
IMG_0234.jpg.299c07ca636bdc9784dd12cbfa5ef3e9.jpg
IMG_0235.jpg.96ef131c2bc27fc82b768e5331afe3dd.jpg
IMG_0237.jpg.00d961cee765c351833dabdab7703015.jpg

Looks great! Did you just spray onto the headlights or did you open them up?


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
10 hours ago, allblack16 said:

Smoked my driving lights, amber turn signals, amber corner markers, and fogs with VHT nightshades. Blacked out my bowtie, Z71 emblem, and chrome bumper valance with plastidip.

 

 

IMG_0234.jpg

 

 

Night and day difference man. Looks amazing. I really wish I could get away with that.

Share this post


Link to post
Share on other sites

Heading to the dealer this afternoon to install the GM accessories navigation upgrade cable. It’s supposed to convert my radio from an IO5 to IO6. One of my irritants with my truck is that it didn’t come with factory Nav, and doesn’t have apple CarPlay so I’ve been stuck using my phone. I’m trying the GM accessory cable because it’s about $600 cheaper than if the dealer brought in York Eectronics to do whatever it is they do to upgrade to navigation. 

Share this post


Link to post
Share on other sites
10 hours ago, Neallynein said:


Looks great! Did you just spray onto the headlights or did you open them up?


Sent from my iPhone using Tapatalk

Opened them up.. a much better look imo than spraying the lense cover.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.