Jump to content

block8head

What have you done to your K2 today?

Recommended Posts

On ‎6‎/‎24‎/‎2018 at 7:16 PM, Neallynein said:

Just happened today while raining. The truck lights turn on while the truck is off (happened at first key in ignition but not on, and then again while unlocked key not near truck). All of the lights turn on and the turn signals flash. It goes for like 15 seconds or so and then stops. Has anyone had this issue yet?
 


Sent from my iPhone using Tapatalk

ANY problem with Green grill lights ??

Share this post


Link to post
Share on other sites
ANY problem with Green grill lights ??

Nope. It seems to have stopped. I’m not sure what stopped it. Maybe it was something got wet like someone said earlier and now it’s dried. The grill lights have been installed since Octoberish


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
19 minutes ago, Neallynein said:


Nope. It seems to have stopped. I’m not sure what stopped it. Maybe it was something got wet like someone said earlier and now it’s dried. The grill lights have been installed since Octoberish


Sent from my iPhone using Tapatalk

Thank You for the info.

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Zrodie21 said:

1d047f7520c34eac44d5181eb262ee3c.pnga2663e56d336b219ec351dc05d207672.heic picked up the truck from getting the new 7-9 McGaughys suspension put on and cognito upper control arms. Rides so much better and the angles are perfect! Selling my 7.5 RC lift if anybody wants it


Sent from my iPhone using Tapatalk

Is that a t-rex grill (overlay) ????

Share this post


Link to post
Share on other sites
I took 2 things I would say were useless to me and made them useful
 
Never left this unlocked so can’t use the USB, and never used this storage for anything more then safety glasses.
 
48caa2453f4afa887559a6b99be85d52.jpg850ea9a817b0c9bafe4d2abad404f44b.jpg
 
Will work tell apples new update and I’ll have to replace the cord for the 100th time.
 
 
Sent from my iPhone using Tapatalk
 
 



What year is your truck? Don’t have that USB plugin in mine.
  • Like 1

Share this post


Link to post
Share on other sites



What year is your truck? Don’t have that USB plugin in mine.


2018


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites



What year is your truck? Don’t have that USB plugin in mine.

I have a 2016 and have that Glove Box USB as well. It seems GM added for 2016+ trucks that have a jump seat. If you have a full center console, they seem to have deleted the glove box USB. It uses the green port of the HMI. Which would explain why it’s not there if you have a full center console.

Full center consoles seem to leverage the green and black ports to the USB Hubs.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
4 minutes ago, pgamboa said:


I have a 2016 and have that Glove Box USB as well. It seems GM added for 2016+ trucks that have a jump seat. If you have a full center console, they seem to have deleted the glove box USB. It uses the green port of the HMI. Which would explain why it’s not there if you have a full center console.

Full center consoles seem to leverage the green and black ports to the USB Hubs.


Sent from my iPhone using Tapatalk

I have a 2015 LTZ that had the glovebox USB. Strange place for I thought. Never use mine. I should add that I have the jump seat as well. 

Edited by michigan2500hd
  • Like 1

Share this post


Link to post
Share on other sites

I have a 2016 and have that Glove Box USB as well. It seems GM added for 2016+ trucks that have a jump seat. If you have a full center console, they seem to have deleted the glove box USB. It uses the green port of the HMI. Which would explain why it’s not there if you have a full center console.

Full center consoles seem to leverage the green and black ports to the USB Hubs.


Sent from my iPhone using Tapatalk


I have a 16 with the jump seat but I’m a custom so I don’t have the usb in the glove box. I do have the two USB ports in the console though with a 12v port. I’m assuming since I’m a custom (I basically have the WT but a painted bumper & bigger radio) that I didn’t that get that feature like a LT would


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I have a 2016 and have that Glove Box USB as well. It seems GM added for 2016+ trucks that have a jump seat. If you have a full center console, they seem to have deleted the glove box USB. It uses the green port of the HMI. Which would explain why it’s not there if you have a full center console.

Full center consoles seem to leverage the green and black ports to the USB Hubs.


Sent from my iPhone using Tapatalk



I have a 14 and had jump seat before I upgraded to console - made my own harness. One of my USB plugins isn’t in use, can’t remember which one.

Share this post


Link to post
Share on other sites
Is that a t-rex grill (overlay) ????

Yes it is


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Had about 45 minutes and with this 100°+ heat, that what 45 minutes too much! Had to take my illuminated handles off to get some switchbacks retrofitted in them. Figured this would be a perfect time to add some chrome lock knobs while I had the panels off. I can never just do one thing. Lol.

Thanks to@cmatt for the idea!

Lock knob rods are for an Escalade, so I just swapped the knobs since the rods are different.

The little details I tell ya. Lol. I like the touches of chrome on the inside.

c3d2ce8e57ff06abf30fb68f868ef7f2.heic

fb97aaf327cb4e39b624fa7c7dc8b158.heic

c7fb84550e49b2074ab576190d06f4b7.heic

a5f999c7a02fc8d83a710d46c6ff1a74.heic

68715ed25c77e6e9788afb235d080587.heic


Sent from my iPhone using Tapatalk

  • Like 11

Share this post


Link to post
Share on other sites

Yep to damn hot out today. I was gonna detail my truck inside and out and was like no way! Lol

 

  • Like 3

Share this post


Link to post
Share on other sites
13 hours ago, Zrodie21 said:


Yes it is


Sent from my iPhone using Tapatalk

Thank you for the information

Share this post


Link to post
Share on other sites

Installed the new Baja Designs OnX6 Arc Series 30" light bar

 

IMG_7175.PNG.e290467e414bca336a8c5d62411099de.PNG

  • Like 7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.