Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

What have you done to your K2 today?


Recommended Posts

Did you need load resisters to stop the missing light bub warning from displaying due to low current draw?

Do you have a link to the bulbs you used?

Nope. No load resistors. I think that since those bulbs are outside of the lights that are of 'legal necessity' to be able to operate the vehicle with all the legally required lighting, they do not trip the bulb out warning system.

 

I do have these screen shots of the item picture and vendor and price paid. Since I'm typing this on my phone, it was easier to do it this way.

 

yju2aja7.jpgzubyseju.jpg

 

 

Mine arrived about 1.5 weeks after ordering them, which put them 2 weeks ahead of their scheduled delivery. Also these lights seemed extremely sturdy when I opened them and installed. I'm happy with them. Very nice, bright, and most importantly (IMO), they are white. They are great lights. And I would recommend them over stock any day of the week

 

 

Sent from my iPhone using Tapatalk

 

 

EDIT:

 

Go check out this thread, it goes over more options for the reverse and cargo lights and other people's findings. Also I posted some pictures in that thread of the results of the light change.

 

http://www.gm-trucks.com/forums/index.php?/topic/153101-LED-921-Reverse-%26-Cargo-Bulbs

Edited by Mike1220
  • Like 1
Link to comment
Share on other sites

Did you need load resisters to stop the missing light bub warning from displaying due to low current draw?

Evidently they're built in the bulb somewhere because I haven't had that or any other problem since I put them in.

Link to comment
Share on other sites

Got AMP power steps installed today.

 

Bushwacker flares showed up on the porch today.

 

Morimoto HID fog kit showed up yesterday.

 

Weathertech liners showed up a few days ago.

Edited by spurshot
  • Like 1
Link to comment
Share on other sites

Had my cloth interior replaced by a dealer authorized Katzkin installer. Disappointed with the fit. The fit seems loose. I'll give it a couple of days. Even though I figure it will only get worse.

Link to comment
Share on other sites

Installed a High Country grille. It went pretty well and it looks sooooo good :D. THANKS Brentadams646!!!! Couldn't have done it without ya!!

 

Before

140530_01.jpg

 

In progress...

140530_02.jpg

 

Finished product!!

140530_04.jpg

Edited by LTZTom
  • Like 8
Link to comment
Share on other sites

Installed a High Country/HD2500 grille. It went pretty well and it looks sooooo good :D. THANKS Brentadams646!!!! Couldn't have done it without ya!!

 

Before

140530_01.jpg

 

In progress...

140530_02.jpg

 

Finished product!!

140530_04.jpg

I can never see your pics when I'm at work. Even if I copy the URL it blocks it and the reason is weapons..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.