Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
kdeerman

2006 sierra z71- push button 4WD not working

Recommended Posts

Sometimes it works, sometimes it doesn't. Sometimes yellow lights are on, sometimes not, though it seems they all light up when I crank the truck?

Share this post


Link to post
Share on other sites

Your unit could be going out I had the same problem in my 03 I replaced it and that fixed mine. Do you get a service 4wd alarm on your dash?

Share this post


Link to post
Share on other sites

OK, switched out the dash switch with my 04 suburban, it worked in the suburban. Yes, it reads Service 4WD on dash. I'll get it scanned.

 

Thanks.

Share this post


Link to post
Share on other sites

You could also disconnect your battery for a bit to reset your computer and if that doesn't clear your code then you could get it serviced

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.