Jump to content
Sign in to follow this  
T Duramax

2015 Yukon Suspension Noises and Squeaks

Recommended Posts

New to the forum and was hoping to get some suggestions. Bought my wife a new SLT a couple months ago and it now has around 6k miles (went on a road trip). Recently it started squeaking like a hoopty at every bump she hits. She told me about it and I went to the garage and pushed up and down on the front of it and I didn't really hear anything. The next day she was still complaining about it. I decided to drive it to see what she was talking about and sure enough... it's a straight up hoopty at any and every demand that is made on the suspension at slow speeds. I drove it slow out in a grassy field and it sounds like it's going to fall apart. I initially thought it was only coming from the back but it sounds like the front is squeaking as well. I find it odd that the first 6k miles have been the best quiet ride of any vehicle I've owned and all of the sudden....

 

I'm going to try to get it to the dealership next week. I'll post what they say/do but was wondering if anyone else is experiencing this??

  • Like 1

Share this post


Link to post
Share on other sites

Hello T Duramax,

 

I am sorry to hear of the concerns you and your have are experiencing with your Yukon squeaking. I understand how you feel, you do not expect problems with a new vehicle. I recognize that you are seeking feedback from fellow members about their experiences. If any additional assistance is needed on our end, we're glad to assist. When is your appointment?

 

 

Andraya

GM Customer Care

Share this post


Link to post
Share on other sites

X2. Ours does the same thing. It's a good thing the exhaust leak is so bad, it drowns out the squeaky suspension noises.

Share this post


Link to post
Share on other sites

I know this is an old thread, but this squeak just showed up in my 2015 Yukon SLT. It has 20K miles on it. Is it just the bushings?....or was it something major?

 

It seems odd the bushings would squeak only after 20K miles.

Share this post


Link to post
Share on other sites

I have a 2016 Yukon Denali , with 65k on it and it just started making a bushing rubber type sound from the front right. I took a look and it looks like the lower shock bushing is deteriorating ( breaking apart). The left side looks good no issues. Anyone else have this experience?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.