Jump to content

hutch08

Calling all leveled/lifted trucks with All Terrain factory 20's

Recommended Posts

I have a 2018 crew cab 2wd, 1.5 motofab level. I’m rubbing sway bar with 275/60r20’s. Only happens in forward while turning hard left. Doesn’t happen hard right, and no rub in reverse.

2E3CA972-A6FA-43F7-B920-32C9560D2971.jpeg

Edited by wepiii

Share this post


Link to post
Share on other sites

I think this is a good example of why leveling/adjustable shocks like bilstein 5100 & eibachs kit are superior to the cheap puck style level kits.

 

i have run the bilsteins @ full height + 2.25” (+1”) rear blocks & 275/60R20s for 50k miles & while I do have the slightest rub @ full lock on sway bar- there is no contact whatsoever w/ the A-arms. This was the case when I ran 275/65R20 as well (I went down in size due to weight not b/c they didn’t fit)

 

i didnt look at the multitude of other posts but you can clearly tell the A-arms are put @ altered angles from the ball joints.

 

this is a pretty clear cut example- I may have totaled my ‘15 if I get another I’m running the same setup.

 

granted the OP is running a wider tire also- spacers may alleviate the situation? I still think the A-arms look like they’re gonna chew up your ball joints tho

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.