Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Advent ogm1 stuck on splash screen


Recommended Posts

I have an Advent ogm1 in my 2012 traverse. The last week it has stopped working. When starting the car it turns on and gets stuck on the splash screen then powers off. Sometimes it will power right back on or turn off for 20 seconds and then power back on. There is no sound and it fails to boot all the way up. The turn signal sound comes out when it is stuck on the splash screen but turn signals don't make noise when the screen goes blank. Tried the reset button and still happens. Any ideas?

  • Like 1
Link to comment
Share on other sites

  • 1 month later...
  • 6 months later...

Did you ever get this resolved? I just had the same issue. I submitted a report to the Audiovox Customer Support site. They responded the next day with a procedure that got the unit up and running again.

Did you ever get this resolved? I just had the same issue. I submitted a report to the Audiovox Customer Support site. They responded the next day with a procedure that got the unit up and running again.

 

Having the same issue. What procedure was used to resolve?

Link to comment
Share on other sites

I have an Advent ogm1 in my 2012 traverse. The last week it has stopped working. When starting the car it turns on and gets stuck on the splash screen then powers off. Sometimes it will power right back on or turn off for 20 seconds and then power back on. There is no sound and it fails to boot all the way up. The turn signal sound comes out when it is stuck on the splash screen but turn signals don't make noise when the screen goes blank. Tried the reset button and still happens. Any ideas?

Having the same issue. How did you resolve it?

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hello. I too had run into this issue 2 days ago.

The resolution I came up with and is working is as follows.

1) Press and hold your finger to the middle top portion of the screen

of your Advent as you start your truck until you see it flash a solid green.

2) You will then see a code prompt. Default (as I understand) is 1630. Press enter.

3) You will then see a series of commands. Scroll to Update All. Execute.

This forces the unit to reinstall everything from the memory card.

It does take some time. You will see multiple updates.

(Do Not Interrupt or Shut off the unit until Done!!!)

The unit will shut down when done and then will restart when installation

is complete. (Might take a few minutes. Again do not interrupt!)

It should then be up and running as normal.

I am unsure if this will erase any saved data. ie: maps, saved routes, fuel and the like.

This is by no means an official fix from Audiovox. I have not been in contact with them.

Nor am I a technician or claim to have knowledge of the workings of the unit.

This is solely what I did to resolve the issue of My Unit. Best of luck.

Link to comment
Share on other sites

  • 1 year later...
  • 3 years later...

I just used this procedure and it worked great. I was able to get my CD out and bought some time before I have to get a new unit. Thanks!

 

The OGM1 is installed in a 2013 Suburban. Advent said the latest firmware update was 2011. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.