Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
ember1205

USB in Armrest Dead?

Recommended Posts

Mine died in my armrest after 3 months on my 16. It's a known issue. Just go to the dealer and have them pop in a new one. Mine has been fine since they replaced it. I have the center console version no center seat.

 

Sent from my SM-G930V using Tapatalk

Share this post


Link to post
Share on other sites

Looks like both of the USB ports in my center arm rest are no longer working. Has to be a very recent thing as the iPod I keep plugged in there is still charged up all the way.

 

Anyone else had this happen? Does anyone know if there's a fuse for these ports? I just haven't had time to look.

 

Tried known good devices, known good cables, moved this device/cable to a known good port... It's definitely the two ports.

Just replace it, I bought one from GMPARTSDIRECT.COM and did it myself because I did not want deal with the warranty work. $60.00 dollar part and you get to tear apart your new truck. I replaced mine within the first 2000 miles.

Edited by jimcost2014

Share this post


Link to post
Share on other sites

Just replace it, I bought one from GMPARTSDIRECT.COM and did it myself because I did not want deal with the warranty work. $60.00 dollar part and you get to tear apart your new truck. I replaced my with in the first 2000 miles.

Uh, no.

 

Warranty item, my dealer is good to me. They will take care of it at the next oil change.

Share this post


Link to post
Share on other sites

Uh, no.

 

Warranty item, my dealer is good to me. They will take care of it at the next oil change.

Good relationship with my dealer too, just did not want to make 2 trips and waste a full day for a 30 minute fix.

Share this post


Link to post
Share on other sites

What is the part number? Mine acted up tonight and then started working. Curious if it happens again if it is a bad port.

 

Much rather replace it myself vs. the dealer. Did it simply pop out and plug in? I have not looked any deeper than Google and see this issue in many results lol

Share this post


Link to post
Share on other sites

Hey 'bird, @ws6firebirdta00 I see you have an '18 as well.

 

I've had issues where it connects and then disconnects the phone when plugged into the console (Android).  Enough that I won't use it until it works better.  I really wanted to use the Android interface.  I bought a new cable yesterday and haven't tried it.  What is your indication of failure?

 

I will try it again and make note if the phone shows charging or not, which would indicate a power fail.  I also have a USB light thingy that I could use to check if DC power is present on the 2nd port at the same time.

Share this post


Link to post
Share on other sites

Mine just won’t do anything. I shut the truck off for about 2 minutes then it started again. It’s weird, I use USB music a lot and this was the first time I really had an issue. My iPhone would not connect to it either. The two ports up in the console near the dash worked fine though.

Share this post


Link to post
Share on other sites

My new cable seemed to work fine this morning.

I also started using a USB thumb drive for music and that worked great as well.

I'm thinking it was a bad cable.

Share this post


Link to post
Share on other sites
15 hours ago, ws6firebirdta00 said:

What is the part number? Mine acted up tonight and then started working. Curious if it happens again if it is a bad port.

 

Much rather replace it myself vs. the dealer. Did it simply pop out and plug in? I have not looked any deeper than Google and see this issue in many results lol

This is the part number that I used in my 16, 22990883.

 

It will give you the media card reader the 16-18 do not come with, was in the 14 and 15's.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.