Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
whodey1418

2014 Silverado - Noisy Engine/Ticking

Recommended Posts

Let me start off by saying I am not very knowledgeable when it comes to vehicles. I purchased a 2014 Silverado z71 crew cab hoping for a reliable truck that would last me well beyond when I pay it off. I figured I would come to this site to ask people that are much more knowledgeable than I about an issue I am having.

I own a 2014 Chevy Silverado 5.3 with after market exhaust. The exhaust was put on the truck by a previous owner. At idle, the truck seems loud (and not from the exhaust) standing on the side of the truck by the front doors. I am not sure "ticking" is the right word, but that's about all I can come up with. I have heard some people talk about the DI causing this, but my brother also has a 5.3 and mine is way louder than his. It is almost embarrassing how loud it is when people are standing around it at idle because they are constantly pointing it out. My question is: Is this the direct injection, or could I possibly have another issue (such as an exhaust leak)? I have attached a video for anyone that has the time to listen and provide feedback.

A big thank you to anyone that takes the time to provide feedback. I am looking forward to checking out this website in the future and increasing my "truck smarts." Thanks again.

 

Here is a link to the video of my truck: https://www.youtube.com/watch?v=zK643x41t4g&feature=youtu.be

Edited by whodey1418

Share this post


Link to post
Share on other sites

Can you post a video? DI engines are a bit noisier at idle, but shouldn't be anywhere close to embarrassing! It could be an exhaust leak.

Edited by jono20

Share this post


Link to post
Share on other sites

I hear the high pressure fuel pump in there. Doesn't sound abnormal in the video. Of course the phone is going to amplify all the small noises.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Ticking is normal on DI engines....nothing to worry about

Share this post


Link to post
Share on other sites

Normal. Mostly DI high pressure fuel pump and the DI injectors.

Share this post


Link to post
Share on other sites

Hey guys. Can anyone give me a 2nd opinion on this “ticking”, I just bought the truck with 87,000 on it, dealership said it’s normal but man is it loud. Didn’t seem this loud standing at the dealership with a freeway right next to it. Read all up on the DI noise, just really second guessing my purchase lol. Thanks

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Brad Davies
      Hey guys,
      I got a 2015 Silverado 5.3l. 138,250km. started ticking sometime last winter. Would happen instantly at start up and last about 5 minutes then would fade away. Sounded like a lifter. Took it to the dealer they said they couldn't hear it. Sound went away so left it.
      Fast forward to this winter and as Soon as the weather started to cool down I noticed the ticking again.
      Took it back to the dealer said they couldn't hear it again. I went and picked up my truck right at closing, soon as I fired her up the sound was there but everyone was gone so no one to hear it. I took a video. Next day I called the dealer, sent the video. Took like a week to get back to me. In the meantime I had taken videos pretty much every time I started it.
      Long story short after a brief fight with them about them trying to say it's normal etc they agreed that it sounded like a noise coming from the valve train. Left my truck with them, they called me said they had to change all lifters. Went to pick up my truck and on start up the sound is still there.
      This was a month ago. Sent more videos and a previous video from before they did the work and they are saying they can't hear it again.
      Took it in in person they agreed that there's an issue again and they will look at it. Now they are saying it's possible bad injector noise but they can't figure out which one 🙄.
      In the meantime I took it to another dealership they changed the vacuum pump. After that the sound changed. Now it's no longer at start up but once the truck has reached operating temperature and is more of a dull sound. Took it back to that same dealer who did the vacuum pump and they said valve train noise and deffo not injectors. But they won't work on it because the other dealer already did. 
      They didn't change the VLOM or the cam. I had/have no check engine lights. Truck runs awesome. Sometimes rough idle.
      Any ideas what it could be?
       
    • By Hunter1296
      Took my 2017 Chevy Silverado z71 to the dealer today . Engine was ticking on top end sounded like a lifter tick and slight deeper knock in bottom end . oil presure was all over the place would go from 65 psi to 25 psi at same rpm. I have 44,000 miles. Has anyone else had this issue?  With the strike in play who know how long I will be without my truck.
    • By madsen203
      I'm doing my best to isolate this ticking sound that is persistent, yet intermittent. 
       
      Data so far: 
      2018 CC SLT 1500 6.2L 4WD Max Tow 19K miles, all stock
      Doesn't happen when motor is cold, much more prevalent when motor is warmed Doesn't happen when letting off throttle (only under application of throttle), can be heard in neutral, park, and in drive (not in reverse enough to tell--but it happens when transmission is not engaged) Sound follows steady or increasing RPM of motor Under light to medium load, noise is prevalent, under heavy acceleration it subsides (not because of engine noise) If I turn wheels hard left, the noise disappears, straighten wheels, it returns (like wheel is blocking noise from traveling) Sound only heard on driver side If I hit some oscillating bumps on the road, it can stop for a while before returning back (under varying loads as well) If left in tow/haul mode, at 2500 rpm under light load it can still be heard Ran 2 bottles of Red Line injector cleaner and it didn't eliminate/help noise The truck was silent until the 700 mile mark and I hit an expansion joint (nothing out of the ordinary) and the sound started and has remained ever since I've checked exhaust/manifold connectors and no sign of leaks (soot) I put a hollow aluminum rod (2 foot long) to the vacuum pump and did not hear any abnormal noises directly from the pump Obviously heard injector noises when put to the injectors; haven't had chance to stop on side of road when the sound disappears to run comparison tests Sometimes it'll run dead silent when driving down the road (after complete warm up) and power delivery doesn't change but noise comes back within a minute or two Sound heard in both V-8 and V-4 modes, and while in manual shift mode Use premium 91 gas ever since purchase (93 not available in Bay Area)--use Costco Top Tier fuel (high volume station) Oil changed with Mobil 0-20W Full Synthetic every 5K miles religiously and OEM filters (indicator usually states 37% remaining at around 5k miles) 90/10 Highway/City driving  
      Any thoughts? My MPG is seems close to normal. Lifetime average of 17, most of my time driving is short city trips or long highway driving with a bed full of gear and a dirt bike. 
       
      Some of the actions seem like it could be a noise related to the vacuum pump but the pump doesn't exhibit any noises itself. Sounds kind of like exhaust leak--exhaust seems to check out (no notable soot around connections or along piping that is visible). If it was something loose, I would think that even under deceleration (letting off throttle) would cause the noise to persist. It follows increasing RPM. 
       
      I've checked around the footwell and haven't noiced any plugs missing or issues there. The fact that the sound is not there when cold or after some bumpy roads makes me think something else is up. 
       
      Thoughts? Things to check? 
       
      When it is quiet, this truck is wonderful. The ticking in the background that comes and goes is like a form of Chinese water torture. The fact that it does go away sometimes makes me even crazier as I know it could be better. When I bought it, it did not make this noise. Only after 700 miles of driving did it begin to tick tick tick away. 
       
       
       
       
       
       
       
       
    • By ObscureGlock
      Hey all! Hope everyone is having a wonderful Monday morning. I’m reaching out to y’all because i purchased my 2014 Silverado 5.3 used, with 76k highway miles. From purchase, it had a decently loud engine, which after reading some posts about direct injection and the oil delivery of these engines, thought it was normal. But after comparing engine sounds to other 2014-2016 5.3 engines, I’ve come to the realization that my engine is obviously not operating the way it should be. 
       
      My transmission acts up a bit, but that’s GM transmissions... I’ll have it checked out when I take it for a warranty service.
       
      Anyways, I wanted to hear what you guys think on this topic. I can’t seem to figure out what the whining is from, and why it’s incredibly quieter on other trucks. Maybe my (part that produced the whine) needs to be replaced? I don’t know what it is. My starter grinds sometimes and it’s a nasty sound, but I heard starters aren’t covered under warranty. Then, I noticed, if I get on the pedal and let off, there’s a chirp...I have no freakin clue what that is, so any insight on that helps. Next up is my lifters. I have to definitely get new lifters, and I heard that the lifters go bad after many miles thanks to the B.S. AFM. Once I get the full service I’ll be tuning out the AFM. 
       
      Then, finally, is my driveline. I get almost like a “clunk” somewhere along the driveline towards the end when I’m coming to a stop, and going... I think it might be my UJoint.
       
      Thank you guys for any input you leave, it’s greatly appreciated.
    • By th3r00st3r
      My engine is ticking and it seems to be getting louder. I read up and the Direct Injection ticking being noisy, but does this sound right?
       
      https://photos.app.goo.gl/ge3qqYU9YrzvPx3l2
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    218,862
    Total Topics
    2,347,279
    Total Posts
  • Member Statistics

    203,732
    Total Members
    8,960
    Most Online
    Benjamin Henderson
    Newest Member
    Benjamin Henderson
    Joined
  • Who's Online   13 Members, 0 Anonymous, 578 Guests (See full list)



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.