Jump to content

RCORBETT

Problem with iphone 7 and bluetooth 2014 Yukon Denali

Recommended Posts

iphone 7 with iOS 10.3.3 pairs ok. But needs to use Siri voice command to make a call. Paired ok, connects ok, but when calling, car Bluetooth first shows my cell phone number on dash then voice says "call ended". But then after 2 or 3 second delay, connects to the desired number (shows on dash). The call goes through ok.

 

Cannot use call button on car, must use Siri. The "end call" is distracting, obviously.
When it first happened, I ended the call, but after a couple tries, I found that the call will go through.

 

I deleted pair and re-paired several times after turning off car completely and rebooting phone.

 

Is this car's glitch, or the phones?

Share this post


Link to post
Share on other sites

I've owned most of the iPhones. I got the 7+. To me the iPhone 4 was a better phone !

 

What a pos this 7 is ! Can't wait for the 8's to come !

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

There was allot of updates for the radio in the 14's I had four done on my 14 when I had it.

 

If you have any warranty left I would go in and make sure it has all of the updates.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.