Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
JoeyCreech

2015 GMC Denali Driverside Daytime running lights not working

Recommended Posts

My driverside running lights work only when the truck is automatic started. When the key is inserted they go off. I was wonder had anyone else ran into this problem. Thanks in advance

Share this post


Link to post
Share on other sites

Running lamps only come on when the headlights are on - or in the case of remote start - or when the parking lights are turned on manually.

 

So to test things - use the light control knob to turn the parking lights on and off - make sure that all the lights go on and off with this control.

 

They should also go on with remote start - and go off when the key is turned on - during daylight hours -but remain on at night.

Share this post


Link to post
Share on other sites

Take it in.

 

Let us now what they find.

Share this post


Link to post
Share on other sites

I have the same problem on my 2015 silverado. Right side works great. Left side drl not coming on. Lights work fine at night, but the drl only works on the right side. Has anyone found a solution to this problem? 

Share this post


Link to post
Share on other sites

To follow up on this, the instructions said to tie into one side and run the wire to the other headlight. This was causing the drls not to work on the far side. I ended up tying into the key on power on both sides and that solved my problem.

 

Hope that helps

Share this post


Link to post
Share on other sites

I've seen a ton of GM's driving around with one drl on, including my own 2009 CTS I used to have. 

Share this post


Link to post
Share on other sites

Same problem here with a 2014 Silverado. The automatic control lights are only working on passenger side. Did you get it fixed creech?

Share this post


Link to post
Share on other sites
On 8/4/2018 at 9:40 AM, cdh027 said:

I've seen a ton of GM's driving around with one drl on, including my own 2009 CTS I used to have. 

GM's 'signature' look for the last 15 years or so...

 

(once they get some time/miles on them)

Share this post


Link to post
Share on other sites

Whats crazyier. The automatic control lights are now using the same bulb as the signal. The signal works so it's not the socket. Makes no freaking sense. 

Share this post


Link to post
Share on other sites

The signal and the running lights are the same bulb, two filaments inside. I had one that wasn't working, replaced the bulb and now it works. If one hole side is out it could possible be a fuse but if the blinker works on that side then it's probably the bulb.

Share this post


Link to post
Share on other sites

2015 2500 SLE drivers side drl was out. Blinker would work but not the drl. I changed the bulb and it works again but the right side drl stopped working right after changing the left. Maybe a bad fuse? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.