Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Recommended Posts

Got oil change yesterday, after that it tells me drivers door open, interior lights work, windows do not let down from drivers control, but will on other doors from their switch, and horn doesn’t blow when locking doors with remote.

Link to comment
Share on other sites

If im not mistaken the drivers window switch is like a small module and has a logic internal to it that also controls the door ajar message to the cluster. This thing may just need the window switch. Only saying because I ran into this before.


Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Okay, I verified with a schematic, the drivers door ajar message is controlled through the window motor, the motor has an internal logic that control this message from the BCM to the IPC. Get the motor changed, it should fix it.

 

 

Sent from my iPhone using Tapatalk

c0d1d7960558bc078c2975b963ba7a19.jpg

Link to comment
Share on other sites

  • 3 months later...

Just had this happen to my 2014 silverado (102,000 miles) but on the rear drivers side door (crew cab).  had to flip my dome light switch to off as it stayed on ciontunously.  dismiss the warning on the dash every time i start the truck, the horn does not sound when remote locking nor do the headlights flash.  Upon dealer diagnostics they found the wiring harness to be damaged inside the sheath with four broken wires after taking the door panel off.  (door ajar warning, lights and horn not working on remote lock, and also that the power window would not roll down)

$148 for the diagnostics and going to be another $250ish for the repair when they can get the wiring harness.  GM is currently out of stock.  Hmmmm?  sounds like i may not be the only one.

The door switch itself is fine.

Hope this helps others with the grief I experienced.

Link to comment
Share on other sites

  • 4 weeks later...

Hi

On 2018-06-28 at 6:39 PM, singleup said:

Just had this happen to my 2014 silverado (102,000 miles) but on the rear drivers side door (crew cab).  had to flip my dome light switch to off as it stayed on ciontunously.  dismiss the warning on the dash every time i start the truck, the horn does not sound when remote locking nor do the headlights flash.  Upon dealer diagnostics they found the wiring harness to be damaged inside the sheath with four broken wires after taking the door panel off.  (door ajar warning, lights and horn not working on remote lock, and also that the power window would not roll down)

$148 for the diagnostics and going to be another $250ish for the repair when they can get the wiring harness.  GM is currently out of stock.  Hmmmm?  sounds like i may not be the only one.

The door switch itself is fine.

Hope this helps others with the grief I experienced.

Hi singleup, I have a 2014 1500 High Country with 168,000 kms on it, giving me the exact same problem. Are you referring to the wiring harness located in the accordion style boot between the door and the frame of the cab? 

Or is this only accessible by taking the door panel off? 

Really would rather not go to the dealership on this any info would be a great help.

 

Thanks

Link to comment
Share on other sites

That’s where the wires were either broken or the sheathing was exposed.  After looking at the old harness, I think that the wires could have been soldered or taped up if still in tact.  Not sure how they get or got pinched through that boot but that was definitely the problem area.  It’s a big harness so if you can get at it through that area, you might have a shot at it.  Researched for a long time with no answer and hope this helps.  Good luck.

Link to comment
Share on other sites

I had an older car about 30 years ago.  Was having problems with windows and other things.  Turned out the wires in the drivers door were all in a state of disrepair.  Some were broken, some had a few strands broken, some just had the insulation cracked.  Redid all wires and problems were gone. 

Jim

CYWG

Link to comment
Share on other sites

  • 3 weeks later...

Did this get resolved? My 2015 is having the same issue. Checked the harness and power seems to be getting to both the switch and the window motor.

 

Also I swapped the switches out for the ones from a buddies truck. No change.

 

Help please.

Edited by kmyndiuk
Link to comment
Share on other sites

  • 2 weeks later...
On 2018-03-10 at 8:26 AM, 205harleyman said:

Got oil change yesterday, after that it tells me drivers door open, interior lights work, windows do not let down from drivers control, but will on other doors from their switch, and horn doesn’t blow when locking doors with remote.

 

Hi, I am having the same issue in 2015 1500, did this issue with your door get fixed? What was the cause? Thank you

Link to comment
Share on other sites

On 2018-08-13 at 3:52 PM, kmyndiuk said:

Did this get resolved? My 2015 is having the same issue. Checked the harness and power seems to be getting to both the switch and the window motor.

 

Also I swapped the switches out for the ones from a buddies truck. No change.

 

Help please.

 

Did you end up fixing or finding out the cause for this problem? Thank you 

Link to comment
Share on other sites

15 minutes ago, Chevy9 said:

 

Did you end up fixing or finding out the cause for this problem? Thank you 

Have a new power window motor on its way. Hopefully get it replaced on Saturday, will update then.

Edited by kmyndiuk
spelling
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Apache32Bravo
      Bought this vehicle brand new. I love it, and perfect for myself, my family, and the fact it's Diesel puts the cherry on top for me. But... now things have started. We have currently 1,137 miles on the vehicle and had the first message populated:
       
      - Service steering column lock. (see photo)
       
      Everything else worked, remote start, standard start, and the vehicle had zero issues. The following day from our road trip, we had to go to the DMV with our out-of-state paperwork to submit for plates. My wife now received a new message. 
       
      - Service emissions system. See owners manual. (see photo)
       
      She drove to the DMV and left to get the smog paperwork. Then a new issue: 
       
      - Vehicle remote start isn't working. (see photo)
       
      She is in the car and tries to start... Nothing. She tries again. It starts, and she drives it to a local dealer. They come to look and scheduled us for an appointment. She drives the vehicle now, and Onstar now shows the emission issue. ( see photo ) We now can't register the vehicle in California, because, the check engine light is on, emissions warning, and they won't smog it until it's corrected. 
       
      Awesome... 
       
      I noticed that none of these issues happened until it updated the software in the vehicle. I'm hoping this is something that can be fixed. I've been looking around for answers and only finding more issues that are all pretty shitty. Sorry, no better way to say it. I've also seen a post of people saying, “deal with it, it's a new breed of vehicles,” etc. I’d challenge that answer. No one should pay this much for a vehicle and face these issues I'm reading about. 
       
      So here's what I'm going to do, document everything, and I mean everything. This will be for everyone who may have this issue now or who may come across it. 
       
      My opinion...but I'm not a mechanic, is that there is a massive software and hardware issue with these models. I believe GM internally has to know about this from Dealers, Customer Service, Compliance Reports, etc. I'm sure all issues are in the queue to be address or fixed. I do, however, feel with the challenges of physical hardware that they chose a vendor that was most cost-effective, which is a component of these issues a long with the capability to support the software complexity of the current models. 
       
      Or maybe I'm just wearing a tin hat, who knows. 
       
      So, I open this up to you. Any advice, similar issues, outcomes you've faced, and other topics, please comment below. 
       
      May the journey of dealership visits begin. Hopefully, this journey isn't to long. 



    • By BlaineBug
      Sold
    • By Tyler Sywykk
      My issue is a little bit different however none the less an annoying one. So yesterday i bought some led bulbs off amazon to replace the dome lights in my truck, i got them opened them up all looks good and then go to put them in, and as i did they turned on not an issue however they where to small so i have to return them, i put the old one back in and not lights in the dash and dome lights are acting up. So it was the left front one i tried it in and took it back out no others. Now none of the lights turn on by the button inside the truck. (door lights and turning them on by the small switch which turns them all on works just fine. when the door is open i can now turn the light off by pressing the button. now those issues are a little less of a bother to me, however the radio (which still works perfect) now has no lights, same with the driver info center buttons 4wd actuator light and the lights on the steering wheel lights. All the buttons however still work perfect it is just the lights. Any help is much appreciated !
       
      Truck is a 2008 GMC sierra 2500HD SLE Diesel crew cab long box
    • By JayTrailBoss
      My wife and I were going to have a picnic by the ocean so went on a sandy (beach sand) road, meant for off road vehicles only. I switched to 4 Hi and while drove in the sand at less than 10mph. After about 5 minutes or so I had warnings of "service ESC" and "steering assist is reduced, drive with care". The truck, which is a 2019 Trail Boss, performed fine and I did not notice any difference in handling. I tried taking off the traction control, putting the truck in park, shutting the truck off for a while, but still the lights stayed on. The lights went off after driving about 5 minutes in 2 Hi. I also recieved emails from OnStar "there is an issue with the ABS system" and "there is an issue with Stabilitrack traction control". I don't think this is normal so it is at the dealer now. They said the initial results are the yaw sensor triggered for some reason...I don't think this is normal, the truck has 800 miles on it, but any ideas what this is or what it means? Thanks. 
    • By colsonerb
      I have a 2004 Chevy Silverado 1500 with axles off of a 1993 ford f350. The chevy had abs brakes but the for axles do not, so I have the abs wire disconected. How do I remove the service brake system message and abs warning light?
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    241.4k
    Total Topics
    1.4m
    Total Posts
  • Member Statistics

    305,141
    Total Members
    8,960
    Most Online
    patrick spires
    Newest Member
    patrick spires
    Joined



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.