Jump to content

Sign in to follow this  
Sierra_LC9

Service Stabilitrak & Traction Control - SES

Recommended Posts

I bought a Certified Pre-Owned 2010 Sierra SLE 5.3L (LC9) Vin code "3" about 3 years ago. It's stock besides a front leveling spacer on the strut, no aftermarket electrical.
The truck will intermittently go into limp mode with "Service Stabilitrak & Service Traction Control" displayed on the DIC (No SES Light).
Eventually when the CAN bus reboots the SES light illuminates. After clearing the codes it drives normal until it happens again.
I've had it happen on the freeway, in park, on normal surface roads, over bumps, doesn't seem to be a reason why or when it occurs other than outside temps.
The odd thing is it only acts up when its warmer than 60 Degrees outside, this winter she drove fine without a single hiccup. Which tells me it
might be an internal module failure...
However, I've had it happen in the same spot on the way to work several times.
When I pull the DTC's it's from modules that lost communication on the high speed CAN/LAN buss or modules requesting MIL because of no ability to communicate.

DTC's:
U0073 - Communication Bus A OFF
U0100 - Lost Comm with ECM
U0101 - Lost Comm with TCM
P0700 - TCM Request MIL
P069E - Fuel Pump Control Module Request MIL
U0140 - Lost Comm with BCM
U0121 - Lost Comm with EBCM
U0102 - Lost Comm with Transfer Case Cntrl Module

- I've replaced the battery (Optima Red Top), cleaned the terminals and cleaned Mega Fuse. Tested Alternator with a Midtronics GR8
- Cleaned the Grounds on the Front Engine Block, Fire Wall, Chassis under drivers door, front frame by radiator. (Hood to Firewall ground strap missing)
- Removed the UBEC fuse block and swapped relays, no corrosion, applied dielectric grease.
- Removed the TPA lock on the TCM/ Trans connector, checked for backed out terminals or ATF leaking. Found nothing abnormal.
- Checked the Harness from the TCM going up to the Engine Block, nothing abnormal.
- Checked EBCM connectors & harness, nothing abnormal
- Checked FPCM connectors & harness, nothing abnormal
- Replaced 120 Ohm Terminating Resistor (Twice)
- Checked ECM connectors & harness, nothing abnormal
- Checked BCM Connectors, nothing abnormal
- Checked harness on top of engine, nothing
- Using a DLC Break-out box, I have 60 ohms on PIN 14 (CAN High), but haven't been able to test when it acts up.
- I can talk to most modules with my scan tool when the CAN bus is online, if I plug it in just after the bus went down, I cant communicate and have to wait until the bus
reboots to clear the codes and get back on the road. I used to be able to clear the codes "on the fly" while driving but it seems like its taking the bus longer to reboot
as time goes on.
Just ordered new Positive and Negative battery cables, and the Hood ground (not sure why the hood needs a ground)
Could the VCIM module be bad?

The truck is pretty much babied since I've had it, I change the oil myself every 2-3k (fear of AFM issues).

Any help is much appreciated. I'm running out of ideas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • By mamboking
      Hi everybody, does anyone have any suggestions why my 2011 GMC Sierra 1500  gives me the message "service stabilitrak and service traction control"? It only happens while the truck has been sitting under the sun and the outside temperature is hot. The message does not appear first thing in the morning when I use the truck to go to work and the outside temperature is not hot yet.
    • By mountainman80901
      hey gm lovers mountain man here. ive got a 2017 gmc sierra 1500 crew cab 4x4 7" lift 35 " tires.and I am having problems/hate the stabilitrak.when I make a long angle 90 degree turn at more than 25 mph the stabilitrak comes on and I hate it.i understand how stabilitrak works and why its there.and the cables going to the wheel hubs are not tight when stand still of course. BUT is there a way to eliminate it.i kinda already have.i pulled the #3 fuse under the hood which is the antilock brake system BUT I have no cruise control and I understand why. plus the abs and stabliltrak light is on but I don't care.i still have brakes and they work fine and it DOES NOT SKID when you slam on brakes at 60mph.but what I would like to accomplish if possible if anybody out there can get there hands on a wire diagram for fuse #3 and if there is a certain wire under fuse #3 (theres 8-10) that controls only the stabilitrak that I could cut and just put a toggle switch in the cab.or if there is another to eliminate stabilitrak and still have cruise control im all ears.any questions feel free to ask thanx
    • By mark97213
      Greetings all.  I sure would appreciate any members thoughts on my ABS Traction control nightmare that I'm having, I just can't seem to get ahead on this one.  2006 Avalanche 1500 4x4 LT, 108k.

      Started out as an intermittent ABS and Traction Control lights activating with the "service stability" in the display.  They would stay on for five minutes driving down the highway, then turn off for a half hour, then back on.  All intermittently.  Ran a scanner, no DTC's.  I tried a different scanner but still, no DTC's.  Cleaned up the grounds and Decided to replace the front hub assemblies with the sensors because they're almost  the same price for just the sensors.  Still getting the warning lights on.  Replaced the rear sensors but it helped none.  So, not much left so I replaced the ABS Module.  Had the Dealer Reprogram and still... ABS and TC Lights are illuminating.

      Could air in the brake lines cause this weird abs problem?  Any help would be greatly appreciated.
    • By roadrage201
      I've got a 2012 Silverado 1500 Z71 and I'm disgusted with it. The trouble started when my 4wd would not go into 4 Auto and would barely shift into 2hi and 2lo. I received a "service four wheel drive" display. My local shop pulled the code that basically said the front differential actuator was faulty. I cant remember the exact code.. anyway, I changed the actuator (very easy fix...I thought). The problem persisted. Now, I'm not sure what prompted me to do this, but I pulled the encoder motor from the transfer case. As I was doing  this, the motor bumped into the t case and arced. This is when the lights on the 4wd knob went out. So, after that I bought a new encoder motor. I also replaced the TREC fuse. It had popped, I'm guessing, when the arc occurred. Now, after all this, not ONLY is my 4wd auto STILL not working, but my dash is lit up with the same "service 4wd system", but also the "service trailer brake system", brake light and traction control light. I got the codes read again, and it is displaying U0121, Cannot communicate with ABS controller. I have inspected the ABS controller connection for corrosion and loose fitting as well as checked ALL fuses. I tested the grounds and hot wire pins. I also tested and cleaned the chassis ground connection on the frame. All good. I suspect that the OBD2 needs to be reset but I'm not sure.  Anyone have any suggestions?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    198,928
    Total Topics
    2,111,181
    Total Posts
  • Member Statistics

    167,216
    Total Members
    8,960
    Most Online
    markt111
    Newest Member
    markt111
    Joined
  • Who's Online   52 Members, 1 Anonymous, 358 Guests (See full list)

×

Important Information

By using this site, you agree to our Terms of Use.