Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

2017 L5P high country brakes.. gripes


Recommended Posts

I am back to GM for my truck. I got a 2017 L5P High Country. I love the truck. I have a couple of gripes. The calipers have surface rust on them. I know it is surface, but I have had a bunch of trucks over the years. Never had rust on them. Not on GMC, Chevy, Toyota or Dodge. Also my brakes squeek  at low speeds.. drives me up the wall. I have asked the dealer about it...they said for Chevy it is normal??

It sounds like bad design if that is true. I want to clean up my brake calipers but it is under warranty... Do they cover this ...as it is surface??

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Henry L
      2020 Silverado 2500, have taken this truck to two different GM dealers and they cannot find an issue. At the at the 7-pin plug when the manual gain is depressed at 100%, it only puts out 7 volts. Need 12 to lock up brakes. Cannot properly set up my gain when hooked to trailer before towing. Dealership has replaced fuse block brake controller and I had them change out the plug on the bumper. Still the same. At neither dealership have they been able to give me voltage going in the controller and coming out. One even said they can't put a volt meter on it. I believe it's a wire somewhere. But due to my health issues I cannot physically work on my truck. I'm probably going to end up taking it to an auto electrician. Any thoughts!
    • By BoyBlue22
      Hey all!  I'm the proud owner of our 1st brand-new vehicle ever! this '22 Silverado HD High County is a game-changer for pulling our new camper trailer! I recently retired and found this beauty on a dealer lot near me!
       
      So... as per usual with my vehicles, I really enjoy there look of nice clean, glossy calipers peaking from behind the rims!  These wheels are not as open-spoked as others I've done, but still look great, especially when they turning miles not the highway!  I always use the brush-on G2 caliper paint.  The stuff is incredible! Here's a couple pictures in process and afterwards...
       
      Carl



    • By Snake River Wraps
      2004 Yukon Denali XL 1500 AWD
      Ok, so I have done many brakes in the past but this has me stumped. I put new calipers rotors and pads all the way around on the truck and have bled the brakes like 6 times. twice with a helper and 4 times with a bottle. All times the fluid comes out with no air but it still goes to the floor when its turned on. A small amount of push back is noticed after pumping a few times while the truck is off. But as soon as I turn it on and push its nothing. I have read about there possibly being air in the ABS module and am looking for how to bleed that with just one person and have it actually work. The master cylinder is and has been filled throughout and never dropper too low. I placed all the new parts and puller the hose off the old calipers and attached it to the new ones quickly replacing the copper washers. I just cant figure out what could be happening, any help would be appreciated.
    • By Jason Fowler
      I am new to the forum here and I apologize if this has been asked prior, I tried searching, but came up empty.  
       
      I have a 2020 Sierra 2500 Denali and for the past 5k miles or so I have had noise in the rear.  I learned there was a safety bulletin on the rear brakes due to noise, but because I was out of the B2B warranty and it was not covered and would be an out of pocket expense.  With my son in the business can do the work, so I went ahead and ordered and paid for a set of brake pads and now have been waiting for almost 3 weeks.  The dealer told me that GM is not releasing the pads (I suspect unless the dealer is doing the work) and that they have no expected date of delivery.  
       
      I'd like to stay with OEM, any recommendations on where I can locate a set would be greatly appreciated.  Or if anyone has a recommendation on a good aftermarket set of pads, that would be appreciated as well.  
       
      Rotars are no problem, I have them, just waiting on the pads.  
       
      Thanks.  
    • By NorthIdahoTexan
      Experienced a one-off braking issue while descending a 7% grade. Had driven ~100 miles, stopping as needed with no issues. Began descending about 3 miles of maximum 7% grade touching the brakes infrequently as my 2018 Silverado 2500HD Duramax does a great job of reducing speed when off the petal. No towing selector, downshifting, no engine brake engaged. I’m just about to level ground, slowly apply my brakes and HELLO! Front-end/wheels start shaking like I’m about to throw a wheel. I feather braked to a stop on a side street, checked for play in the wheels and nothing evident. Continued another 120 miles, up hill/down hill, two 9% grades and only one instance of a very light wobble.
      Suggestions/similar situations?
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    241.3k
    Total Topics
    1.4m
    Total Posts
  • Member Statistics

    304,514
    Total Members
    8,960
    Most Online
    Seif Khene
    Newest Member
    Seif Khene
    Joined


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.