Jump to content

Recommended Posts

Posted (edited)

So I am currently on vacation 300 miles from home. My truck is a 16 1500 Z71 and has about 33000 miles on it and all of the sudden driving on a flat surface grade braking will enable. The truck is also shifting randomly and violently. Sometimes when making turns in auto mode it will feel as though the 4wd system is engaged. Anyone else encounter these issues? Anyone might know what could wrong that I can fix real quick while I'm away?

Edited by Riki Knight
added truck year and model

Share this post


Link to post
Share on other sites

Sorry to hear about your situation! I haven't experienced the grade braking engaging unexpectedly, but my transmission definitely acts up. It seems to be linked to my driving style. If I grandpa around drive the truck easy like I want it to last 15 years, it shifts like dog crap.

 

Example: One road I travel home is 40mph speed limit. I let off the gas for a red light up ahead, truck speed slows to 32-35mph, light turns green so I press my foot into the pedal just slightly as if I wanted to gradually speed back up to speed limit. The trans will downshift violently and whip your neck. It seems to happen randomly at other times, but mostly 30-45 mph and around downshifts.

 

In contrast, if I drive it like a race car (100% throttle leaving corners or red lights, 100% braking into corners or stops) it shifts just magically and it's quite pleasing. It flows from gear to gear, smooth as butter. Never a shortage in power, keeping you sucked back in your seat.

 

I can't help but wonder if they tailored the transmission design to that majority of ass-hat drivers that we all see everyday. It's a shame too because that's not how I want to drive at all. I'm mostly over here trying to beat my high score fuel mileage. I did 10 under on a 5hr drive a while back and averaged 27.2mpg. The only way to beat it is to grandpa around and I don't think this pickup was made for that. Oh, I also have a 2016 Silverado 1500 6-speed. 4WD double cab LT.

Edited by rudyb

Share this post


Link to post
Share on other sites

Thanks for the reply. I do notice that the truck drives better when I drive it mad. I'm going to take it to the shop when I get back home. Yesterday it acted just fine... it's really weird. How did you manage 27mpg?! At best I get 19 on our 5 hour trip each year.

Share this post


Link to post
Share on other sites

I will def say the same if I drive it like I stole it it runs through the gears like it should. If I drive like driving miss daisy lol it’s like riding a mechanical Bull lolol.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Update for anyone with similar issues. We made it home safely but had a few more issues. I have resorted to turning off the grade braking manually by holding down the trailer button for a few seconds. I took it out of auto and stayed in 2wd mode, still turning like 4wd is engaged. Cruse control decided to automatically turn off on me randomly and also didn't work for 1/2 the trip.

 

Thanks everybody for the replys. I did not reset the computer as I want all the info there when the dealer looks at it, i dont think they will see anything though as I'm not putting out a CEL. I will be calling my dealership tomorrow. I just cant believe at 30000 miles this truck that i baby is going to crap...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.