Jump to content
  • Sign up for FREE! Become a GM-Trucks.com Member Today!

    In 20 seconds you can become part of the worlds largest and oldest community discussing General Motors, Chevrolet and GMC branded pickups, crossovers, and SUVs. From buying research to owner support, join 1.5 MILLION GM Truck Enthusiasts every month who use GM-Trucks.com as a daily part of their ownership experience. 

Sign in to follow this  
geswek

Rough Country 6” Lift Owners

Recommended Posts

Is anyone with RC 6” lift having more sensitive left turns? I have noticed ever since having my lift installed that when I make a left hand turn at my normal usual self traction control engages and I start feeling that pulsing in pedal—and I lose throttle.

 

I have checked the wiring to see if maybe it was pulling on the sensor but that wasn’t it.

 

RC was no help and neither was installer.

 

It just seems odd that I can make left turn off a light and at casual pace I’m tripping the system.

 

Truck is tuned for the tire size as well.

 

8f9ed65093dc0f80cab97f56530f0f6a.jpg

 

 

Sent from my iPhone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

This happens to mine also...ive been told its an alignment issue...ive never had it in yet to see if thats the cause. Let me know if you figure it out!

Share this post


Link to post
Share on other sites
This happens to mine also...ive been told its an alignment issue...ive never had it in yet to see if thats the cause. Let me know if you figure it out!


Interesting...

Truck was aligned when the lift was installed by the same shop.

I contacted RC because it’s driving me up a wall.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Isn't there something in the BCM that needs to be reflashed to accommodate the higher center of gravity or roll angle or something? Similar situation in lifted previously owned vehicles, not sure with these trucks.

Share this post


Link to post
Share on other sites
Isn't there something in the BCM that needs to be reflashed to accommodate the higher center of gravity or roll angle or something? Similar situation in lifted previously owned vehicles, not sure with these trucks.


I have no idea.

I have a tune from Diablew for my 35’s and 4.10 gear. I don’t know if there is anything for center of gravity. However I can’t even run stock anymore since I have different gears. Truck goes into limp mode.

I had this issue long before I changed my gears.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
21 hours ago, geswek said:

 


Interesting...

Truck was aligned when the lift was installed by the same shop.

I contacted RC because it’s driving me up a wall.


Sent from my iPhone using Tapatalk

 

I also had mine aligned by the shop that did my lift.  Was told i needed to change tire size with programmer which didnt solve the problem and cost me more money.  It is super annoying and have been living with it for 2 years now

Share this post


Link to post
Share on other sites

This seems to be an issue on some lifted trucks and not others. Some only have a 4" lift and have the issue others have a 10" lift and have no issues. I have no problems with my 6" BDS lift. I believe it has been determined that the cause is the yaw sensor needs calibrated. I have no clue why it happens on some trucks and not others, I believe you can search and find a few topics on the same/similar issues.

 

Sorry I am not of more help, I've never dealt with it personally.

Share this post


Link to post
Share on other sites

I just read a 10 page post from 2015 regarding this issue. Several people said their alignment was off and it was enough to trip the sensors. I’m going to take truck to another shop and ask them to check it. I’ve had issues with the company that did lift in regards to alignments.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 15/06/2018 at 9:59 PM, geswek said:

 

Is anyone with RC 6” lift having more sensitive left turns? I have noticed ever since having my lift installed that when I make a left hand turn at my normal usual self traction control engages and I start feeling that pulsing in pedal—and I lose throttle.

 

I have checked the wiring to see if maybe it was pulling on the sensor but that wasn’t it.

 

RC was no help and neither was installer.

 

It just seems odd that I can make left turn off a light and at casual pace I’m tripping the system.

 

Truck is tuned for the tire size as well.

 

8f9ed65093dc0f80cab97f56530f0f6a.jpg

 

 

Sent from my iPhone using Tapatalk

 

Ok....so.....i broke down and decided to buy the hypertech speed caliberator and it has completely fixed the problem!! Ive drove it this way for a week now with no more issues with stabilitrak coming on and making it harder to turn corners! 

Hyper732501 was the part number for the 2014 gmc. 

Share this post


Link to post
Share on other sites
Ok....so.....i broke down and decided to buy the hypertech speed caliberator and it has completely fixed the problem!! Ive drove it this way for a week now with no more issues with stabilitrak coming on and making it harder to turn corners! 
Hyper732501 was the part number for the 2014 gmc. 


Hmm, I have a custom tuner and the tire size change was already set. I still have issues making lefts. It’s not as sensitive as it was before; had the alignment done again.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
6 minutes ago, geswek said:

 


Hmm, I have a custom tuner and the tire size change was already set. I still have issues making lefts. It’s not as sensitive as it was before; had the alignment done again.


Sent from my iPhone using Tapatalk

 

I had bought a tuner (bullydog gt) as i thought why buy the hypertech that had next to no features when i can buy the BD and chnage and adjust all kinds of settings. I broke down and thought it cant hurt to try it.  I now have a bullydog tuner for sale.  When i talked to the guys that installed my lift they said for whatever reason the only tuner that works with these lifts is the hypertech

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.